[Browser]There is an invalid back icon at left side of address bar.

REOPENED
Unassigned

Status

Firefox OS
Gaia::Browser
REOPENED
3 years ago
2 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2 nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8628180 [details]
logcat_0503.txt

[1.Description]:
[Flame v2.2 & master][Nexus5 v2.2 & master][Browser]If user opens forget FXA password page and send a mail,then try to back to the most previous page, they will find there is an invalid back icon at left side of address bar.
Found time:05:03
See attachment:logcat_0503.txt & video_0503.3gp

[2.Testing Steps]: 
1.Open Settings -> Firefox Accounts.
2.Input an existing email and go to password page.
3.Tap "Forget your password".
4.Tap "Next".
5.Tap "<" icon.
6.Tap ">" icon.
7.Tap "<" icon.

[3.Expected Result]: 
7.No back icon is at left side of address bar.

[4.Actual Result]: 
7.There is an invalid back icon at left side of address bar.

[5.Reproduction build]: 
Device: Flame 2.2 version(Affected):
Build ID               20150630162500
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150630.200238
Firmware Date          Tue Jun 30 20:02:49 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master version(Affected):
Build ID               20150630160220
Gaia Revision          5997b406e77ea726fbd9047057a1c3504f6cd6d4
Gaia Date              2015-06-30 01:48:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/291614a686f1
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150630.193722
Firmware Date          Tue Jun 30 19:37:34 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Affected):
Build ID               20150630162500
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150630.200214
Firmware Date          Tue Jun 30 20:02:30 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_master version(Affected):
Build ID               20150630010206
Gaia Revision          27fe0f4261e3685187769411f2f74cff19287b19
Gaia Date              2015-06-29 14:29:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/aad95360a002
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150630.042823
Firmware Date          Tue Jun 30 04:28:43 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free test
(Reporter)

Comment 1

3 years ago
Created attachment 8628181 [details]
video_0503.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
This is not a bug. The settings launches browser when user clicks 'forget your password'. At first page, there is no '<'.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

3 years ago
In this case, "<" icon will mislead the users that they can return to settings/home page via tapping "<",but this function is not actually implemented.So I think device should back to settings/home page in this case or  “<” icon  should be removed .
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I still do not think it is a valid bug.

However, a better way might be that the transition animation (Settings->Browser) time can be longer after user clicks 'forget your password'. It has a benefit that user can see the browser log at the animation and then know he/she is not using Settings app.

I think we need UX input here, but not sure who is current owner.

Helen, could you help here?
Flags: needinfo?(hhuang)
I'm going to need info Eric who is the visual designer of Browser.

Hi Eric, can you take a look this bug?
Flags: needinfo?(hhuang) → needinfo?(epang)
The UX flow of these screens feel really odd to me..

1. When the Reset Page loads
There is no way for the user to go back or cancel (only a next button). I Feel like there should be a ‘Cancel’ button that brings the user back to settings.

2. The user presses next and back button appears (in the chrome)
When they go back there is now a forward arrow in the chrome and next button with a back button underneath on the site's screen

Buttons sometimes seem to be missing while at others times being duplicated (in the chrome and on the site). The user should have the option to go back and forth but only in one consistent area.  My recommendation would be for it to appear on the site if possible and removed from the chrome.  Francis, what do you think?
Flags: needinfo?(epang) → needinfo?(fdjabri)
> 1. When the Reset Page loads
> There is no way for the user to go back or cancel (only a next button). I Feel like there should be a > ‘Cancel’ button that brings the user back to settings.

This isn't a bug. The forgotten password link is just a hyperlink to a web site which opens in a new browser window. If you want a back button in the forgotten password screen which goes back to the previous screen we'd need to build some forgotten password UI into the app itself, or maybe add a close button which closes the browser window.

> 2. The user presses next and back button appears (in the chrome)
> When they go back there is now a forward arrow in the chrome and next button with a back button
> underneath on the site's screen

It's just a browser window, the back and forward buttons appear when there is back and forward history.

Firefox OS does not have a universal back button like Android which both goes back in browsing history and goes back to the previous window you were using. In order to go back to the previous window you can swipe from the left edge of the screen though.
There does seem to be a bug at second :51 in the video. The user presses the forward button but the user is not taken forward in their history and yet a back button appears - this is the confusing part. Otherwise, the video appears to work as it's supposed to. I do feel that we could make cross-app transitions more obvious, but this is somewhat tangential to this bug.
Flags: needinfo?(fdjabri)
You need to log in before you can comment on or make changes to this bug.