4x-Scriptable plugin sample not work

VERIFIED WORKSFORME

Status

()

Core
Plug-ins
--
major
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Ahmed Abdullah, Assigned: av (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I'm working on a web-based project for IBM which intended to support all types 
of browsers (I.E & Netscape).
The work includes a plugin for Netscape that contains functions to be called 
from Java Script.
The plugin works properly for Netscape v.4.0 ,v4.78 and v.6.0.
When I use the plugin with v.6.1 and v.6.2.
The plugin fails.
so I investigated in that issue and found that the architecture of Plugins 
changed in those versions.
I downloaded the sample plugin from Mozilla site (modules/plugin/samples/4x-
scriptable)
Compile it using Mozilla environment.
Put it in plugins directory of Netscape.
Launch Netscape.
The Javascript calls didn't work and produces Javascript errors 
(function xxx not found)
I use the same plugin with Mozilla Browser (v.0.9.7) it produces the same 
error .

What can be the cause of that problem and how can I resolve it,or is it a known 
bug.

This problem is urgent for my work,and if not solved as soon as possible The 
product will not support the new versions of Netscape.

Thanx for your help,

Yours,
(Assignee)

Comment 1

16 years ago
Did you create an .xpt file?

Comment 2

16 years ago
works fine for me on winNT using 6.2.2 . Build the dll and xpt today. 
tested using this test:
http://lxr.mozilla.org/seamonkey/source/modules/plugin/tools/sdk/samples/scripta
ble/test.html

Comment 3

16 years ago
Created attachment 76308 [details] [diff] [review]
add REQUIRES into makefile.win

build failed w/o REQUIRES

Comment 4

16 years ago
WFM w2k debug 20020324 build
http://lxr.mozilla.org/seamonkey/source/modules/plugin/samples/4x-scriptable/tes
t.html
(Assignee)

Comment 5

16 years ago
I verified that scripting is working using SDK samples. REQUIRES already added
there, so it should compile as is.

Comment 6

16 years ago
marking bug as WFM based on shrir's, serge's, and av's comments.
anthonyd
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.