MailNews hangs when going off-line

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: GA, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Hello Mail / News --

1) Select Inbox for offline sync.  close app.
2) open mozilla (broswer opens first for me)
3) open mail/news (IMAP over SSL)
4) view couple msgs (cached to local)
5) click on connection pipe for off-line (lower right)
6) select don't download
7) close Mail/News window (browser still open)
8) brower is non-responsive with graphics frozen from earlier Mail/news pane.

Bld #2002010103

Updated

16 years ago
Severity: normal → critical
Keywords: hang
Summary: Mail/News Hang when going off-line → MailNews hangs when going off-line

Updated

16 years ago
QA Contact: esther → gchan

Comment 1

16 years ago
Using commercial trunk 2002010203 on NT 4.0

Reporter this is what I did following your steps to
reproduce:
>3) open mail/news (IMAP over SSL)
    Made sure that in Preference section under Server Settings for
    my IMAP mail account, I checked the pref 'Use secure Connection (SSL)'
    I then quit the application and restarted. When I logged into my
    imap account, I was prompted for my cert and I can see the mail
    server in the folder pane with the padlock on it.
>1) Select Inbox for offline sync.  close app.
  Clicked 'Select button' from Offline&DiskSpace preferences and
  Went to the Items for Offline Usage window and checked the inbox
  folder. Then quit the application.

>2) open mozilla (broswer opens first for me)
    Started browser, then messenger and logged into my imap mail acct.
>4) view couple msgs (cached to local)
>5) click on connection pipe for off-line (lower right)
>6) select don't download
>7) close Mail/News window (browser still open)
>8) brower is non-responsive with graphics frozen from earlier Mail/news pane.

What do you mean in step 8 by Browser non-responsive? If you mean
you can't click on links, change to another web page, than yes that
is supposed to happen. When you disconnect the 'connection pipe for off-line'
in the messenger window, you ALSO disconnect it for the browser to.
Notice the in the lower right hand corner that offline icon is disconnected.
You should have access to previous cached web pages, hit forw/back buttons 
(assuming cached pages), access to the menu items, etc.. But in
terms of changing web pages/links no access until you go online.

Am I misunderstanding something?

thanks.


(Reporter)

Comment 2

16 years ago
hello again -- per your question on what I mean by "non-responsive".  I mean: 
"application is un-responsive to end-user control and must be killed via win2k
task manager".





Comment 3

16 years ago
Using 2002010303 on NT 4.0 I still don't see this problem.

When I close messenger (clicking the x button in right top
corner), the window does not hang. Browser is responsive.

Tried both a migrated and new profile.

Reporter does this always happen everytime or just once? 
Have you tried today's build?
New profile?

I am afraid I might have to mark as works for me unless
I can replicate this problem.

thanks.
(Reporter)

Comment 4

16 years ago
hello -- with latest mozilla build #2002010303

I filed the suspect msg into subfolder (per IMAP).   Mail/News continues to core
immediately upon access.  Same file, different location, same result.  

This is not ambiguous, nor up to interpretation.  

Talkback ID# TB1312013Q  -GA

Comment 5

16 years ago
Reporter,
You mentioned 'suspect msg'. So it's problem with a particular mesg
and not directly related to closing messenger then? I'm confused. 
You didn't mention the 'message' in your steps to reproduce. maybe that's
why I can't reproduce the problem.

Also I couldn't find your talkback report (wrong id?) but I did
search by your email address. And judging by dates/times
you had problem with a mail mesg. Is this the stack trace:
nsPluginStreamListenerPeer::OnDataAvailable 8a8e2d36

Was it this talkback id: 1212013 on 2002-01-03 at 19:24:36 that
your problem occurred?

So Can you be little more descriptive in describing the problem?
Is it reading a certain mesg while offline? Is it closing messenger
while offline?

What is unique about that mesg? Attachments? URL? 

Do you have problem reading the message while online?

Any special plugins we should know about?





(Reporter)

Comment 6

16 years ago
apologize for my recent update -- it was for completely different issue (bug
#117911 -- ref this bug # for correct talkback ID).  

Anyways, I did verify the steps to replicate Mozilla hang that I initially
posted.  Here's another recap with additional comments:

1) MailNews:  Select Inbox for offline sync.  close Mozilla application.
2) open mozilla (broswer opens first for me)
3) open mail/news (IMAP over SSL)
4) view couple msgs (cached to local because of offline setting in prev step)
5) click on connection pipe for off-line (lower right corner of MailNews)
6) select "NO" to prompt to "download mail for off-line" when click pipe.
7) close Mail/News window (browser still open behind MailNews from beginning)
8) brower is non-responsive with graphics frozen from earlier Mail/news pane.

Reference desktop screenshot.  This happens _every_ time.  
http://www.garretta.com/horked-mozilla1.jpg

I've tested with newer build #2002010303.  Thx -GA

Comment 7

16 years ago
Reporter, with 2002010703 commercial trunk build on NT 4.0
I am still not seeing this problem.

There have been some general problems with outliner, etc..
Fridays build (1-4) where I wasn't doing what you described but
the messenger would freeze and be unresponsive and I'd have to
kill it with the task manager.

There is a problem with todays build and using a 'migrated' profile.

I take it you haven't tried this with a new profile?

IMO this isn't a offline issue as I think other problems are
causing what you see.
(Reporter)

Comment 8

16 years ago
Hello MailNews -- Per debug suggestion, I attempted to read "suspect" msg from
newly created profile.  As before, I experienced an immediate crash upon click
on msg in MailNews (again, via IMAP over SSL).

Talkback ID#  TB1366603X

Comment 9

16 years ago
Reporter you are confusing bugs again. Your last comment
was for bug 117911 not this bug.

Anyways, I still can't reproduce your crash. If you are offline
and you selecting the mesg that crashes for bug 117911, maybe
that's why it hangs for offline.

I would suggest creating a new profile. 
(Reporter)

Comment 10

16 years ago
Doah ... sorry about the mis-read on bug#.  

Per suggestion, I tried the off-line senario described below with _NEW_ profile
and experience NO hang.  While I'm relieved to not experience problems on the
new profile, this isn't really a "solution" in my mind (though it is from
dealing with Netscape enterprise/e-comm tech. support ... ha).   

I can't help but wonder what the issue if with existing profile that causes the
problem.  I plan to migration prefs.js, abook, and bookmarks to new profile.  If
I experience similar probs with new profile, I'll report back. 

Otherwise, closing bug for now (closing as "worksforme" because I really don't
consider this "fixed").  Thx for your patience. -GA  

 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
I have had this bug *once*.
(Mozilla 20020530 build, win 98.)

When this happened to me,the following also occured:
The "Dial up connection" window was up. I wasn't connected to the internet,
(Although mozilla was on-line).
When I closed the dialup conection window, mozilla became responsive.
Another dial up window appeared.
I clicked cancel on the new dialup window,
Mozilla was now unresponsive again!
What's more IE6.0 wouldn't start either.
Once mozilla was killed IE appeared!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.