Why does the old font size=?? and the new css font-size : ?????? render differently

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Ian Christie, Assigned: dbaron)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I hope I have this in the right section.

I notice that this old problem (goes back to Netscape 4.xx) seems to still be
around.

If I use the old html way of setting font size, <font size="4"> and compare it
to using css font-size : medium ,   why does the css size render smaller?

Shouldn't they be the same size?

Assumed equivelants

Font size=   Font-size :

    1         xx-small
    2         x-small
    3         small
    4         medium
    5         large
    6         x-large
    7         xx-large


Take a look at this page http://www.800line.com/~ichristie/sizetest.html for a
complete comparison
No they shouldn't. 

In HTML, the default font size is 3.
http://www.w3.org/TR/html4/present/graphics.html#edef-FONT
The BASEFONT element sets the base font size (using the size attribute). Font
size changes achieved with FONT are relative to the base font size set by
BASEFONT. If BASEFONT is not used, the default base font size is 3.

In CSS, the default is medium.  So obviously things don't map properly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Correction, we do display the font sizes properly, I meant to say they don't map
as you expect them to.

Random article: http://www.alistapart.com/stories/sizematters/
(Assignee)

Comment 3

16 years ago
Yep.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

16 years ago
Sorry to have bothered you with it, just seemed to me that even though the CSS 
basefont is medium, that should be larger than the old base font of 3. Using 
medium as the same size as font size 3 makes xx-small so small it is virtually 
un readable. Also Opera (around the 98% compliance) and IE render the xx-small 
to xx-large the same as 1 to 7 respectivly. It would be nice to not have to 
maintain multiple style sheets because of different interpretations of the 
standard.

Here's another interpretation, based on what I've read in the replies, basefont 
of the old Font size method was 3, might be a little small, so make the base 
font 1 step up, from the css equivelant (small) to medium (4). Makes more sense 
than making medium equal to size 3, therefore making xx-small equal to the non 
existing size=0.

Besides it would be nice to not to have to force viewers using Mozilla/NS 6 to 
squint, or maintain two otherwise identical style sheets.

I appologize for my rant, I thought originally that this might have been a 
small bug, I would love to switch permenantly to Mozilla and get away from IE, 
but when text on pages that display normally in IE (text size of smaller) are 
almost unreadable in Mozilla/NS 6, it drives me around the bend, especially 
when I'm trying to make pages viewable by many people and are easy to modify 
(no html font tags please), I just have to bring it up.

Sorry again for the rant

Ian Christie, the link I gave in comment 2 is a perfect article for you to read.
 It addresses your concerns.
(Assignee)

Comment 6

16 years ago
There is no question that 'medium' should be the default, and there is no
question that 3 should be the HTML FONT default.  There have been a number of
interesting discussions on how to do the rest.  I suggest you read Todd
Fahrner's proposals (I'm not quite sure where to find them now), which are very
clearly thought out and which we have roughly followed.
You need to log in before you can comment on or make changes to this bug.