Font rendered too small--style attr to DIV ignored?

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
--
minor
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: Rob Anderson, Assigned: Kevin McCluskey (gone))

Tracking

({pp})

Trunk
Future
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; FreeBSD i386; U;) Gecko/0
BuildID:    20020102

If you go to http://www.seattletimes.com/, the main heading--the first article
heading, that is--is always rendered in a tiny size. The face of the font is
correct (the Seattle Times puts its headings in--you guessed it--Times Roman)
but the size is way too small. Today it is supposed to be an 18 pt font.

The difference between the main heading and all subsequent headings is that the
main heading has its style adjusted using a DIV tag which contains a STYLE
attribute. It seems this attribute is being ignored. Interestingly I tried
swapping the DIV with a P, and the style attribute was still ignored. But if I
removed the STYLE attribute from the DIV tag and added a SIZE attribute to the
adjacent FONT tag, the main heading was rendered correctly. All other headings
are styled with a FONT tag containing a SIZE attribute--not with a DIV tag w/ a
STYLE attribute--and so these headings are correctly sized.

I am using True Type fonts.

This page is rendered "correctly" in M$ IE. The page doesn't look like very
standard HTML, mind you.

Reproducible: Always
Steps to Reproduce:
1. Just go to the seattletimes.com page.


Actual Results:  Font looked tiny.

Expected Results:  Font should have been bigger--a full 18 points.

Comment 1

17 years ago
Seems quite normal to me on 2002010203, Win98. Is this a font problem in your
machine ? There is a known bug about Arial fonts on Linux, see 0.9.7 release
notes or bug 46415. It might be related.
(Reporter)

Comment 2

17 years ago
I tried this on two different FreeBSD machines, and neither worked. It would be 
helpful to see if this works on Linux. I do think this is a problem with the 
FreeBSD implementation of Mozilla, however, since I can set the SIZE attribute 
of the FONT tag, and see the correctly-sized font in my browser.

Comment 3

17 years ago
Confirming issue in the Linux 2002-01-10-08 build.
Status: UNCONFIRMED → NEW
Component: Compositor → Layout
Ever confirmed: true

Comment 4

17 years ago
Here is the code the specifies the div:

<div style="font-size:15pt"><font face="times new roman, times, serif"><b><a
href="/html/nationworld/134389318_war100.html">7 Marines die in plane crash,
including Washington man</a></b></font></div>

(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
WFM in a current Windows trunk build.
Component: Layout → Layout: Fonts and Text
Keywords: pp
WFM as well.  Marking so; please reopen if this is still an issue (and attach a
HTML page showing the problem to the bug if so).
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.