imap maildir folder has false excess unread message count in folder pane

RESOLVED FIXED in Thunderbird 43.0

Status

MailNews Core
Backend
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rkent, Assigned: rkent)

Tracking

Thunderbird 43.0

Thunderbird Tracking Flags

(thunderbird40 wontfix, thunderbird41 fixed, thunderbird42 fixed, thunderbird43 fixed, thunderbird_esr3841+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
One of my folders has an unread count in the folder pane that shows 37 unread messages more than are actually there. I have not been able to get rid of it. The count is correct on restart, but the first time I click on the folder it adds the extra false unread message count.
(Assignee)

Comment 1

2 years ago
Here's why repair folder is failing. In folderpane.js, repair has:

      if (folder.supportsOffline) {
        // Remove the offline store, if any.
        let offlineStore = folder.filePath;
        if (offlineStore.exists())
          offlineStore.remove(false);
      }

which generates JavaScript error: chrome://messenger/content/folderPane.js, line 2443: NS_ERROR_FAILURE: Component returned failure code
: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.remove]

That is, you cannot remove a maildir directory with a simple .remove command because it is a directory and not a file.
(Assignee)

Comment 2

2 years ago
Created attachment 8628544 [details] [diff] [review]
Make the offline store delete recursive

Although this can cause main thread lockup while the OS is deleting thousands of files, this is no different than how it is handled in the main maildir C++ code. For a repair operation, I think this is acceptable.
Assignee: nobody → rkent
Status: NEW → ASSIGNED
Attachment #8628544 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1182687

Comment 4

2 years ago
Comment on attachment 8628544 [details] [diff] [review]
Make the offline store delete recursive

Review of attachment 8628544 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, sorry for the delay. r=mkmelin
Attachment #8628544 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 5

2 years ago
Comment on attachment 8628544 [details] [diff] [review]
Make the offline store delete recursive

http://hg.mozilla.org/comm-central/rev/780522954c42
Attachment #8628544 - Flags: approval-comm-esr38?
Attachment #8628544 - Flags: approval-comm-beta?
Attachment #8628544 - Flags: approval-comm-aurora?
(Assignee)

Updated

2 years ago
status-thunderbird41: --- → affected
status-thunderbird42: --- → affected
status-thunderbird43: --- → fixed
status-thunderbird_esr38: --- → affected
tracking-thunderbird_esr38: --- → +
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0
(Assignee)

Comment 6

2 years ago
Comment on attachment 8628544 [details] [diff] [review]
Make the offline store delete recursive

https://hg.mozilla.org/releases/comm-esr38/rev/7b835a634206
https://hg.mozilla.org/releases/comm-beta/rev/166d8e44fb95
https://hg.mozilla.org/releases/comm-aurora/rev/b378d2df070c
Attachment #8628544 - Flags: approval-comm-esr38?
Attachment #8628544 - Flags: approval-comm-esr38+
Attachment #8628544 - Flags: approval-comm-beta?
Attachment #8628544 - Flags: approval-comm-beta+
Attachment #8628544 - Flags: approval-comm-aurora?
Attachment #8628544 - Flags: approval-comm-aurora+
(Assignee)

Updated

2 years ago
status-thunderbird40: --- → wontfix
status-thunderbird41: affected → fixed
status-thunderbird42: affected → fixed
status-thunderbird_esr38: affected → fixed
tracking-thunderbird_esr38: + → 41+
You need to log in before you can comment on or make changes to this bug.