Microsoft Office Plug-in is not activated when you use a link targeting a file

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: Frédéric LESPEZ, Unassigned)

Tracking

38 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I will describe 2 use cases to illustrate this bug.

In order to reproduce it, you need :
 - Access to a SharePoint Server with an Excel file on it (the same bug happen with Word or PowerPoint files).
 - A PC with Windows (Windows 7) and Microsoft Office 2010 (or 2013 installed).

Use case #1
What did you do? (steps to reproduce)
I click on this link http://my.sharepoint.company.com/path/to/a/folder/
And when Firefox displays the content of the Sharepoint folder, I click on "myfile.xls".
What happened? (actual results)
Firefox displays a dialog box asking to confirm if you want to open the file. This dialog box is brought by the Microsoft Office Plug-in. I click "OK" and then the file is opened in Microsoft Excel. Note that the file is opened by Excel directly from the SharePoint (the file is stored downloaded and opened from the local drive).
In this case everything works as expected. That is the expected behavior.

Use case #2
What did you do? (steps to reproduce)
I click on this link http://my.sharepoint.company.com/path/to/a/folder/myfile.xls

What happened? (actual results)
Firefox displays its standard download dialog box asking you if you want to open the file with the default app (EXCEL) or download it (on your local drive). If you choose to open it with Excel, Firefox will download the file on a temporary local folder and Excel will open it (locally).

What should have happened? (expected results)
what is use case #1 : Firefox should have displayed a dialog box asking to confirm if you want to open the file. This dialog box is brought by the Microsoft Office Plug-in. I would have clicked "OK" and then the file should have been opened in Microsoft Excel directly from the SharePoint server (not locally).

It seems that in the use case #2, the Microsoft Office Plug-in is not activated.

This bug renders Firefox useless when you are using SharePoint sites because in case #2 if you modify the Excel file and save it, the file will be saved locally (on a temporary folder) instead of being saved on the SharePoint server. In brief, the modifications will be silently dropped :-(

Updated

2 years ago
Component: General → Plug-ins
Product: Firefox → Core
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.