[Usage] Cost Control notifications are not selectable.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Cost Control
P1
normal
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: Marty, Unassigned, NeedInfo)

Tracking

unspecified
FxOS-S5 (21Aug)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8628525 [details]
Cost-Control-Notification-Logcat.txt

Description:
If the user exceeds their data limit, the alert notification is not selectable. Tapping the notification in the utility tray results in no functionality.

Note: Tapping the notification on the Flame will result in the Usage app launching.

Repro Steps:
1) Update a Aries to 20150701145139
2) Configure a data alert limit for 5MB in the Usage app
3) Connect to a Cellular Data network.
4) Open the Browser and browse the web until you receive the data alert notification
5) Tap the notification banner, or pull down the utility tray and tap the notification.

Actual:
The notification highlights when tapped, and the utility tray is dismissed, but the usage app is not launched,

Expected:
The usage app is launched after tapping the notification.

Environmental Variables:
Device: Aries 2.5 (Full Flash)
Build ID: 20150701145139
Gaia: 5a39ff43424e92e73c468b8f00a6c62476f30177
Gecko: 2ec00565de09
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached: Logcat, Video (URL)
(Reporter)

Comment 1

3 years ago
This issue does NOT occur on the latest Flame 2.5 build.
The usage app is launched after tapping the notification.

Environmental Variables:
Device: Flame 2.5 (Full Flash)
Build ID: 20150629010206
Gaia: 8a1e4ae522c121c5cacd39b20a5386ec9055db82
Gecko: eaf4f9b45117
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional regression from Flame behavior
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
This is a duplicate of the bug where we have too many touch events on the Aries screen. Every notification will have the same issue. I tried to find it but I couldn't. Leaving DUPEME if somebody finds the other bug.
blocking-b2g: 2.5? → ---
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe] → [2.5-Daily-Testing][Spark][DUPEME]
Actually the one I was thinking of is bug 1170357, which is supposed to be fixed on June 19th.
blocking-b2g: --- → 2.5?
Whiteboard: [2.5-Daily-Testing][Spark][DUPEME] → [2.5-Daily-Testing][Spark]
Keywords: regression
Comms triage: Regression.
blocking-b2g: 2.5? → 2.5+

Comment 6

3 years ago
Francisco, could you take a look to the issue? thanks.
Flags: needinfo?(francisco)
Unfortunately the engineers in Telefonica are not working on this app anymore.

ni Hema to check if Marshall can take a look.
Flags: needinfo?(francisco) → needinfo?(hkoka)

Updated

3 years ago
Flags: needinfo?(hkoka) → needinfo?(marshall)

Updated

3 years ago
Assignee: nobody → marshall
Target Milestone: --- → FxOS-S5 (21Aug)
Priority: -- → P2

Comment 8

3 years ago
Marshall, 

If you have any update on this, please add it to the bug. 

Unassigning so someone else can help. 

Thanks
hema
Assignee: marshall → nobody
I tried with the recent build(20151007) but can't reproduce this issue. Need QA support here.
Keywords: qawanted
Hi, I tried with latest Aries 2.5 build and can reproduce when the app is closed, not in background and once the notification is received I tap on it.

The notification will not disappear from the utility tray until although the app is open, it is necessary to remove it from the utility tray swiping right or with clear all option. 

BuildID: 20151018190150
Gaia: f75a7e01
NO Repro per these two builds: 

RESULTS: 
When go over usage limit as setup in the Usage App, a notification appears at the banner.
When tap the banner the Useage App appears with the expected information. 

Environmental Variables:
Device: Aries 2.5
BuildID: 20151019104907
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: d3e87bb40753327550143ba8ac8ee27b300cd4a9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20150707180647
Gaia: 86af137c7f4c41c1185e609339002ab47fd6c640
Gecko: ffa83d153080
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Contact: sleedavid
Marty can you still reproduce this issue?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado) → needinfo?(mshuman)
QA Contact: sleedavid
(Reporter)

Comment 13

3 years ago
I am still reproducing this issue on the latest Aries 2.5 master build.
The notification highlights when tapped, and the utility tray is dismissed, but the usage app is not launched.

Note: This occurs when tapping the notification toast, as well as when tapping the notification in the Utility Tray (Found toward the top of the screen after the tray has been pulled down).  This issue does NOT occur when tapping the Usage Widget, found toward the bottom of the Utility tray, which tracks how much data has been used relative to the Usage limit.

Environmental Variables:
Device: Aries 2.5
BuildID: 20151019104907
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: d3e87bb40753327550143ba8ac8ee27b300cd4a9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(mshuman) → needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Steve we are still able to reproduce this issue.  Please see comment 13.
Flags: needinfo?(schung)
Thanks Jayme and Martin, I found a critical step that might cause the problem. I would like to confirm this behavior with QA and see if it's still reproducible in 2.2

1) Open usage app
2) Configure a data alert limit for 5MB in the Usage app
3) Connect to a Cellular Data network.

3-A) Close usage app, or
3-B) Keep the usage app in the background

4) Open the Browser and browse the web until you receive the data alert notification
5) Tap the notification banner, or pull down the utility tray and tap the notification.

I can reproduce it with 3-A, but unable with 3-B. I guess this issue also existed in 2.2 or even in older version.
Flags: needinfo?(schung)
Keywords: qawanted
Assignee: nobody → salva
I can confirm the finding on comment 15. This issue appears to only occur to me if I have Usage killed in task manager (3A scenario at comment 15)

3A is reproducible on Aries, Flame 2.5 and Flame 2.2.

Device: Aries 2.5
BuildID: 20151020162500
Gaia: 3491a49da4d4ce45b8a682e95d0ce68892c2b8ea
Gecko: f7b746b4e91307448cb0746a41f677bfc23908b0
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.5
BuildID: 20151020031318
Gaia: 3491a49da4d4ce45b8a682e95d0ce68892c2b8ea
Gecko: f7b746b4e91307448cb0746a41f677bfc23908b0
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.2
BuildID: 20151020032711
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 6b4e563acaf9
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Also, tapping on the notification banner (the blue one that appears for ~3 seconds on top edge of screen) seems to be a hit or miss experience. Sometimes tapping on it does nothing; other times it takes user to where it should. I'll look into bugging this separately.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmercado)
Keywords: qawanted, regression
Summary: [Aries][Usage] Cost Control notifications are not selectable. → [Usage] Cost Control notifications are not selectable.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
[Blocking Requested - why for this release]:
Because it's not a 2.2 regression(actually this regression existed more than one year), requesting triage again to see if we still want to set it as blocker now.

Hi Salva, since you took it and you're the usage owner, you must be the best candidate to estimate the effort of this bug. I just found the root cause about the timing you set the notification. If you set notification in message_handler.html URL launched by networkstats-alarm or other system message, the notification system message wont be fired since it is registered to index.html. Not sure if it's easy to change the networkstats-alarm back to index.html launch path since it was refactored in last year, but setting the system message to same URL might be the only way if we don't touch system message mechanism.
blocking-b2g: 2.5+ → 2.5?
Comms triage: Apparently, not being able to dismiss a notification can have some side effects, like: having twice the Cost Control notification for 2 different months. Isabel, could you see if this kind of scenarios occurs?
Flags: needinfo?(isabelrios)
Hi, here an update after some more testing..
Although the notifications cannot be dismissed by tapping on them and going to the app, it is possible to clear them by swapping or clearing all the notifications from the utility tray.

On the other hand, if user does not remove them by himself, they will persists in the utility tray. It will be possible to have two or more notifications showing that the limit has been passed even when that is not actually true.

1-Set the limit, close the app and start browsing
2-Once the limit is reached, the notifications arrives and appears in the utility tray (sc1.png)
3-Go to Usage app, reset mobile data and close the app
4-Check the utility tray (sc2.png) Here there is a notification but is due to the previous limit, as you can see at the bottom, there is still data available.
5-Start browsing again till the limit is reached again.
6-Check the utility tray. 
7-Go to Usage app, reset mobile data and pull down the utility tray. (sc3.png).Two or more notifications will be there. And same case than in step 4, there is still data available

Here the steps I followed to have that kind of information shown by notifications not being consistent.
note: bug 818000 is the bug that should change the system messages mechanism. But it's not due for 2.5.
Comms triage: Based on comment 19, the functionality to clear the notification is present, thanks to the swipe move and the "clear all" button. The tap event has to be done at some point, but there is no need to hold the 2.5 release on it.
blocking-b2g: 2.5? → ---
tracking-b2g: --- → backlog
Priority: P2 → P1
Answer provided in comment 19.
Flags: needinfo?(isabelrios)
Assignee: salva → nobody

Comment 26

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.