Closed Bug 1179666 Opened 7 years ago Closed 7 years ago

Wi-Fi settings should sort network names alphabetically within each signal bar level

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-master affected)

RESOLVED FIXED
tracking-b2g backlog
Tracking Status
b2g-master --- affected

People

(Reporter: cpeterson, Assigned: scottwu)

References

Details

(Keywords: foxfood)

Attachments

(1 file)

iOS sorts the entire list of network names alphabetically. Apple probably assumes users want to find a specific network (by name), not just select the random network with the strongest signal.

Android and Firefox OS appears to sort by precise signal strength, even though the UI only shows four signal bars: Very Good, Good, Average, and Weak. The list appears to be random because networks that fall into the same signal bar bucket will be sorted by a criteria that is not visible to the user (precise signal strength, not number of signal bars).

I think Firefox OS should either:

1. sort the entire list alphabetically (like iOS). This list order is stable even when networks' signal strengths fluctuate!
2. or separate networks into the four signal bar buckets and sort each of those sub-lists alphabetically.
Summary: Wi-Fi settings should sort network names alphabetically (entire list or within each signal strength bucket) → Wi-Fi settings should sort network names alphabetically (entire list or within each signal bar level)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Component: Gaia::Feedback → Gaia::Settings
QA Whiteboard: [foxfood-triage]
let UX decide if we need change current behavior
Flags: needinfo?(hhsu)
I think the current design make sense as users typically connect to the Wi-Fi access point that has the strongest signal. But we can alphabetically order the ones that has the same signal bar.
Flags: needinfo?(hhsu)
denominate since it's an expected behavior. 

Add it to backlog for `alphabetically order the ones that has the same signal bar`
blocking-b2g: 2.5? → ---
Summary: Wi-Fi settings should sort network names alphabetically (entire list or within each signal bar level) → Wi-Fi settings should sort network names alphabetically within each signal bar level
If you think it's an important improvement, please vote it in `Importance` field
See Also: → 833249
Assignee: nobody → scwwu
Comment on attachment 8682929 [details] [review]
[gaia] scottwu:1179666-wifi-network-sort > mozilla-b2g:master

Thanks to :cpeterson for reviewing, but I think I accidentally overwritten his comments on github..

WiFi networks are now sorted by signal bars and alphabetically. I've added a function in WifiHelper to convert relSignalStrength (0~100) to signal bars (0~4).

Could you take a look as well Fred? :)
Attachment #8682929 - Flags: review?(gasolin)
Attachment #8682929 - Flags: feedback?(cpeterson)
Comment on attachment 8682929 [details] [review]
[gaia] scottwu:1179666-wifi-network-sort > mozilla-b2g:master

looks good. it will be nice with some unit test
Attachment #8682929 - Flags: review?(gasolin) → review+
Comment on attachment 8682929 [details] [review]
[gaia] scottwu:1179666-wifi-network-sort > mozilla-b2g:master

LGTM! Thanks for fixing this bug. :)
Attachment #8682929 - Flags: feedback?(cpeterson) → feedback+
Thanks Fred and Chris! I've added unit test that covers the sorting behaviour.

Merged to master.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.