[RTL][Music]The LTR text is truncated at wrong side in loading music view.

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Music
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Shine(Leave from Mozilla), Assigned: sfoster)

Tracking

(Blocks: 2 bugs)

unspecified
FxOS-S6 (04Sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(6 attachments)

(Reporter)

Description

2 years ago
Created attachment 8628715 [details]
Music.png

[1.Description]:
[RTL][Flame v2.2&Master][N5 v2.2&master][Music]Launch music for the first time, the music name with LTR text is truncated at wrong side in loading music view.
See attachment: Music.png

[2.Testing Steps]: 
Precodition: Have some music with long name or long album name in device.
1. Set system language as Arabic.
2. Launch Music for the first time.

[3.Expected Result]: 
2. The music name with LTR text should be truncated at right side in loading music view.

[4.Actual Result]: 
2. The music name with LTR text is truncated at wrong side in loading music view.

[5.Reproduction build]: 
Device: Flame 2.2 build (Affected)
Build ID               20150701162502
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150701.195343
Firmware Date          Wed Jul  1 19:53:55 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Flame 2.5/master)  (Affected)
Build ID               20150701160205
Gaia Revision          858764a56982eb558259ccc689bbee855f090085
Gaia Date              2015-07-01 16:59:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c36f68439496
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150701.193443
Firmware Date          Wed Jul  1 19:34:55 EDT 2015
Bootloader             L1TC000118D0

Device: N5 2.2 build (Affected)
Build ID               20150701162502
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150701.195806
Firmware Date          Wed Jul  1 19:58:26 EDT 2015
Bootloader             HHZ12f

Device: N5 master (N5 2.5/master) (Affected)
Build ID               20150701160205
Gaia Revision          858764a56982eb558259ccc689bbee855f090085
Gaia Date              2015-07-01 16:59:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c36f68439496
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150701.193431
Firmware Date          Wed Jul  1 19:34:50 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

2 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected

Updated

2 years ago
status-b2g-v2.5: affected → ---
Blocks: 1181938
[Blocking Requested - why for this release]:
blocking for clear RTL feature breakage.  (Since RTL is in scope for 2.5)
blocking-b2g: --- → 2.5?
Delphine, so in this case, should the LTR (English) text be truncated normally?  Do you think it's a blocker?
Flags: needinfo?(lebedel.delphine)
Hey No-Jun: yeah, it should truncate normally in this case. I think this should be a blocker for 2.5. thanks!
Flags: needinfo?(lebedel.delphine)
Created attachment 8649782 [details]
AriesKK_v2.5.3gp

This issue can be reproduced on latest AriesKK v2.5 build by the same STR in comment 0.
Actual Result: 
The music name with LTR text is truncated at wrong side in loading music view.

See attachment:AriesKK_v2.5.3gp.
Reproducing rate:5/5

Device:AriesKK v2.5 build
Build ID               20150818005621
Gaia Revision          60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gaia Date              2015-08-16 02:21:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6ae3e9ff53b2bae8d95a90c9f25368fd81fa357e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150818.003312
Firmware Date          Tue Aug 18 00:33:21 UTC 2015
Bootloader             s1
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]

Comment 5

2 years ago
RTL is a 2.5 requrement per PM. Please review in Media triage.
Flags: needinfo?(hkoka)

Comment 6

2 years ago
Wilfred, what is the status of Phoxygen's work on RTL?
Flags: needinfo?(wmathanaraj)
(Assignee)

Comment 7

2 years ago
I have a patch in progress for this. Its hard to trigger it though, is there good way to see this scanning mode without dropping new files on the sdcard, restarting the app and setting a breakpoint?
Assignee: nobody → sfoster

Comment 8

2 years ago
Created attachment 8653136 [details] [review]
[gaia] sfoster:music-scanning-rtl-bug-1179696 > mozilla-b2g:master

Updated

2 years ago
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(hkoka)
(Assignee)

Comment 9

2 years ago
Comment on attachment 8653136 [details] [review]
[gaia] sfoster:music-scanning-rtl-bug-1179696 > mozilla-b2g:master

I ended up just calling 

  TitleBar.showScanProgress({ count: 1, artist: 'Very Long Artist Name Which Should Ellipsize', title: 'Very Long Title Which Really Should Ellipsize' }) 

..from the console. I looked at both LTR content in RTL (ar) and RTL content in en-US. I also checked actually scanning for new content and it whizzed by pretty quick but looked correct to me. I didn't update any tests for the new markup but I'm sure treeherder will let me know if I missed something.
Attachment #8653136 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Comment 10

2 years ago
Created attachment 8653138 [details]
music-scanning-rtl.png

Screenshot of patch applied with LRT scanning content in RTL document
(Assignee)

Comment 11

2 years ago
Created attachment 8653140 [details]
music-scanning-ltr.png

Screenshot of patch applied with RTL scanning content in LTR document

Comment 12

2 years ago
accidentally moved this to 2.5+ during triage 

triage notes: if this is only happening on scanning/loading phase and it is very difficult to reproduce and see the issue, it is not going to block a release, but good to fix it as a polish bug. but if the long names are truncated incorrectly in song view then it is bad user experience. no-jun is going to quickly test on latest build and confirm.
blocking-b2g: 2.5+ → 2.5?
Flags: needinfo?(npark)
(Assignee)

Comment 13

2 years ago
I can confirm that the titles are fine in song view, as a gaia-header is used there which already does the right thing. Its just the scanning/loading phase that has the bidi problem. I agree, I wouldn't block on it, I just wanted to see the RTL bug count go down instead of up!

Comment 14

2 years ago
Comment on attachment 8653136 [details] [review]
[gaia] sfoster:music-scanning-rtl-bug-1179696 > mozilla-b2g:master

This looks good, provided tests pass, of course. However, the music app is currently in the process of being replaced for 2.5, so this probably won't actually ship.
Attachment #8653136 - Flags: review?(squibblyflabbetydoo) → review+

Comment 15

2 years ago
P.S.: Thanks for the patch, and sorry for the fact that it probably won't see the light of day (unless NGA Music goes completely off the rails)!

Updated

2 years ago
Flags: needinfo?(npark)
(Assignee)

Comment 16

2 years ago
(In reply to Jim Porter (:squib) from comment #15)
> P.S.: Thanks for the patch, and sorry for the fact that it probably won't
> see the light of day (unless NGA Music goes completely off the rails)!

Not to worry, its better to have a good baseline to compare the new NGA Music to. Tests are messy but good I think - only a 'TypeError: Cannot call method 'send' of undefined' unrelated failure. Leaving checkin-needed for when the tree re-opens
Keywords: checkin-needed

Updated

2 years ago
blocking-b2g: 2.5? → ---
Master: https://github.com/mozilla-b2g/gaia/commit/48ab5292285ef415aef94cd47277103079831554
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-b2g-master: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S6 (04Sep)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: The music name with LTR text is truncated at right side in loading music view.
See attachment: verified_FlameKK_v2.5 & AriesKK_v2.5.png
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150830150218
Gaia Revision          31e595f86f6bf159b3a9a46816a6ac00a55ca9f9
Gaia Date              2015-08-30 00:42:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2ad5077d86ba81b667de45ccc986dbd2ce633cc4
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150830.184031
Firmware Date          Sun Aug 30 18:40:47 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150830210046
Gaia Revision          31e595f86f6bf159b3a9a46816a6ac00a55ca9f9
Gaia Date              2015-08-30 00:42:30
Gecko Revision         http://hg.mozilla.org/integration/fx-team/rev/2ad5077d86ba81b667de45ccc986dbd2ce633cc4
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150830.203030
Firmware Date          Sun Aug 30 20:30:38 UTC 2015
Bootloader             s1
status-b2g-master: fixed → verified
Created attachment 8654716 [details]
verified_FlameKK_v2.5 & AriesKK_v2.5.png
Status: RESOLVED → VERIFIED
Flags: needinfo?(wmathanaraj)
You need to log in before you can comment on or make changes to this bug.