Closed Bug 1179761 Opened 4 years ago Closed 4 years ago

[Windows 10] Pinning and unpinning Firefox often results in a tile missing its icon

Categories

(Firefox :: General, defect)

All
Windows 10
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox39 --- affected
firefox40 --- affected
firefox41 --- affected
firefox42 --- affected

People

(Reporter: avaida, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Reproducible on:
* Firefox 39.0 RC (build6: 20150630154324)
* Aurora 40.0a2 (2015-06-29)
* Nightly 42.0a1 (2015-07-01)

Affected platforms:
Windows 10 Pro (x64) Insider Preview Build 10185

Steps to reproduce:
1. Open Firefox's installation folder.
2. Right-click firefox.exe and select "Pin to Start".
3. From either the Start Screen or Start Menu -depending on your setup- right-click the tile and select "Unpin".
4. Repeat these steps a few times and check how the tile is displayed each time.

Expected results:
Firefox is successfully pinned and unpinned and its icon is displayed inside the tile.

Actual result:
After a few pins and unpins, the Firefox icon is no longer displayed in the tile.

Additional notes:
* I was unable to replicate this issue on Windows 8.1 (x64) or Windows 8 (x64) using the same hardware, so I believe this is likely a Windows 10-specific issue.
** Please note that I'm not sure if this is related to Firefox, but having a blank tile for it is a bug worth filing.
* The bug happens across branches.
This seems like a Win10 bug. I'm not aware of us doing anything when you're using pin-to-start, especially if we're not even running at the time.
Blocks: windows-10
I can't reproduce this in Win10 build 10240.

Agreed that this isn't likely to be a bug in Firefox.

(I've seen some posts on Reddit about pinning being wonky in Win10 previews, so this seems more widespread than just Firefox anyway.)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.