Closed Bug 1179766 Opened 5 years ago Closed 5 years ago

Intermittent browser_urlbarDelete.js | "xample.com/" == "xam" - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js :: testDelete :: line 47 etc...

Categories

(Firefox :: Address Bar, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 43
Tracking Status
e10s + ---
firefox41 --- unaffected
firefox42 --- fixed
firefox43 --- fixed
firefox-esr38 --- unaffected

People

(Reporter: RyanVM, Assigned: mak)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

Attached image test screenshot
19:03:52 INFO - 624 INFO TEST-START | browser/base/content/test/general/browser_urlbarDelete.js
19:03:56 INFO - TEST-INFO | screentopng: exit 0
19:03:56 INFO - 625 INFO checking window state
19:03:56 INFO - 626 INFO Entering test
19:03:56 INFO - 627 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_urlbarDelete.js | "xample.com/" == "xam" - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js :: testDelete :: line 47
19:03:56 INFO - Stack trace:
19:03:56 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js:testDelete:47
19:03:56 INFO - self-hosted:InterpretGeneratorResume:715
19:03:56 INFO - self-hosted:next:623
19:03:56 INFO - resource://gre/modules/Task.jsm:TaskImpl_run:314
19:03:56 INFO - resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:Handler.prototype.process:920
19:03:56 INFO - resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:this.PromiseWalker.walkerLoop:799
19:03:56 INFO - resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:this.PromiseWalker.scheduleWalkerLoop/<:738
19:03:56 INFO - null:null:0
19:03:56 INFO - Not taking screenshot here: see the one that was previously logged
19:03:56 INFO - 628 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_urlbarDelete.js | "ample.com/" == "am" - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js :: testDelete :: line 52
19:03:56 INFO - Stack trace:
19:03:56 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js:testDelete:52
19:03:56 INFO - self-hosted:InterpretGeneratorResume:715
19:03:56 INFO - self-hosted:next:623
19:03:56 INFO - resource://gre/modules/Task.jsm:TaskImpl_run:314
19:03:56 INFO - resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:Handler.prototype.process:920
19:03:56 INFO - resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:this.PromiseWalker.walkerLoop:799
19:03:56 INFO - resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:this.PromiseWalker.scheduleWalkerLoop/<:738
19:03:56 INFO - null:null:0
19:03:56 INFO - Not taking screenshot here: see the one that was previously logged
19:03:56 INFO - 629 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_urlbarDelete.js | "xample.com/" == "xam" - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js :: testDelete :: line 47
19:03:56 INFO - Stack trace:
19:03:56 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js:testDelete:47
19:03:56 INFO - self-hosted:InterpretGeneratorResume:715
19:03:56 INFO - self-hosted:next:623
19:03:56 INFO - Promise*openNewForegroundTab@resource://testing-common/BrowserTestUtils.jsm:95:12
19:03:56 INFO - this.BrowserTestUtils.withNewTab<@resource://testing-common/BrowserTestUtils.jsm:57:21
19:03:56 INFO - TaskImpl_run@resource://gre/modules/Task.jsm:314:40
19:03:56 INFO - TaskImpl@resource://gre/modules/Task.jsm:275:3
19:03:56 INFO - createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:249:14
19:03:56 INFO - @chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js:24:9
19:03:56 INFO - TaskImpl_run@resource://gre/modules/Task.jsm:314:40
19:03:56 INFO - Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:920:23
19:03:56 INFO - this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:799:7
19:03:56 INFO - this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:738:39
19:03:56 INFO - Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:738:7
19:03:56 INFO - this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:762:7
19:03:56 INFO - this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:705:7
19:03:56 INFO - onPopupShown@chrome://mochitests/content/browser/browser/base/content/test/general/head.js:846:5
19:03:56 INFO - Not taking screenshot here: see the one that was previously logged
19:03:56 INFO - 630 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_urlbarDelete.js | "ample.com/" == "am" - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js :: testDelete :: line 52
19:03:56 INFO - Stack trace:
19:03:56 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js:testDelete:52
19:03:56 INFO - self-hosted:InterpretGeneratorResume:715
19:03:56 INFO - self-hosted:next:623
19:03:56 INFO - Promise*openNewForegroundTab@resource://testing-common/BrowserTestUtils.jsm:95:12
19:03:56 INFO - this.BrowserTestUtils.withNewTab<@resource://testing-common/BrowserTestUtils.jsm:57:21
19:03:56 INFO - TaskImpl_run@resource://gre/modules/Task.jsm:314:40
19:03:56 INFO - TaskImpl@resource://gre/modules/Task.jsm:275:3
19:03:56 INFO - createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:249:14
19:03:56 INFO - @chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarDelete.js:24:9
19:03:56 INFO - TaskImpl_run@resource://gre/modules/Task.jsm:314:40
19:03:56 INFO - Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:920:23
19:03:56 INFO - this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:799:7
19:03:56 INFO - this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:738:39
19:03:56 INFO - Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:738:7
19:03:56 INFO - this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:762:7
19:03:56 INFO - this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:705:7
19:03:56 INFO - onPopupShown@chrome://mochitests/content/browser/browser/base/content/test/general/head.js:846:5
19:03:56 INFO - 631 INFO Leaving test
19:03:57 INFO - MEMORY STAT | vsize 1695MB | residentFast 513MB | heapAllocated 215MB
19:03:57 INFO - 632 INFO TEST-OK | browser/base/content/test/general/browser_urlbarDelete.js | took 4328ms
Mak, is this something you'd have cycles to look at? Otherwise, can you suggest someone who might? It's a pretty frequent e10s test failure.
tracking-e10s: --- → ?
Flags: needinfo?(mak77)
I suspect the problem is a previous test adding a typed visit to example.com, then sometimes we might autoFill it.
Using a unique string for this test is likely a good idea.
Assignee: nobody → mak77
Flags: needinfo?(mak77)
Attached patch patch v1Splinter Review
should be fine, on Try now:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4925af7a8d16
Attachment #8653488 - Flags: review?(markh)
Comment on attachment 8653488 [details] [diff] [review]
patch v1

Review of attachment 8653488 [details] [diff] [review]:
-----------------------------------------------------------------

The reasons why this might fix it escape me, but I'll take your word for it! :)
Attachment #8653488 - Flags: review?(markh) → review+
basically "exam" could be autofilled to example.com/ if a previous test added an example.com/ typed visit. at that point the first delete would cause "xample.com/" instead of "xam"

by using a custom string, there's no risk some previous test has added such a visit.
https://hg.mozilla.org/mozilla-central/rev/3406e5f7e3d0
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
You need to log in before you can comment on or make changes to this bug.