Closed Bug 1179772 Opened 5 years ago Closed 5 years ago

"Enable Service Workers over HTTP (when toolbox is open)" setting is not working

Categories

(Core :: DOM: Service Workers, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla42
Tracking Status
firefox41 --- fixed
firefox42 --- fixed

People

(Reporter: noemi, Assigned: bkelly)

References

Details

Attachments

(1 file)

Tested on today's (7/2) master build

STR:
1- Active "Enable Service Workers over HTP (when toolbox is open)" flag in Advanced Settings
2- Try to register a sw over HTTP when toolbox is open

Actual result:
It is not possible to properly register the sw

Expected result:
The sw should be properly registered under those conditions

Please find below the corresponding traces:
http://jaoo.es/service-worker-testing/service.js
Execution context(): install event fired!
Client context: registration has an installing worker (installing)!
Execution context(): opening cache...
[Child 47828] WARNING: CacheStorage not supported on untrusted origins.: file /Users/noef/Documents/mozilla-central/dom/cache/CacheStorage.cpp, line 212
[Child 47828] WARNING: 'NS_FAILED(mStatus)', file /Users/noef/Documents/mozilla-central/dom/cache/CacheStorage.cpp, line 324
[Child 47828] WARNING: '!info', file /Users/noef/Documents/mozilla-central/dom/workers/ServiceWorkerManager.cpp, line 3275
[Child 47828] WARNING: '!info', file /Users/noef/Documents/mozilla-central/dom/workers/ServiceWorkerManager.cpp, line 3275
[Child 47828] WARNING: '!aInstallEventSuccess', file /Users/noef/Documents/mozilla-central/dom/workers/ServiceWorkerManager.cpp, line 1304
[Child 47828] WARNING: 'NS_FAILED(aStatus)', file /Users/noef/Documents/mozilla-central/dom/workers/ServiceWorkerManager.cpp, line 295
[Child 47828] WARNING: ServiceWorkerJob failed with error: NS_ERROR_DOM_ABORT_ERR
: file /Users/noef/Documents/mozilla-central/dom/workers/ServiceWorkerManager.cpp, line 301
JavaScript error: http://jaoo.es/service-worker-testing/service.js, line 44: SecurityError: The operation is insecure.
Summary: Enable Service Workers over HTTP (when toolbox is open) setting is not working → "Enable Service Workers over HTTP (when toolbox is open)" setting is not working
Hi Ben,

Would you mind to take a look at this?. It seems to be a regression maybe caused by some change in CacheStorage. Thanks!
Flags: needinfo?(bkelly)
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Flags: needinfo?(bkelly)
Related to the patches you reviewed for me last week.  Cache needs to trust the origin on ServiceWorkers themselves in addition to trusting them during script load.
Attachment #8628814 - Flags: review?(ehsan)
Comment on attachment 8628814 [details] [diff] [review]
Make Cache API honor devtools SW testing flag in SW itself. r=ehsan

Review of attachment 8628814 [details] [diff] [review]:
-----------------------------------------------------------------

We should probably uplift this to 41...
Attachment #8628814 - Flags: review?(ehsan) → review+
Comment on attachment 8628814 [details] [diff] [review]
Make Cache API honor devtools SW testing flag in SW itself. r=ehsan

Approval Request Comment
[Feature/regressing bug #]: Regressed in bug 1175138
[User impact if declined]: Devtools SW testing option does not work properly.  This will reduce the amount of testing of SW in firefox.
[Describe test coverage new/current, TreeHerder]: Devtools has a test for this option, but did not catch this particular issue.
[Risks and why]: Minimal.  Its a one line change.
[String/UUID change made/needed]: None
Attachment #8628814 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d7e196b07cee
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Hi,

Checked with today's (7/3) master build and the sw under this scenario is properly registered. Please see the current traces below:

http://jaoo.es/service-worker-testing/service.js
Execution context(): install event fired!
Client context: registration has an installing worker (installing)!
Execution context(): opening cache...
Execution context(): opened cache so adding content!
[Child 43010] WARNING: '!info', file /Users/noef/Documents/mozilla-central/dom/workers/ServiceWorkerManager.cpp, line 3276
[Child 43010] WARNING: '!info', file /Users/noef/Documents/mozilla-central/dom/workers/ServiceWorkerManager.cpp, line 3276
Execution context(): activate event fired!

Thanks for fixing it so quickly!
Comment on attachment 8628814 [details] [diff] [review]
Make Cache API honor devtools SW testing flag in SW itself. r=ehsan

Approving for uplift to Aurora. The fix was verified on the nightly build and works.
Attachment #8628814 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Changing status to verified based on comment #7.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.