Opening new tabs quickly will not add top-sites to about:home

RESOLVED WONTFIX

Status

()

Firefox for iOS
Home screen
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: fluffyemily)

Tracking

unspecified
ARM
iOS

Firefox Tracking Flags

(fxios+)

Details

(Reporter)

Description

3 years ago
By simply opening a couple sites in a row in a bunch of new tabs this will beat the top-site addition code-path.

Updated

3 years ago
tracking-fxios: ? → +
Investigate listening for notification changes to invalidate the Top Sites so we're not getting outraced.

Updated

3 years ago
Assignee: nobody → bmunar
seems like "onLocationChange" is not being fired, gonna investigate
being fired for certain sites* thus resulting in some top sites not being added

Updated

3 years ago
Assignee: bmunar → wjohnston
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1179798
This was fixed by backout, right?
Flags: needinfo?(bmunar)
(Reporter)

Comment 6

3 years ago
Unless there was a backout this afternoon, I was still seeing this on a build I made this morning while testing my other bug.
@wesj I haven't checked!
Flags: needinfo?(bmunar)
Assignee: wjohnston → nobody
This seems to work now..(?)
Flags: needinfo?(wjohnston)
The original bug was fixed by the backout.

I think maybe some of the problems Aaron was seeing were related to bug 1184650 (i.e. in the right set of circumstances, we might have set a limit on the top sites query of 3 or something).

I'm going to close this, but feel free to reopen if I'm wrong.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(wjohnston)
Resolution: --- → FIXED
(Reporter)

Comment 10

3 years ago
Still reproducible in the sense in that we have delayed or slow writes to about:home so if you open a new tab as the prior is still loading you won't see it on about:home until you re-visit about:home later. At that point you will see your tabs there.

Is there anything we can do to speed this up?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We could add the site earlier (during page load?). That would probably have a tiny impact on page load perf, and might result in sites being added that wind up being redirects.
This behavior works for me.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

3 years ago
This is still reproducible.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

3 years ago
Assignee: nobody → etoop
Status: REOPENED → ASSIGNED
Triage result: WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.