Closed Bug 1179923 Opened 4 years ago Closed 4 years ago

Wrong total count when importing a vcard with several contacts via Bluetooth

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WORKSFORME
blocking-b2g 2.5+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: oteo, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image 2015-07-02-20-28-48.png
STR:
1. Send a vcard with multiple contacts (in this case a .vcf file with 14 contacts) to a FxOS device via BT
2. Accept the transfer in the FxOS device

Actual Result:
Although the contacts included in the vcard are successfully imported to the device, the total count while transferring the file is wrong. See in the attached screenshot that is shown: "6/0" and should be "6/14"

Environment variables:
The issue is reproducible in master and 2.2 FxOS releases but NOT in 2.1 version
 
Flame master (3.0 version)
Build ID: 20150702060218
Gecko: 18d550e
Gaia: 4b7ad0d
Platform version: 42.0a1

Flame master (2.2 version)
Build ID: 20150702051817
Gecko: 4c21883
Gaia: bd386f3
Platform version: 37.0

Flame master (2.1 version)
Build ID: 20150702033027
Gecko: 29bc578
Gaia: 7080a7c
Platform version: 34.0
See Also: → 1179884
[Blocking Requested - why for this release]: regression
blocking-b2g: --- → 2.5?
Comms triage: Regression.
blocking-b2g: 2.5? → 2.5+
I've tried this, and I think we landed the new open/import, working for me.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
(In reply to Francisco Jordano [:arcturus] [:francisco] (on PTO till 6th of September) from comment #3)
> I've tried this, and I think we landed the new open/import, working for me.

That's right, after merging the #new and #import activities this issue has been solved.

Environmental Variables (8/31):
flame master (2.5 version)
Build ID: 20150831063701
Gecko: d6c213f
Gaia: 31e595f
Platform version: 43.0a1
See Also: → 1184075
You need to log in before you can comment on or make changes to this bug.