gen_test_packages_manifest.py failing on 40.0b1 release builds

RESOLVED FIXED in Firefox 39

Status

()

Core
Build Config
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bhearsum, Assigned: chmanchester)

Tracking

unspecified
mozilla42
Points:
---

Firefox Tracking Flags

(firefox39 fixed, firefox40 fixed, firefox41 fixed, firefox42 fixed, firefox-esr38 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Looks like something isn't coping with spaces in filenames properly:
make -C ./testing/web-platform stage-package
../../config/nsinstall -D ../../dist/test-stage/web-platform
./config/nsinstall -D dist/test-stage/luciddream
/builds/slave/rel-m-beta-m64_bld-00000000000/build/obj-firefox/i386/_virtualenv/bin/python /builds/slave/rel-m-beta-m64_bld-00000000000/build/build/gen_test_packages_manifest.py --common Firefox 40.0b1.tests.zip --jsshell jsshell-mac.zip --dest-file dist/mac/en-US//test_packages.json
usage: gen_test_packages_manifest.py [-h] --common TESTS_COMMON --jsshell
                                     JSSHELL --dest-file DESTFILE
gen_test_packages_manifest.py: error: unrecognized arguments: 40.0b1.tests.zip
(Reporter)

Comment 1

3 years ago
Chris, looks like you added this target in http://hg.mozilla.org/mozilla-central/diff/a7a6d91116ab/testing/testsuite-targets.mk
Flags: needinfo?(cmanchester)
(Assignee)

Comment 2

3 years ago
Created attachment 8629063 [details] [diff] [review]
Deal with spaces in file names when generating test archive dependencies

I wasn't able to reproduce the issue locally, but this ought to address it.
Attachment #8629063 - Flags: feedback?(bhearsum)
(Assignee)

Updated

3 years ago
Assignee: nobody → cmanchester
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Flags: needinfo?(cmanchester)
(Reporter)

Comment 3

3 years ago
Comment on attachment 8629063 [details] [diff] [review]
Deal with spaces in file names when generating test archive dependencies

Review of attachment 8629063 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, this should work for central...per IRC we'll need a different one for aurora and beta.
Attachment #8629063 - Flags: feedback?(bhearsum) → feedback+
(Assignee)

Comment 4

3 years ago
Created attachment 8629067 [details] [diff] [review]
Deal with spaces in file names when generating test archive dependencies (patch for beta)

Fix for beta (the first applies to central).
Attachment #8629067 - Flags: feedback?(bhearsum)
(Reporter)

Updated

3 years ago
Attachment #8629067 - Flags: feedback?(bhearsum) → feedback+
(Reporter)

Updated

3 years ago
Attachment #8629063 - Flags: review+
(Reporter)

Updated

3 years ago
Attachment #8629067 - Flags: review+
(Assignee)

Updated

3 years ago
Keywords: leave-open
(Assignee)

Updated

3 years ago
Attachment #8629067 - Flags: approval-mozilla-beta?

Comment 6

3 years ago
Comment on attachment 8629067 [details] [diff] [review]
Deal with spaces in file names when generating test archive dependencies (patch for beta)

This is blocking 40.0b1 release. Approving for uplift to Beta.
Attachment #8629067 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Aurora nomination coming too? :)
Flags: needinfo?(cmanchester)
(Assignee)

Updated

3 years ago
Flags: needinfo?(cmanchester)
Attachment #8629067 - Flags: approval-mozilla-aurora?
We hit another error with that fix in:

/builds/slave/rel-m-beta-m64_bld-00000000000/build/obj-firefox/i386/_virtualenv/bin/python /builds/slave/rel-m-beta-m64_bld-00000000000/build/build/gen_test_packages_manifest.py --common 'Firefox 40.0b1.tests.zip' --jsshell 'jsshell-mac.zip' --dest-file dist/mac/en-US//test_packages.json
Traceback (most recent call last):
  File "/builds/slave/rel-m-beta-m64_bld-00000000000/build/build/gen_test_packages_manifest.py", line 62, in <module>
    with open(args.destfile, 'w') as of:
IOError: [Errno 2] No such file or directory: 'dist/mac/en-US//test_packages.json'
make[3]: *** [test-packages-manifest] Error 1
make[2]: *** [postflight_all] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2

Full log:
http://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/40.0b1-candidates/build2/logs/release-mozilla-beta-macosx64_build-bm84-build1-build4.txt.gz

We're not actually running tests on these release builds so this would not be a problem, except that it blocks other packaging and uploading.
Created attachment 8629216 [details] [diff] [review]
Create directory before trying to write to it

r? rail to try to get this beta out this week
Attachment #8629216 - Flags: review?(rail)
Attachment #8629216 - Flags: review?(rail) → review+
Comment on attachment 8629216 [details] [diff] [review]
Create directory before trying to write to it

https://hg.mozilla.org/releases/mozilla-beta/rev/962491662436 
(and removed the release tags to that with 2455ab8cb01c)
Comment on attachment 8629216 [details] [diff] [review]
Create directory before trying to write to it

This works for me on a borrowed slave, but I want to run it by you before landing on default on beta, and possibly elsewhere.
Attachment #8629216 - Flags: review?(mh+mozilla)
Comment on attachment 8629216 [details] [diff] [review]
Create directory before trying to write to it

Review of attachment 8629216 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/testsuite-targets.mk
@@ +418,5 @@
>  
>  test-packages-manifest:
>  	@rm -f $(MOZ_TEST_PACKAGES_FILE)
> +ifndef UNIVERSAL_BINARY
> +	$(NSINSTALL) -D $(DIST)/$(PKG_PATH)

$(dir $(MOZ_TEST_PACKAGES_FILE))
Attachment #8629216 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/d2c37bf5d4a6
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
status-firefox40: --- → fixed
status-firefox41: --- → affected
(Assignee)

Comment 16

3 years ago
Comment on attachment 8629216 [details] [diff] [review]
Create directory before trying to write to it

Review of attachment 8629216 [details] [diff] [review]:
-----------------------------------------------------------------

We'll need this for aurora too. I'll file a follow up for the fix to central.
Attachment #8629216 - Flags: approval-mozilla-aurora?
(In reply to Chris Manchester [:chmanchester] from comment #16)

Thanks for catching this. Please note that what landed is slightly different from attachment 8629216 [details] [diff] [review]. See https://hg.mozilla.org/releases/mozilla-beta/rev/7b632d539a00.
(Assignee)

Updated

3 years ago
Blocks: 917999
(Assignee)

Updated

3 years ago
Attachment #8629067 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

3 years ago
Attachment #8629216 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 18

3 years ago
The rest of bug 917999 is on aurora now, I'll do the rest of the uplifts in bug 1181732
status-firefox41: affected → fixed
status-firefox39: --- → fixed
status-firefox-esr38: --- → fixed
You need to log in before you can comment on or make changes to this bug.