Remove-All in password manager should be disabled in no sites in list

VERIFIED FIXED in mozilla0.9.8

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: morse, Assigned: morse)

Tracking

Trunk
mozilla0.9.8
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
1. Open password-manager dialog (tasks->privacy->password-manager->view
2. Go to passwords-never-saved tab
3. If any sites are present in the list, remove them

expected result: Remove-All button should now be disabled
acutal result: Remove-All button is enabled even though list is empty

Note that related to this is a js error saying:

   document.getElementById("removeAllRejects") has no properties

This error is the cause of the symptom being reported.
(Assignee)

Comment 1

17 years ago
See also comment #3 in bug 117023
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 2

17 years ago
Created attachment 63416 [details] [diff] [review]
fix js error, symptom then disappears
(Assignee)

Comment 3

17 years ago
cc'ing alecf and sgehani for reviews

Comment 4

17 years ago
Comment on attachment 63416 [details] [diff] [review]
fix js error, symptom then disappears

sr=alecf
Attachment #63416 - Flags: superreview+

Comment 5

17 years ago
Comment on attachment 63416 [details] [diff] [review]
fix js error, symptom then disappears

r=sgehani
Attachment #63416 - Flags: review+
(Assignee)

Comment 6

17 years ago
Patch checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
Verified fixed win xp build 2002032803
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.