Status

()

Toolkit
Places
RESOLVED WONTFIX
2 years ago
8 months ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I only have my browsing history back to September 2014. I would like to not loose history entries.
Could you please tell me value of places.history.expiration.transient_current_max_pages and the size of the places.sqlite?
Btw, more or less, my history is the same, it goes up to September 2014, that is 10 months.
It's possible to disable expiration and retain history forever, but it's not suggested, cause the awesomebar performance can suffer quite a lot if the database grows too much. The current expiration is setup so that we can guarantee a good experience.

My add-on can do that:
https://addons.mozilla.org/en-US/firefox/addon/expire-history-by-days/
we could also try to tweak expiration so that for old pages it retains 1 visit, until a second larger threshold, it's something that I was evaluating from some time. Though I don't know when history will get some dev resources to work on such improvements.
(Reporter)

Comment 4

2 years ago
places.history.expiration.transient_current_max_pages  = 104858

my places database is 70M

What's the cause of the performance problems with large histories?
(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> What's the cause of the performance problems with large histories?

we don't have a fulltext index, so we must do a scan table to fetch the awesomebar entries, that means go through most of the entries in some cases (few sparsed matches, or very low frecency matches)
plus the fact we have stupid views that try to show all of history at once.
btw, if you have an ssd, you can likely set places.history.expiration.max_pages (hidden pref) to an higher value than the current places.history.expiration.transient_current_max_pages, this will then copy the value and that will be the new limit (don't recall if that requires a restart).

Comment 7

8 months ago
we don't plan to have infinite history atm, it can be increased through prefs, but then we can't guarantee perf yet.
we will re evaluate limits in future
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.