db/sqlite3/src/libdb_sqlite3_src.a needed by libmozsqlite3.so

RESOLVED FIXED

Status

SeaMonkey
Release Engineering
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

(Blocks: 1 bug)

Trunk

Firefox Tracking Flags

(firefox42 affected)

Details

Attachments

(2 obsolete attachments)

(Assignee)

Description

3 years ago
l10n nightly builds failing at (make_config step) with the following error:

make[1]: Entering directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/config'
mkdir -p '.deps/'
host_nsinstall.o
/tools/gcc-4.7.3-0moz1/bin/gcc -o host_nsinstall.o -c -gdwarf-2 -DXP_UNIX -MD -MP -MF .deps/host_nsinstall.o.pp -O3  -DUNICODE -D_UNICODE -I/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config -I.  -I../dist/include  -I/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/dist/include/nspr /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config/nsinstall.c
host_pathsub.o
/tools/gcc-4.7.3-0moz1/bin/gcc -o host_pathsub.o -c -gdwarf-2 -DXP_UNIX -MD -MP -MF .deps/host_pathsub.o.pp -O3  -DUNICODE -D_UNICODE -I/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config -I.  -I../dist/include  -I/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/dist/include/nspr /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config/pathsub.c
nsinstall_real
/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config/expandlibs_exec.py -- /tools/gcc-4.7.3-0moz1/bin/gcc -o nsinstall_real -gdwarf-2 -DXP_UNIX -MD -MP -MF .deps/nsinstall_real.pp -O3  -DUNICODE -D_UNICODE  host_nsinstall.o host_pathsub.o  
cp nsinstall_real nsinstall.tmp
mv nsinstall.tmp nsinstall
../config/nsinstall -R -m 755 'nsinstall' '../dist/bin'
../config/nsinstall -R -m 644 '../mozilla-config.h' '../dist/include'
/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/toolkit/xre/make-platformini.py --print-buildid > buildid
mkdir -p 'system_wrappers/'
/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/_virtualenv/bin/python -m mozbuild.action.preprocessor -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -DMOZ_ENABLE_PROFILER_SPS='1' -DMOZILLA_VERSION='"42.0a1"' -DMOZILLA_VERSION_U='42.0a1' -DMOZILLA_UAVERSION='"42.0"' -DXP_LINUX='1' -DD_INO='d_ino' -DMOZ_DEBUG_SYMBOLS='1' -DSTDC_HEADERS='1' -DHAVE_VISIBILITY_HIDDEN_ATTRIBUTE='1' -DHAVE_VISIBILITY_ATTRIBUTE='1' -DHAVE_DIRENT_H='1' -DHAVE_GETOPT_H='1' -DHAVE_SYS_BITYPES_H='1' -DHAVE_MEMORY_H='1' -DHAVE_UNISTD_H='1' -DHAVE_GNU_LIBC_VERSION_H='1' -DHAVE_NL_TYPES_H='1' -DHAVE_MALLOC_H='1' -DHAVE_X11_XKBLIB_H='1' -DHAVE_CPUID_H='1' -DHAVE_SYS_QUOTA_H='1' -DHAVE_SYS_SYSMACROS_H='1' -DHAVE_LINUX_QUOTA_H='1' -DHAVE_LINUX_IF_ADDR_H='1' -DHAVE_LINUX_RTNETLINK_H='1' -DHAVE_SYS_QUEUE_H='1' -DHAVE_SYS_TYPES_H='1' -DHAVE_NETINET_IN_H='1' -DHAVE_BYTESWAP_H='1' -DHAVE_SYS_CDEFS_H='1' -DHAVE_DLOPEN='1' -DHAVE_DLADDR='1' -DHAVE_MEMMEM='1' -DFUNCPROTO='15' -D_REENTRANT='1' -DHAVE_PTHREAD_H='1' -DHAVE_STAT64='1' -DHAVE_LSTAT64='1' -DHAVE_TRUNCATE64='1' -DHAVE_GMTIME_R='1' -DHAVE_LOCALTIME_R='1' -DHAVE_CLOCK_MONOTONIC='1' -DHAVE_RES_NINIT='1' -DHAVE_LANGINFO_CODESET='1' -DVA_COPY='va_copy' -DHAVE_VA_COPY='1' -DHAVE_THREAD_TLS_KEYWORD='1' -DHAVE_I18N_LC_MESSAGES='1' -DHAVE_LOCALECONV='1' -DMALLOC_H='<malloc.h>' -DHAVE_ALLOCA_H='1' -DHAVE_STRNDUP='1' -DHAVE_POSIX_MEMALIGN='1' -DHAVE_MEMALIGN='1' -DHAVE_MALLOC_USABLE_SIZE='1' -DHAVE_MALLOC_H='1' -DMALLOC_USABLE_SIZE_CONST_PTR='' -DHAVE_VALLOC='1' -DTARGET_XPCOM_ABI='"x86-gcc3"' -DNIGHTLY_BUILD='1' -DE10S_TESTING_ONLY='1' -DMOZ_UPDATE_CHANNEL='nightly' -DEARLY_BETA_OR_EARLIER='1' -DMOZ_BUILD_APP='../suite' -DMOZ_X11='1' -DMOZ_WIDGET_GTK2='1' -DMOZ_WIDGET_GTK='2' -DMOZ_PDF_PRINTING='1' -DMOZ_ENABLE_XREMOTE='1' -DMOZ_INSTRUMENT_EVENT_LOOP='1' -DGLIB_VERSION_MIN_REQUIRED='GLIB_VERSION_2_26' -DGLIB_VERSION_MAX_ALLOWED='GLIB_VERSION_2_26' -DNS_PRINTING='1' -DNS_PRINT_PREVIEW='1' -DMOZ_DISTRIBUTION_ID='"org.mozilla"' -DMOZ_ENABLE_GIO='1' -DMOZ_ENABLE_GCONF='1' -DMOZ_ENABLE_DBUS='1' -DACCESSIBILITY='1' -DMOZ_WEBRTC='1' -DMOZ_WEBRTC_ASSERT_ALWAYS='1' -DMOZ_WEBRTC_SIGNALING='1' -DMOZ_PEERCONNECTION='1' -DMOZ_SCTP='1' -DMOZ_SRTP='1' -DMOZ_SAMPLE_TYPE_FLOAT32='1' -DMOZ_WEBSPEECH='1' -DMOZ_WEBSPEECH_TEST_BACKEND='1' -DMOZ_RAW='1' -DATTRIBUTE_ALIGNED_MAX='64' -DMOZ_WEBM='1' -DMOZ_FFMPEG='1' -DMOZ_FMP4='1' -DMOZ_EME='1' -DMOZ_MEDIA_NAVIGATOR='1' -DMOZ_VPX='1' -DMOZ_VPX_ERROR_CONCEALMENT='1' -DVPX_X86_ASM='1' -DMOZ_VPX_NO_MEM_REPORTING='1' -DMOZ_WAVE='1' -DMOZ_VORBIS='1' -DMOZ_WEBM_ENCODER='1' -DMOZ_GSTREAMER='1' -DGST_API_VERSION='"0.10"' -DMOZ_PERMISSIONS='1' -DENABLE_SYSTEM_EXTENSION_DIRS='1' -DMOZ_WEBGL_CONFORMANT='1' -DMOZ_GAMEPAD='1' -DMOZ_CRASHREPORTER='1' -DMOZ_CRASHREPORTER_ENABLE_PERCENT='100' -DMOZ_UPDATER='1' -DENABLE_TESTS='1' -DGTEST_HAS_RTTI='0' -DMOZ_GMP_SANDBOX='1' -DMOZ_SANDBOX='1' -DMOZ_FEEDS='1' -DMOZ_HELP_VIEWER='1' -DMOZ_SAFE_BROWSING='1' -DMOZ_URL_CLASSIFIER='1' -DGL_PROVIDER_GLX='1' -DMOZ_STACKWALKING='1' -DMOZ_LOGGING='1' -DFORCE_PR_LOG='1' -DMOZ_GLUE_IN_PROGRAM='1' -DMOZ_REPLACE_MALLOC='1' -DMOZ_MEMORY='1' -DMOZ_MEMORY_LINUX='1' -DMOZ_SUITE='1' -DMOZ_MORK='1' -DHAVE_MOVEMAIL='1' -DMOZ_SECUREELEMENT='1' -DHAVE___CXA_DEMANGLE='1' -DHAVE__UNWIND_BACKTRACE='1' -DJS_DEFAULT_JITREPORT_GRANULARITY='3' -DMOZ_OMNIJAR='1' -DMOZ_USER_DIR='".mozilla"' -DHAVE_FT_BITMAP_SIZE_Y_PPEM='1' -DHAVE_FT_GLYPHSLOT_EMBOLDEN='1' -DHAVE_FT_LOAD_SFNT_TABLE='1' -DHAVE_FONTCONFIG_FCFREETYPE_H='1' -DMOZ_TREE_PIXMAN='1' -DHAVE_STDINT_H='1' -DHAVE_INTTYPES_H='1' -DMOZ_TREE_CAIRO='1' -DMOZ_ENABLE_SKIA='1' -DUSE_SKIA='1' -DUSE_SKIA_GPU='1' -DMOZ_XUL='1' -DMOZ_PROFILELOCKING='1' -DENABLE_MARIONETTE='1' -DBUILD_CTYPES='1' -DMOZ_PLACES='1' -DMOZ_SOCIAL='1' -DMOZ_SERVICES_COMMON='1' -DMOZ_SERVICES_CRYPTO='1' -DMOZ_SERVICES_SYNC='1' -DMOZ_SERVICES_CLOUDSYNC='1' -DMOZ_BINARY_EXTENSIONS='1' -DMOZ_MACBUNDLE_ID='org.mozilla.seamonkey' -DMOZ_B2G_VERSION='"1.0.0"' -DMOZ_B2G_OS_NAME='""' -DMOZ_APP_UA_NAME='""' -DMOZ_APP_UA_VERSION='"2.39a1"' -DFIREFOX_VERSION='42.0a1' -DMOZ_TELEMETRY_DISPLAY_REV='2' -DMOZ_DATA_REPORTING='1' -DMOZ_DLL_SUFFIX='".so"' -DHAVE_POSIX_FADVISE='1' -DHAVE_POSIX_FALLOCATE='1' -DXP_UNIX='1' -DMOZ_ACCESSIBILITY_ATK='1' -DATK_MAJOR_VERSION='1' -DATK_MINOR_VERSION='28' -DATK_REV_VERSION='0' -DA11Y_LOG='1' -DEXPOSE_INTL_API='1' -DENABLE_INTL_API='1' -DU_STATIC_IMPLEMENTATION='1' -DU_USING_ICU_NAMESPACE='0' -DMOZ_STATIC_JS='1' \
	-DMOZ_TREE_CAIRO=1 \
	-DMOZ_TREE_PIXMAN=1 \
	-DMOZ_NATIVE_HUNSPELL= \
	-DMOZ_NATIVE_BZ2= \
	-DMOZ_NATIVE_ZLIB= \
	-DMOZ_NATIVE_PNG= \
	-DMOZ_NATIVE_JPEG= \
	-DMOZ_NATIVE_LIBEVENT= \
	-DMOZ_NATIVE_LIBVPX= \
	-DMOZ_NATIVE_ICU= \
	/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config/system-headers | /usr/bin/perl /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/nsprpub/config/make-system-wrappers.pl system_wrappers
../config/nsinstall -R system_wrappers ../dist
/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config/make-stl-wrappers.py stl_wrappers gcc /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config/gcc-stl-wrapper.template.h /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config/stl-headers
/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/config/nsinstall.py -t stl_wrappers ../dist
touch ../dist/stl_wrappers/sentinel
make[1]: Leaving directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/config'
make[1]: Entering directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/config'
make[2]: Entering directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir'
make recurse_compile
make[2]: Circular /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/CLOBBER <- /builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/mozilla/CLOBBER dependency dropped.
make[3]: Entering directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir'
make[4]: Entering directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/config/external/sqlite'
make[4]: Leaving directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/config/external/sqlite'
make[4]: *** No rule to make target `../../../db/sqlite3/src/libdb_sqlite3_src.a', needed by `libmozsqlite3.so'.  Stop.
make[3]: *** [config/external/sqlite/target] Error 2
make[3]: Leaving directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir'
make[2]: *** [compile] Error 2
make[2]: Leaving directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir'
make[1]: *** [compile] Error 2
make[1]: Leaving directory `/builds/slave/c-cen-t-lnx-l10n-ntly/build/comm-central-trunk/objdir/config'
make: *** [default] Error 2
(Assignee)

Comment 1

3 years ago
Talking to :glandium over irc, apparently we hit bug 1169937.

Solution is to change the make_config step to run |make export| in the
objdir/config.
(Assignee)

Updated

3 years ago
Component: Build Config → Release Engineering
(Assignee)

Updated

3 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Created attachment 8629274 [details] [diff] [review]
change to run make export
Attachment #8629274 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 3

3 years ago
Created attachment 8629289 [details] [diff] [review]
proposed patch (v2)
Attachment #8629274 - Attachment is obsolete: true
Attachment #8629274 - Flags: review?(bugspam.Callek)
Attachment #8629289 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 4

3 years ago
Well, the patch is manually patched on the master.  

and it looks like it works.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1187798
(Assignee)

Updated

3 years ago
Blocks: 1072713
(Assignee)

Comment 6

2 years ago
Comment on attachment 8629289 [details] [diff] [review]
proposed patch (v2)

This was pushed in bug 1072713.
Attachment #8629289 - Attachment is obsolete: true
Attachment #8629289 - Flags: review?(bugspam.Callek)
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.