Closed Bug 1180146 Opened 4 years ago Closed 4 years ago

App icon is not loaded when HTTP Basic Auth is required

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bugzilla.mozilla.org, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150602115007

Steps to reproduce:

1. Open a website that offers the installation of a WebApp, but requires http Basic Auth Login
2. Install the (hosted) app.


Actual results:

The app icon could not be loaded by the homescreen because no cookies or auth headers were sent for the app icon request although the user was already logged into the webpage.

(The server (correctly) returned a 401 status code.)

Instead, the default fallback app icon is shown.


Expected results:

The correct app icon should have been loaded from the server (cookies should have been sent in the request).
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.