Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: krejca, Unassigned)

Tracking

Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8629343 [details]
thinline.cz.xml

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.6.0
Build ID: 20150331233809

Comment 1

4 years ago
Dear reporter, If you have time enough, please describe the issue properly and visit https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines to understand bug reporting process.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

4 years ago
(In reply to Towkir Ahmed from comment #1)
> Dear reporter, If you have time enough, please describe the issue properly
> and visit
> https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines
> to understand bug reporting process.
> 
> Thanks

I'd like to have attached XML added to ISPDB database for Thunderbird autoconfig.
Thanks
(Reporter)

Updated

4 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
krejca, do you represent thinline? If so, is there any reason why you do not host this yourself?
(Reporter)

Comment 4

4 years ago
Yes Kent, I represent thinline.cz, czech ISP - hosting service provider. Now we have >100000 mailboxes on approx 20000 client domains. All domains have MX records in form mx*.thinline.cz. We can't host it ourselves, because significant part of our customers doesn't use our DNS, so we can't add autoconfig subdomain to these zones.
Thinline.cz is more known as Český-hosting.cz (http://www.cesky-hosting.cz/). But the MX records are mx****.thinline.cz, so Thunderbird should be able to find them according to this domain in the ISPDB if added.
Blocks: 593146
Attachment #8629343 - Flags: review?(gozer)
Attachment #8629343 - Flags: review?(bwinton)
Attachment #8629343 - Flags: review?(ben.bucksch)
(In reply to krejca from comment #4)
> Yes Kent, I represent thinline.cz, czech ISP - hosting service provider. Now
> we have >100000 mailboxes on approx 20000 client domains. All domains have
> MX records in form mx*.thinline.cz. We can't host it ourselves, because
> significant part of our customers doesn't use our DNS, so we can't add
> autoconfig subdomain to these zones.

krejca, I think :rkent's point was that if you stand a copy of this XML file up at autoconfig.thinline.cz, it will automatically work.

The logic used by Thunderbird, Firefox OS email, etc. is that if the domain is "xampl.tld" with a mx of "blah.thinline.cz" we will first try to access:
- http[s]://xampl.tld/autodiscover/autodiscover.xml
- http[s]://autodiscover.xampl.tld/autodiscover/autodiscover.xml
but then when we perform the MX entry lookup, we will also try both of:
- http[s]://thinline.cz/autodiscover/autodiscover.xml
- http[s]://autodiscover.thinline.cz/autodiscover/autodiscover.xml

It is possible for you to do this?  (Note that making the autoconfig available with a valid certificate on https is needed for Firefox OS email and likely in the medium-term future for Thunderbird.)
Flags: needinfo?(krejca)
Comment on attachment 8629343 [details]
thinline.cz.xml

(I am taking over review duties for this component, but ideally we'd like this self-hosted, so clearing review for now.)
Attachment #8629343 - Flags: review?(gozer)
Attachment #8629343 - Flags: review?(bwinton)
Attachment #8629343 - Flags: review?(ben.bucksch)
(Reporter)

Comment 8

3 years ago

(In reply to Andrew Sutherland [:asuth] from comment #6)
> (In reply to krejca from comment #4)
> > Yes Kent, I represent thinline.cz, czech ISP - hosting service provider. Now
> > we have >100000 mailboxes on approx 20000 client domains. All domains have
> > MX records in form mx*.thinline.cz. We can't host it ourselves, because
> > significant part of our customers doesn't use our DNS, so we can't add
> > autoconfig subdomain to these zones.
> 
> krejca, I think :rkent's point was that if you stand a copy of this XML file
> up at autoconfig.thinline.cz, it will automatically work.
> 
> The logic used by Thunderbird, Firefox OS email, etc. is that if the domain
> is "xampl.tld" with a mx of "blah.thinline.cz" we will first try to access:
> - http[s]://xampl.tld/autodiscover/autodiscover.xml
> - http[s]://autodiscover.xampl.tld/autodiscover/autodiscover.xml
> but then when we perform the MX entry lookup, we will also try both of:
> - http[s]://thinline.cz/autodiscover/autodiscover.xml
> - http[s]://autodiscover.thinline.cz/autodiscover/autodiscover.xml
> 
> It is possible for you to do this?  (Note that making the autoconfig
> available with a valid certificate on https is needed for Firefox OS email
> and likely in the medium-term future for Thunderbird.)

Andrew, thanks for the information about the autodiscover logic, I didn't know it, as it is not anywhere in the documentation. However it is not working even if http[s]://autodiscover.thinline.cz/autodiscover/autodiscover.xml exists.

I've tried it in TB 38.1.0 on Windows 7, TB 31.7.0 on Ubuntu and Icedove 31.7.0 on Debian. Tracing the run of the latter, it only tries to find local XML file, then  http://autoconfig.xampl.tld/mail/config-v1.1.xml, then https://live.mozillamessaging.com/autoconfig/v1.1/xampl.tld and finally https://live.mozillamessaging.com/autoconfig/v1.1/thinline.cz, nothing more. And indeed, there are no such requests for both autoconfig.thinline.cz and thinline.cz in our webserver's access log.

So in my opinion, the autodiscover process doesn't work in the way you described. Can you please confirm, that your previous information are correct?
Flags: needinfo?(krejca)
Ugh, I'm so sorry, I was in a hurry when writing that message and posted the wrong URLs from our unit tests.  Those are the autodiscover URLs Firefox OS email uses for ActiveSync autodiscover.  The autoconfig URL's we will fetch are:

https://autoconfig.xampl.tld/mail/config-v1.1.xml?emailaddress=user%40xampl.tld
https://xampl.tld/.well-known/autoconfig/mail/config-v1.1.xml?emailaddress=user%40xampl.tld

You can ignore the get requests if you want.  Those would matter if you wanted to provide different settings for different users.  A static file is fine.
Er, and to clarify, Firefox OS email will access them via https (yes S) and Thunderbird will access them via http (no S).
Further ugh.  Your analysis is correct; although Firefox OS email will probe your server configurations after the MX lookup, looking at the Thunderbird code at https://dxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/accountcreation/fetchConfig.js#183, Thunderbird will not.  It just checks the ISPDB after it does an MX lookup.  I apologize for misleading you on this front, I'm still getting my bearings doing reviews for this component.  I thought we were doing the same thing in Firefox OS email as Thunderbird except for our strict use of https.

Since Thunderbird's big 38 release is already out the door, I think this is an argument of hosting the entry in the ISPDB.  Ideologically, it would still be great if you could host the entry via https at autoconfig.thinline.cz, but that might do more harm than good while Thunderbird can't take advantage of it.  I'm very open to your thoughts here.

Do you have a problem if I change your config file to favor initial-TLS for SMTP over STARTTLS like is done for IMAP and land that?  It should lead to faster connection establishment for users.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(krejca)
(Reporter)

Comment 12

3 years ago
(In reply to Andrew Sutherland [:asuth] from comment #11)
> Further ugh.  Your analysis is correct; although Firefox OS email will probe
> your server configurations after the MX lookup, looking at the Thunderbird
> code at
> https://dxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/
> accountcreation/fetchConfig.js#183, Thunderbird will not.  It just checks
> the ISPDB after it does an MX lookup.  I apologize for misleading you on
> this front, I'm still getting my bearings doing reviews for this component. 
> I thought we were doing the same thing in Firefox OS email as Thunderbird
> except for our strict use of https.
> 
> Since Thunderbird's big 38 release is already out the door, I think this is
> an argument of hosting the entry in the ISPDB.  Ideologically, it would
> still be great if you could host the entry via https at
> autoconfig.thinline.cz, but that might do more harm than good while
> Thunderbird can't take advantage of it.  I'm very open to your thoughts here.
> 
> Do you have a problem if I change your config file to favor initial-TLS for
> SMTP over STARTTLS like is done for IMAP and land that?  It should lead to
> faster connection establishment for users.

OK Andrew, it's not a problem for us to host the config for Firefox OS email via https://autoconfig.thinline.cz, but what is the correct path to the XML file then? Is it https://autoconfig.thinline.cz/mail/config-v1.1.xml , https://autoconfig.thinline.cz/.well-known/autoconfig/mail/config-v1.1.xml or anything else?

Also, I don't quite understand your suggestion about preferred SMTP setup. Did you mean to prefer SMTPS on 465 over STARTTLS on 587 and 25 resp.? I thought that the preferred protocol these days is STARTTLS on 587 for SMTP message submission (client to server) and STARTTLS on 25 for server-to-server communication. And that the SMTPS service on port 465 is deprecated and only supported for historical reasons (for old e-mail clients). Or am I wrong?
Flags: needinfo?(krejca)
(In reply to krejca from comment #12)
> OK Andrew, it's not a problem for us to host the config for Firefox OS email
> via https://autoconfig.thinline.cz, but what is the correct path to the XML
> file then? Is it https://autoconfig.thinline.cz/mail/config-v1.1.xml ,
> https://autoconfig.thinline.cz/.well-known/autoconfig/mail/config-v1.1.xml
> or anything else?

Thank you for your willingness to host it yourself!  In comment 11 I think I convinced myself the best option is just for us to host it in the ISPDB, so I think we'll just do that.

> Also, I don't quite understand your suggestion about preferred SMTP setup.
> Did you mean to prefer SMTPS on 465 over STARTTLS on 587 and 25 resp.?

Yes.

> I
> thought that the preferred protocol these days is STARTTLS on 587 for SMTP
> message submission (client to server) and STARTTLS on 25 for
> server-to-server communication. And that the SMTPS service on port 465 is
> deprecated and only supported for historical reasons (for old e-mail
> clients). Or am I wrong?

There have definitely been people suggesting that this is the case, but the rationale doesn't make much sense unless you are experiencing a port shortage and need 465 for something else.  We always want to establish a TLS connection, and we can't trust anything the server says prior to the negotiation of TLS, so every network roundtrip prior to TLS negotiation is wasted bandwidth and latency, so initial-TLS is preferred.

So what really matters is if your server listens on port 465 and it will continue to do so.

I'm going to land your file now with port 465 SMTP moved up in a few moments.  Please reopen if you are really hoping to get rid of port 465 someday (in which case we should probably remove it from the XML file.)
Committed revision 143810.

Thanks again for submitting this and your willingness to self-host!
Status: NEW → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
It took longer than expected to show up (26 minutes?), but it's there now:
https://autoconfig.thunderbird.net/v1.1/thinline.cz
You need to log in before you can comment on or make changes to this bug.