Disable Unified Complete in Firefox 41

RESOLVED FIXED in Firefox 41

Status

()

Toolkit
Places
P1
normal
Rank:
4
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

Trunk
mozilla41
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox40 unaffected, firefox41 fixed, firefox42 unaffected)

Details

(Whiteboard: [unifiedcomplete][fxsearch])

Attachments

(1 attachment)

Unified complete is currently enabled in Aurora.

Considered the first feature taking good benefits from it is search suggestions, and those are only enabled in Firefox 42 (bug 958204).
Also considering the fact we still have regression (bug 1176437, bug 1172937, bug 1047613) that we are working on right now.

I feel like the benefit in keeping the feature enabled in Aurora is not enough vs the price to keep it up to date with nightly by uplifiting patches and tracking all the changes.
I think we should release it along with search suggestions, or in the version where most regressions will be fixed. Releasing a non-top quality awesomebar experience should be a no-go.

However, I'd be fine doing this disabling closer to the Beta merge, so we get more Aurora testing.
Flags: needinfo?(dtownsend)
Flags: firefox-backlog?
status-firefox40: --- → unaffected
status-firefox41: --- → affected
status-firefox42: affected → unaffected
Blocks: 995091
Yeah this makes sense
Flags: needinfo?(dtownsend)
Flags: firefox-backlog?
Flags: firefox-backlog+
Assignee: nobody → mak77
Status: NEW → ASSIGNED

Updated

2 years ago
Rank: 4
Created attachment 8631477 [details] [diff] [review]
patch v1

https://treeherder.mozilla.org/#/jobs?repo=try&revision=94fed337de68
Comment on attachment 8631477 [details] [diff] [review]
patch v1

ok, the failures don't look related to this.
Attachment #8631477 - Flags: review?(adw)

Updated

2 years ago
Attachment #8631477 - Flags: review?(adw) → review+
Comment on attachment 8631477 [details] [diff] [review]
patch v1

Approval Request Comment
[Feature/regressing bug #]: unified complete
[User impact if declined]: the feature is not on-par with quality to ride the trains to release
[Describe test coverage new/current, TreeHerder]: unit tests
[Risks and why]: no risk, just reverting to the old component
[String/UUID change made/needed]: none
Attachment #8631477 - Flags: approval-mozilla-aurora?
This should only land in Aurora.

Comment 6

2 years ago
Comment on attachment 8631477 [details] [diff] [review]
patch v1

Approving uplift to Aurora because low risk, only backing out.
Attachment #8631477 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/7f732682a8ec
status-firefox41: affected → fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Depends on: 1191919
You need to log in before you can comment on or make changes to this bug.