New tab icon (+) overlays with window minimize icon in Windows 10

RESOLVED WORKSFORME

Status

()

defect
--
major
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: 4myforums, Unassigned)

Tracking

39 Branch
Unspecified
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
Posted image Capture.JPG
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Open multiple new tabs to fill top of screen


Actual results:

When the list of tabs fills the top, the new tab control (big +) is overlayed by the window minimize controls, and cannot be used. This happens with Thunderbird as well, but none of my other apps.


Expected results:

The new tab control should not extend as far left. This does not happen with Windows 7 or 8.1.

Updated

4 years ago
OS: Unspecified → Windows 10

Updated

4 years ago
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Summary: Tabs + overlay window controls in Windows 10 → New tab icon (+) overlays with window minimize icon in Windows 10

Comment 1

4 years ago
Look's like windows is updating daily and it was probably a windows bug which has already been fixed from windows

Can you check on yours now (after updating windows) ?
Flags: needinfo?(4myforums)
(Reporter)

Comment 3

4 years ago
I am running the latest Windows Technical Preview 10162 (Fast ring) and the problem is still there, as it has been for the last few releases. This Windows build is expected to be very similar RTM so the problem will likely exist in the final version. Changing the screen resolution does not make a difference.

Rezaul: In the sample "Looks Fine on today's update", open one more tap to see the problem. The big + for a New Tab is overlaid by the Minimize button.

Thanks for investigating.
Flags: needinfo?(4myforums)

Comment 4

4 years ago
(In reply to Chris from comment #3)
> I am running the latest Windows Technical Preview 10162 (Fast ring) and the
> problem is still there, as it has been for the last few releases. This
> Windows build is expected to be very similar RTM so the problem will likely
> exist in the final version. Changing the screen resolution does not make a
> difference.
Probably installing a stable version of wndows was a better idea, I have seen this on some other pc too, but on rezaul's one, it was totally fine

> Rezaul: In the sample "Looks Fine on today's update", open one more tap to
> see the problem. The big + for a New Tab is overlaid by the Minimize button.

There were almost 14 tabs opened while taking the screenshot and I was there seeing the + icon does not go any further to right. no matter how much tabs you open.
(Reporter)

Comment 5

4 years ago
Just installed the latest WTP 10166 and the problem still exists. Let me know if you would like any additional information about my system/configuration as I am not expecting this to go away on the Windows side.

Comment 6

4 years ago
Rezaul had a 64 bit version windows. Chris, are you running a 64 bit version too ?
Ratul could reproduce this issue, Can you please tell your windows bit Ratul ???
Flags: needinfo?(ratulbracu)
(Reporter)

Comment 7

4 years ago
Edition: Windows 10 Pro Insider Preview
Processor: Intel Core i5-4200
RAM: 8GB
System: 64-bit, x64 based processor
Screen resolution: 3200x1800
Display adapter: Intel HD Graphics
With Firefox 39 under Win 10 10159 64-bit I can't see the issue. The Windows's icons are placed above Firefox's tabs. Can you try again with a clean profile [1]? I see that there are a lot of add-ons installed and one of them could cause this.

[1] https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(4myforums)
(Reporter)

Comment 9

4 years ago
Posted image Capture1
Flags: needinfo?(4myforums)
(Reporter)

Comment 10

4 years ago
Posted image Capture2
(Reporter)

Comment 11

4 years ago
Created a new profile with no add-ons. Results were:
1. Running Firefox in a window was acceptable with the new tab + located below the minimize button (see Capture1). It would be preferable for it to be located to the left of the minimize button.
2. Running Firefox in full screen mode exhibited the old problem (see Capture2).
Thanks, Chris. Moving to a more appropriate component.
Component: Untriaged → Tabbed Browser

Comment 13

4 years ago
Have seen strange behaviour of firefox with high resolution displays, may be this issue is happening on very large screens with windows 10.

Chris is using a display with 3200x1800 px resolution
(Reporter)

Comment 14

4 years ago
I tried changing the resolution from 3200x1800 to 1920x1080, 2048x1152, and 1366x768. The overlay still occurs. Even though the resolution was changed the actual Firefox resolution is identical (screen shots are identical).

It may not have been obvious from my earlier screen shots, but I have the Menu Bar turned off. When it is activated (Alt key or View-Toolbars) there is space created at the top for the commands and no overlay occurs. The bug/resolution is that the rightmost tab and new tab + extend too far over. This is when the overlay happens.

There is no overlay with my Win 8.1 laptop set at 2160x1440, or Win 7 desktop set at 1920x1080. Both laptops are running Intel HD Grapics drivers 10.18 but different sub .xx.xxxx levels, and the desktop is also Intel HG Graphics driver 10.15.

Could it be that Win 10 is reporting the size of the window control commands differently?

Comment 15

4 years ago
As with #1188779, I'm seeing this too but only on my Dell XPS 13 which has an Intel HD 5500 3200x1800 hi-dpi display. My desktop PC, also running Windows 10, doesn't have this issue.
(Reporter)

Comment 16

4 years ago
I have found a workaround. Change the value of layout.css.devPixelsPerPX, in about:config, from the default of -1 to 4. The overlay is gone but it increases the overall font size of everything, cutting the number of tabs displayed from 7 to 6. So I am back to the default of -1 and still hoping for a permanent fix.

FYI. My laptop and desktop previously reported as fine on earlier versions of Windows are still fine after the upgrade to Win 10.
(Reporter)

Comment 17

4 years ago
OK, problem is fixed in FireFox 40. Now I need it to be applied to Thunderbird as well.

Comment 18

4 years ago
Did you file any bug report on this same issue happening on thunderbird ? If yes, provide the bug number or link here, then I am gonna resolve this one
Flags: needinfo?(4myforums)
(Reporter)

Comment 19

4 years ago
Posted image Thunderbird overlay
No I did not report the problem with Thunderbird. An image of the overlap is attached.
Flags: needinfo?(4myforums)

Comment 20

4 years ago
Because thunderbird is another separate product of mozilla, I will request you to file another bug report against that and provide the link here, 
I am going to resolve it now, 
Thanks !
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

4 years ago
Thunderbird bug report #1193721

Updated

4 years ago
See Also: → 1193721

Updated

4 years ago
Flags: needinfo?(ratulbracu)
You need to log in before you can comment on or make changes to this bug.