Intermittent apps/system/test/marionette/browser_chrome_new_window_test.js | Browser Chrome - Open New Window open new window

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
3 years ago
5 months ago

People

(Reporter: philor, Assigned: tilman)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments, 1 obsolete attachment)

Comment hidden (empty)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 37

3 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* b2g-inbound: 2

Platform breakdown:
* mulet-linux64: 3
* b2g-linux64: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-10-05&endday=2015-10-11&tree=all

Comment 38

3 years ago
19 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 8
* try: 7
* b2g-inbound: 3
* fx-team: 1

Platform breakdown:
* mulet-linux64: 9
* b2g-linux64: 6
* android-4-3-armv7-api11: 2
* b2g-device-image: 1
* android-4-0-armv7-api11: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-10-12&endday=2015-10-18&tree=all

Comment 39

3 years ago
18 automation job failures were associated with this bug yesterday.

Repository breakdown:
* fx-team: 8
* b2g-inbound: 6
* mozilla-inbound: 4

Platform breakdown:
* mulet-linux64: 10
* b2g-linux64: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-11-13&endday=2015-11-13&tree=all

Comment 40

3 years ago
25 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 9
* fx-team: 9
* b2g-inbound: 6
* mozilla-central: 1

Platform breakdown:
* b2g-linux64: 15
* mulet-linux64: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-11-09&endday=2015-11-15&tree=all

Comment 41

3 years ago
16 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 6
* b2g-inbound: 5
* fx-team: 4
* mozilla-central: 1

Platform breakdown:
* mulet-linux64: 10
* b2g-linux64: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-11-16&endday=2015-11-16&tree=all

Comment 42

3 years ago
23 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 14
* b2g-inbound: 6
* mozilla-central: 2
* fx-team: 1

Platform breakdown:
* mulet-linux64: 12
* b2g-linux64: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-11-19&endday=2015-11-19&tree=all
Blocks: 1222215
Whiteboard: [systemsfe]
Assignee: nobody → francisco
Status: NEW → ASSIGNED
After expending some time in the bug, was able to reproduce thanks to :mhenretty and :mcav by using the cpulimit script here:

https://groups.google.com/d/msg/mozilla.dev.fxos/wHKnQE1gOxE/QZKfAzePAgAJ

Checking the previous comments and the links to the fails in treeherder like:

https://treeherder.mozilla.org/logviewer.html#?repo=fx-team&job_id=5749386

Locally also got the same error:
Error: timeout exceeded!
      at Object.Client.waitForSync (/Users/arcturus/dev/git/community/gaia/node_modules/marionette-client/lib/marionette/client.js:759:16)
      at Object.Client.waitFor (/Users/arcturus/dev/git/community/gaia/node_modules/marionette-client/lib/marionette/client.js:725:60)
      at Context.<anonymous> (/Users/arcturus/dev/git/community/gaia/apps/system/test/marionette/browser_chrome_new_window_test.js:78:12)

In that line we wait for the Clock app to be displayed in the foreground, and the reason why we don't transition from the new browser chrome window to the clock app is cause the clock app died.

Still need to understand the causes why the clock dies on low cpu availability.

Comment 44

3 years ago
69 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 41
* b2g-inbound: 12
* fx-team: 10
* mozilla-central: 5
* try: 1

Platform breakdown:
* b2g-linux64: 35
* mulet-linux64: 34

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-11-16&endday=2015-11-22&tree=all

Comment 45

3 years ago
36 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 33
* b2g-inbound: 2
* fx-team: 1

Platform breakdown:
* mulet-linux64: 31
* b2g-linux64: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-11-24&endday=2015-11-24&tree=all

Comment 46

3 years ago
70 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 54
* b2g-inbound: 8
* fx-team: 6
* mozilla-central: 2

Platform breakdown:
* mulet-linux64: 47
* b2g-linux64: 23

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-11-23&endday=2015-11-29&tree=all

Comment 47

3 years ago
20 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 18
* fx-team: 1
* b2g-inbound: 1

Platform breakdown:
* mulet-linux64: 11
* b2g-linux64: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-12-01&endday=2015-12-01&tree=all

Comment 48

3 years ago
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 7
* fx-team: 5
* b2g-inbound: 3

Platform breakdown:
* b2g-linux64: 9
* mulet-linux64: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-12-02&endday=2015-12-02&tree=all

Comment 49

3 years ago
28 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 14
* fx-team: 8
* b2g-inbound: 5
* mozilla-central: 1

Platform breakdown:
* b2g-linux64: 15
* mulet-linux64: 13

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-12-04&endday=2015-12-04&tree=all

Comment 50

3 years ago
92 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 57
* fx-team: 20
* b2g-inbound: 12
* mozilla-central: 3

Platform breakdown:
* b2g-linux64: 49
* mulet-linux64: 43

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-11-30&endday=2015-12-06&tree=all

Comment 51

3 years ago
26 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 14
* fx-team: 5
* b2g-inbound: 3
* mozilla-central: 2
* gaia-master: 2

Platform breakdown:
* mulet-linux64: 13
* b2g-linux64: 11
* gaia: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-12-07&endday=2015-12-13&tree=all

Comment 52

3 years ago
31 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 16
* fx-team: 10
* mozilla-central: 2
* b2g-inbound: 2
* try: 1

Platform breakdown:
* b2g-linux64: 17
* mulet-linux64: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-12-16&endday=2015-12-16&tree=all
This is one of our worst intermittents, so I'm disabling this for now.

disabled in master: https://github.com/mozilla-b2g/gaia/commit/373a1ef64bca6f6454bb9b8af7f11fbf71dd37c8
Removing the dependency since this test is now disabled.
No longer blocks: 1222215

Comment 55

3 years ago
36 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 24
* fx-team: 6
* b2g-inbound: 4
* mozilla-central: 2

Platform breakdown:
* b2g-linux64: 21
* mulet-linux64: 15

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-12-17&endday=2015-12-17&tree=all

Comment 56

3 years ago
94 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 59
* fx-team: 21
* b2g-inbound: 8
* mozilla-central: 5
* try: 1

Platform breakdown:
* b2g-linux64: 51
* mulet-linux64: 43

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1180236&startday=2015-12-14&endday=2015-12-20&tree=all
Michael, did this disable properly?  It seems we're still hitting it frequently.
Flags: needinfo?(mhenretty)
I think so Ben. When I look at the brasstacks link from comment 56, the most recent failure I see is from 12/18, which is not unusual give the amount of time gaia changes take to propagate to mozilla-inbound (~1 day).  If I look at the logs for a recent Gij 19 run on mozilla-central ([1] for instance), I don't see browser_chrome_new_window_test.js getting run. Have you seen a more recent failure?

1.) https://public-artifacts.taskcluster.net/Eoz-WWaJQ0iLzIrFwF3rKw/0/public/logs/live_backing.log
Flags: needinfo?(mhenretty) → needinfo?(bkelly)
Sorry for the noise.  I must have misclicked brasstacks or somehow gotten stale data from it.

Should we go ahead and close this?
Flags: needinfo?(bkelly)
We should leave this open, since it is still a bad test and needs to be fixed, we just have it disabled right now. After we land bug 1222215, we will be going through and fixing and re-enabling these tests [1] one by one.

1.) https://github.com/mozilla-b2g/gaia/blob/master/shared/test/integration/tbpl-manifest.json
Keywords: leave-open
(Assignee)

Comment 61

3 years ago
I'll give it a spin. Francisco: If you wanna keep it, just take it again.
Assignee: francisco → tilman
Created attachment 8712088 [details] [review]
[gaia] tilmankamp:u1180236 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8712088 - Flags: review?(mhenretty)
Can you show me a try run with say 40 re-triggers all green? This used to be one of our worst intermittents.
Flags: needinfo?(tilman)
Attachment #8712088 - Flags: review?(mhenretty) → review+
Created attachment 8712196 [details] [review]
[gaia] tilmankamp:d1180236 > mozilla-b2g:master
Created attachment 8714092 [details] [review]
[gaia] tilmankamp:u1180236 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8712088 - Attachment is obsolete: true
(Assignee)

Comment 69

3 years ago
Comment on attachment 8714092 [details] [review]
[gaia] tilmankamp:u1180236 > mozilla-b2g:master

50/50 green runs:
https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=2e9a757b8c12822d5344ad67a6d541a84a33761e
Attachment #8714092 - Flags: review?(mhenretty)
Comment on attachment 8714092 [details] [review]
[gaia] tilmankamp:u1180236 > mozilla-b2g:master

Left a question on github. Feel free to re-flag me when you've answered it. Thanks!
Attachment #8714092 - Flags: review?(mhenretty)
(Assignee)

Comment 71

3 years ago
Comment on attachment 8714092 [details] [review]
[gaia] tilmankamp:u1180236 > mozilla-b2g:master

50/50 green test runs:
https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=3568721142fb1742a47ca4c52c00c6243365d6e8
Attachment #8714092 - Flags: review?(mhenretty)
Attachment #8714092 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 72

3 years ago
Merged into master:
https://github.com/tilmankamp/gaia/commit/47185183c76e18605e48ceccce12af04791defd7
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.