Firefox 39.0 missing language packs

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Administration
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: g633, Assigned: kmag)

Tracking

({intl})

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Updated from Firefox 38.0.5 to Firefox 39.0 on several machines using localized language packs


Actual results:

Firefox reported that the language packs are not available for 39.0


Expected results:

If 39.0 language packs are not available:

 - Warn during upgrade that language packs are not ready

 - Offer to continue using old language packs--this would be MUCH BETTER than losing all localization (for indefinite future), do you not think?
(Reporter)

Updated

3 years ago
Component: Untriaged → Translation
Keywords: intl
Component: Translation → Application Update
Product: Firefox → Toolkit
Nick, any idea what is going on here? Perhaps this is an amo bug?
Component: Application Update → Releases
Flags: needinfo?(nthomas)
Product: Toolkit → Release Engineering
QA Contact: rail
Version: 39 Branch → other
Does look like an AMO issue. eg https://addons.mozilla.org/en-US/firefox/addon/english-gb-language-pack/ has 38.0.5, but http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/39.0/win32/xpi/ has the usual set of files. Perhaps just related to the delayed shipping.
Component: Releases → Administration
Flags: needinfo?(nthomas)
Product: Release Engineering → addons.mozilla.org
QA Contact: rail
Version: other → unspecified
The lang pack upgrade process was run last week, but I guess it didn't work. Kris, can you look into this?
Assignee: nobody → kmaglione+bmo
Status: UNCONFIRMED → NEW
Ever confirmed: true
I noticed the 38.0.5 language packs release date is for last friday, so I guess the upgrade process that took place released those instead of the 39.0 ones?
AMO still thinks that 38.0.5 is the current release, so that's what I ran.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.