Closed Bug 1180329 Opened 5 years ago Closed 8 days ago

[meta] Entering numbers or single words and then pressing Enter in the location bar should result in consistent user experience (UX)

Categories

(Firefox :: Address Bar, enhancement, P3)

39 Branch
enhancement

Tracking

()

RESOLVED FIXED
Firefox 78

People

(Reporter: quality+bugzilla, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: meta)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324




Expected results:

The behavior of Firefox (tested on v39) changes depending on the DNS which the host system is currently using.  Since the DNS cannot be modified within Firefox, this leads to different experiences at different times, as well as different experiences for different Firefox users.  Further confusing the user, there is no indication to them why Firefox sometimes behaves differently or any instructions on how to make it behave the same across all systems.

When using some DNS servers, entering 'abcd' (without the single quotes) into the Location Bar results in a search being perfomed for 'abcd'.  This looks great.

When using other DNS servers, performing the identical search results in a confusing notification asking 'Did you mean to go to abcd?', followed by a search.

Toggling browser.fixup.alternate.enabled has no effect on whether or not this notification sometimes appears.

We should not be presenting a different experience to the user depending on the DNS server being used.  Consistency is key, especially in the day and age of browser add-on malware.  As we all know, there is a fair amount of malware that tries to redirect the user to another website.

I recommend changing the user interface so that it is consistent, regardless of the DNS server currently used.
OS: Unspecified → Windows 7
Hardware: Unspecified → All
Related to Bug #693808
Gijs, does this look like something for you?
Component: Untriaged → Location Bar
Flags: needinfo?(gijskruitbosch+bugs)
Flags: firefox-backlog?
Thanks for the report.

(In reply to quality+bugzilla from comment #0)
> The behavior of Firefox (tested on v39) changes depending on the DNS which
> the host system is currently using.  Since the DNS cannot be modified within
> Firefox, this leads to different experiences at different times, as well as
> different experiences for different Firefox users.  Further confusing the
> user, there is no indication to them why Firefox sometimes behaves
> differently or any instructions on how to make it behave the same across all
> systems.

On the one hand, I would agree that the current situation is not ideal. On the other... Firefox cannot (and arguably should not, where it would inhibit functionality) isolate the user from DNS changes entirely. Typical related issues include, for instance, captive wifi portals (I recently saw one with broken TLS, so getting out of it required using IE because both Firefox and Chrome balked at the cert used by the portal) and VPNs (where some addresses will sometimes exist and sometimes not). The only way I know of doing this is fixing your machine's DNS settings to override the DNS offered by the router / DHCP provider with a fixed one (Google and OpenDNS being popular choices).

> When using some DNS servers, entering 'abcd' (without the single quotes)
> into the Location Bar results in a search being perfomed for 'abcd'.  This
> looks great.
> 
> When using other DNS servers, performing the identical search results in a
> confusing notification asking 'Did you mean to go to abcd?', followed by a
> search.

Can you clarify what "abcd" case you care about? I don't really need to know the exact query, but I mean, are you concerned about the case where:

1) the user wants a particular host (e.g. "mylocalmediaserverathome" which doesn't exist on their work wifi network) rather than a search; or
2) the user wants to search, but on some DNSes, their ISP/employer/whatever has added DNS that points to a custom (usually branded) search server / query?


I'm *guessing* you mean (2).

> Toggling browser.fixup.alternate.enabled has no effect on whether or not
> this notification sometimes appears.

No, that pref is about whether we try "www.foo.com" when you try to access http://foo/ .

> We should not be presenting a different experience to the user depending on
> the DNS server being used.  Consistency is key, especially in the day and
> age of browser add-on malware. 

As noted above, complete consistency is impossible for Firefox to achieve, and in many cases it is not desirable.

> As we all know, there is a fair amount of
> malware that tries to redirect the user to another website.
> 
> I recommend changing the user interface so that it is consistent, regardless
> of the DNS server currently used.

This is easier said than done.
Blocks: 693808
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(quality+bugzilla)
Flags: needinfo?(gijskruitbosch+bugs)
Flags: firefox-backlog?
OS: Windows 7 → All
Depends on: 1080682
Priority: -- → P3
Depends on: 1412985, 1566499
Keywords: meta
Summary: Entering numbers or single words and then pressing Enter in the location bar should result in consistent user experience (UX) → [meta] Entering numbers or single words and then pressing Enter in the location bar should result in consistent user experience (UX)
Depends on: 1398567
Depends on: 1613276
Duplicate of this bug: 1627639
No longer depends on: 1566499
Duplicate of this bug: 1566499
Duplicate of this bug: 1631058
Duplicate of this bug: 1631155
Depends on: 1634327
No longer depends on: 1634327
Depends on: 1634650
Depends on: 1634592
Depends on: 1636673
Depends on: 1636583

All the dependencies have been fixed, we'll track remaining issues as single bugs.

Flags: needinfo?(quality+bugzilla)
Status: NEW → RESOLVED
Closed: 8 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
You need to log in before you can comment on or make changes to this bug.