Adobe Flash plugin crashes systematically in Firefox 39

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Helmut Leininger, Unassigned)

Tracking

({crash, flashplayer, regression})

39 Branch
x86_64
Windows 8.1
crash, flashplayer, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

load any page where flaschplayer is used, e.g. http://www.adobe.com/de/software/flash/about/

Environment:
Firefox 39.0
Windows 8.1 64-bit
Adobe Flashplayer 18.0.0.194





Actual results:

flash player plugin crashes


Expected results:

should not crash (worked ok in Firefox 38).
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
The problem appeared after the automatic update of Firefox from 38.0.5 to 39.0.

It seems not to appear after a dowmload of Firefox 39.0 installation file and installing it over the existing firefox installation.

Comment 2

2 years ago
Can you copy-paste a URL to a crashreport corresponding to one of these crashes from the about:crashes page in Firefox?
Component: Untriaged → Plug-ins
Flags: needinfo?(hlein)
Keywords: crash, regression
Product: Firefox → Core
(Reporter)

Comment 3

2 years ago
some sent crash reports:
e3552a67-be0c-46b4-9066-c4534e10fdca
	05.07.2015	09:51
98e8b7fa-d96d-46fd-aaea-d34e22653f87
	04.07.2015	22:04
bp-dd4806ee-6413-437c-856d-14c392150704
	04.07.2015	17:40
1c1adf42-08b0-4058-96d6-82bf52621e84
	04.07.2015	17:39
dccc951a-259f-4b9b-a50d-7083b63c19fd
	04.07.2015	17:39
311b0579-b144-4892-96cf-e86b4c820faa
	04.07.2015	17:32
c3b97865-aceb-4f69-a99f-810278ad0ea9
	04.07.2015	17:32
47084be6-6a60-4984-b71f-cb92bc1b60b0
	04.07.2015	17:28
bp-4497a79a-3135-4c38-bdb3-a07452150704
	04.07.2015	17:25
bp-a8914958-542e-4e5d-b69c-3e33f2150704
	04.07.2015	17:21
bp-17318635-df7b-4a99-82f7-220b72150704
	04.07.2015	17:21
f60c72fd-77ec-412a-ba7d-d3eff7b51b54
	04.07.2015	17:21
Flags: needinfo?(hlein)

Comment 4

2 years ago
(In reply to Helmut Leininger from comment #1)
> The problem appeared after the automatic update of Firefox from 38.0.5 to
> 39.0.
> 
> It seems not to appear after a dowmload of Firefox 39.0 installation file
> and installing it over the existing firefox installation.

Has this remained the case? Because it sounds like that will make it difficult to investigate this further if so (because it's no longer broken)...

Sadly the crash stack has no symbols for flash so I'm not really sure how to dive into that further. rstrong/bsmedberg, do you have ideas?
Flags: needinfo?(robert.strong.bugs)
Flags: needinfo?(benjamin)
Keywords: flashplayer

Comment 5

2 years ago
We have had reports in the past where Flash crashes immediately after a *Flash* update, and continues to do so until the next time the OS reboots. Flash released an update quite recently. Is it possible that these crash reports are related to the Flash update and the Firefox upgrade was an unrelated change?

The Flash symbols are being fixed; Socorro upgrades and symbol issues have prevented good symbols from the most recent Flash version.
Flags: needinfo?(robert.strong.bugs)
Flags: needinfo?(benjamin)

Updated

2 years ago
Flags: needinfo?(hlein)
If it is related to the Firefox update then it would likely be due to plugin code or other code in the Firefox 39 codebase since Flash doesn't install anything into our installation directory and hence shouldn't be affected by Firefox updating.
(Reporter)

Comment 7

2 years ago
I can only tell what happened in my case.
There was no recent update of the Flash and the OS had certainly been rebooted some time after the last Flash update.
The error occurred after Firefox was automatically updated to version 39.0.
I tried with the dayly of Forfox 40 alpha - no problem.
And as the rror in Firefox 39 persisted after several restarts of FF and clean of the cahce, I downloaded th FF 39 installation file from the Mozilla pages and installed it over the updated FF - the problem went away.

Maybe I have another PC with the problem still happening, but I cannot get to it in the next three weeks.

Comment 8

2 years ago
Flash 18.0.0.194 was released June 23, 2015 so there was certainly a fairly recent update.
I'll jump in here quickly but I'm not sure if what I'm seeing is related. I'm going through the blocklisting testing in bug # 1181458 and noticed that flash is crashing pretty consistently when I visit the following sites:

- http://ca.ign.com/
- http://www.gametrailers.com/

When loading a video, about 10% of the time the browser goes completely non-responsive and than ends up crashing with a "exception breakpoint" after about 10-15 minutes of the browser being non-responsive. Unfortunately there's no crash reports being generated when this happens. I've ran into this using the following versions of flash so far:

- 18.0.0.194
- 13.0.0.296
- 18.0.0.203 (latest as of 07/10/2015)

Environment being used:

Build: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015-07-10-03-02-06-mozilla-central/
OS: Win 8.1 x64 (VM running in VMware Fusion)
This bug has been tagged for regression and or closure.
I cannot produce the error/crashes applying updates: 

Adobe Flash Firefox – NPAPI 	21.0.0.242

Version 	39.0
Build ID 	20150630154324
User Agent 	Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Version 	43.0.1
Build ID 	20151216175450
Version 	46.0.1
Build ID 	20160502172042
Version 	49.0a1
Build ID 	20160516030211

Appears updated Flash w/Fx is stable. "ni" me if more info is needed or OK to close this out.
(Reporter)

Comment 11

2 years ago
In my opinion, you may close. No problems with Fx 45 64-bit and up.

Comment 12

2 years ago
Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hlein)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.