UX of home button bad when keyboard displayed

RESOLVED DUPLICATE of bug 1177509

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1177509
3 years ago
3 years ago

People

(Reporter: hwine, Unassigned)

Tracking

({dogfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

I seem to hit the home button at least once per text field I fill out. That dumps me out of the app and into the home screen. Unless the app I was just in has a visible icon, I have to wait 2 seconds for the task switcher to be displayed.

Just doesn't flow well for me. I waited several days to file this in case it was just me getting used to the keyboard, but I still hit it often enough to be frustrated.

Maybe requiring a 1/2 second hold (instead of tap) on the home button when keyboard is displayed?
Component: Gaia::Feedback → Gaia::Keyboard
Flags: needinfo?(firefoxos-ux-bugzilla)
See Also: → bug 1171235
Hal, we landed a fix for this in bug 1177509. You should get it in the OTA update from today. Hopefully that fixes it to your liking. If not, feel free to reopen this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: Gaia::Keyboard → Gaia::System::Window Mgmt
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(hwine)
Resolution: --- → DUPLICATE
See Also: bug 1171235
Duplicate of bug: 1177509
(Reporter)

Comment 2

3 years ago
So far, so good with update!  Thanks!
Flags: needinfo?(hwine)
You need to log in before you can comment on or make changes to this bug.