White bar at the bottom that grows in size while trying to use Firefox

RESOLVED WONTFIX

Status

Add-on SDK
General
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Alan, Unassigned)

Tracking

({addon-compat, regression})

unspecified
x86_64
Windows 8.1
addon-compat, regression
Dependency tree / graph

Firefox Tracking Flags

(firefox39 unaffected, firefox40+ wontfix, firefox41+ wontfix, firefox42+ wontfix)

Details

Attachments

(1 attachment)

551.51 KB, application/zip
Details
(Reporter)

Description

3 years ago
Created attachment 8629708 [details]
FirefoxBug.zip

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Open Firefox (reproduces immediately, always).  This only happens on Firefox Developer Edition and not regular Firefox.  I am on build 41.0a2 (2015-07-05).


Actual results:

As I try to use Firefox, a bar at the bottom that is white starts to grow vertically until the webpage uses up a small number of pixels and I have to give up.  Both dismissing the prompt on launch to make Firefox my default browser and navigating to another webpage both cause the white bar to grow.  I have attached screenshots to demonstrate.


Expected results:

No white bar should be present.
(Reporter)

Comment 1

3 years ago
I just narrows this problem down to the "The Camelizer - Price Tracker" (https://addons.mozilla.org/en-Us/firefox/addon/the-camelizer-price-history-ch/) add on being enabled.  I don't know if the compatibility breakage is coming from something in Firefox 41 or the add-on itself.

Do I report this issue elsewhere?
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64

Comment 2

3 years ago
[Tracking Requested - why for this release]: regression since beta40

Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=5751177e9259&tochange=72f63499f285

Regressed by:
72f63499f285	Dave Townsend — Bug 1160676: Uplift Add-on SDK to fx-team. a=me
Blocks: 1160676
Status: UNCONFIRMED → NEW
status-firefox39: --- → unaffected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox42: --- → affected
tracking-firefox40: --- → ?
tracking-firefox41: --- → ?
tracking-firefox42: --- → ?
Component: Untriaged → General
Ever confirmed: true
Keywords: addon-compat, regression
Product: Firefox → Add-on SDK
Version: 41 Branch → unspecified

Updated

3 years ago
Flags: needinfo?(philringnalda)
Whoever you need info from about a jetpack change, it isn't me.
Flags: needinfo?(philringnalda)

Comment 4

3 years ago
(In reply to Phil Ringnalda (:philor) from comment #3)
> Whoever you need info from about a jetpack change, it isn't me.

Sorry, but the bug was pushed to m-c by you.
Flags: needinfo?(dtownsend)

Comment 5

3 years ago
Tracking for 40, 41, 42 because regression.
tracking-firefox40: ? → +
tracking-firefox41: ? → +
tracking-firefox42: ? → +
The add-on has been broken by the intentional removal of an API it depends on. The API in question has been logging deprecation warnings to the console for over a year. The add-on needs to be updated here, it isn't something we will fix in Firefox.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 1158356
Flags: needinfo?(dtownsend)
Resolution: --- → WONTFIX
Marking release status as wontfix.
status-firefox40: affected → wontfix
status-firefox41: affected → wontfix
status-firefox42: affected → wontfix
You need to log in before you can comment on or make changes to this bug.