Remove pre-v2.x keyboard settings migration

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Input Mgmt
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: timdream, Assigned: ralin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Make sense to do this as we decided to wontfix bug 1109451.
WIP https://github.com/timdream/gaia/tree/input-mgmt-migration

I will work on other bugs first...
Status: ASSIGNED → NEW
Per discussion on dev-fxos.
Summary: Move keyboard settings migration to SettingsMigrator → Remove per v2.x keyboard settings migration
Summary: Remove per v2.x keyboard settings migration → Remove pre-v2.x keyboard settings migration

Comment 3

2 years ago
Created attachment 8708899 [details] [review]
[gaia] timdream:input-mgmt-remove-migration > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Assignee: timdream → ralin

Comment 4

2 years ago
Created attachment 8715119 [details] [review]
[gaia] raylin:input-mgmt-remove-migration > mozilla-b2g:master
(Assignee)

Comment 5

2 years ago
Comment on attachment 8715119 [details] [review]
[gaia] raylin:input-mgmt-remove-migration > mozilla-b2g:master

Hi, Alberto

This is the follow-up bug of Bug 1184342.

It seems the failed tested won't be solved in the near future, however, this patch is done and good, I think we should finish it. Could you please help to review it? Thank you :)
Attachment #8715119 - Flags: review?(apastor)
Hey Ray, could you please rebase it first to make it easier to check the specific changes?Thanks!
Flags: needinfo?(ralin)
(Assignee)

Comment 7

2 years ago
Oops, sorry about that, PR is rebased now. Please help me to check it again, thanks!
Flags: needinfo?(ralin)
The code looks good to me, but can you double check that the Gij10 failure [1] is not caused by this patch?
Thanks!

[1] https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=72bcda22c8d1cd4822bbebaf2e6ba74f4c4f8f8b&selectedJob=3522041
Flags: needinfo?(ralin)
(Assignee)

Comment 9

2 years ago
The cause of the error is intermittent fail again... :( I think we can handle it in another bug. Thanks.
Flags: needinfo?(ralin)
The question here is if the intermittent is caused by this patch or was already there. If it was already there, of course, we can handle that in a different bug. Just asking because Gij10 is related to the Keyboard. Thanks!
Flags: needinfo?(ralin)
(Assignee)

Comment 11

2 years ago
Sorry I did not make it clear, the intermittent is not related to this patch. Thanks!
Flags: needinfo?(ralin)
Comment on attachment 8715119 [details] [review]
[gaia] raylin:input-mgmt-remove-migration > mozilla-b2g:master

Thanks!
Attachment #8715119 - Flags: review?(apastor) → review+
master: https://github.com/mozilla-b2g/gaia/commit/5b90c09648798d8d66c4b08f81402b27acf0dc08

Please remember to update the bug when you merge code!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.