[Marketplace] "Install for <free/price>" string doesn't make sense for non-English locales

RESOLVED FIXED in 2015-07-28

Status

P2
minor
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Tonnes, Assigned: mstriemer)

Tracking

({uiwanted})

Avenir
2015-07-28
uiwanted
Points:
---

Details

(Reporter)

Description

3 years ago
Currently there is an "Install for" string that is followed by an app’s price. When an app is free, the price is subtituted by the word "free". Though this would display "Installl for free" in English as a natural word order, it doesn't make sense for some other locales at all - they may leave out "for" for instance, or even use a totally different phrase. Dutch for instance would use "Gratis installeren", so there is also a word order and captalization issue.

Please use separate strings for "Install for free" and "Install for <price>" and allow other locales to use a correct/different word order. If this is too hard to implement, an easy or temporary fix would be to use "Install ({price})".
(Reporter)

Updated

3 years ago
See Also: → bug 1180464
Severity: normal → minor
Keywords: uiwanted
Priority: -- → P3
Can this get a higher priority please? This is a very visible string and we can't get it translated in many locales.

For instance in French we have no other choice than keeping it in English and it's quite noticeable by the user. Current situation is even worse since "free" is translated. So we have "Install for gratuit", which doesn't make any sense.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1181010
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1180247
(Assignee)

Comment 4

3 years ago
Going to take this and set the milestone for not the next deploy but the one after. That way we can give the localisers some lead time on getting new strings in. I would assume that poorly worded strings in the right language is better than English.
Assignee: nobody → mstriemer
Target Milestone: --- → 2015-07-21
(Assignee)

Comment 5

3 years ago
https://github.com/mozilla/fireplace/pull/1389
Status: NEW → ASSIGNED
(Assignee)

Comment 6

3 years ago
https://github.com/mozilla/fireplace/commit/6d8c8de0e89085f0f285e0ce39ba32ce511bca42
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 7

3 years ago
I'm not sure what was the final decision here. Do we keep "Install for free" for other locales?
Now on -dev buttons for free apps still say Install for free. http://screencast.com/t/2X2g14xOCtM
Mark can you please explain what the decision was and what changes should we see.
Flags: needinfo?(mstriemer)
(Assignee)

Comment 8

3 years ago
The string "Install for free" will need to be translated, we should expect some locales to have reverted to English.

Actually I'm looking at the strings that were extracted and it looks like I did it wrong, so it should be "Install for free" everywhere. Paid apps should have the text unchanged.

I'm going to get this pulled out of the tag and this can deploy next week.
Flags: needinfo?(mstriemer)
Target Milestone: 2015-07-21 → 2015-07-28
(Reporter)

Comment 9

3 years ago
Note that bug 1185250 was filed to address the currency sign position for most non-English locales, which may be something to keep in mind when working on the install / price strings.
(Reporter)

Comment 10

3 years ago
(In reply to Mark Striemer [:mstriemer] from comment #8)
> The string "Install for free" will need to be translated, we should expect
> some locales to have reverted to English.

So today, not entirely unexpected and even while this bug was marked as fixed, locales have indeed reverted to English for this string and the temporary fix does no longer work.

Why was there no new localizable "Install for free" string added to Verbatim so far (or rather: asap), what will it take to get this really fixed, and would that be another 2 weeks? (I did note bug 1180464 comment 9.)
(Assignee)

Comment 11

3 years ago
It was supposed to have been removed from the deployment this week as well since extraction did not happen last week.
(Assignee)

Comment 12

3 years ago
The accidental update has been removed and the "Install for free" string is properly extracted now. Translations for that string will be shown after our next deployment.
I translated the strings in French yesterday and the strings are back in English in production today.

https://github.com/mozilla/fireplace/commit/ada2eb92ff5c8ded82025f4e6999aa41a80a6f18#diff-030c948b84dbda0a980713d5cbac88cdR741

Has something wrong happened?
(Assignee)

Comment 14

3 years ago
This is expected. Your strings should appear next week.

We tag our codebase at 11am pacific on Friday so anything committed after that will wait another week.
You need to log in before you can comment on or make changes to this bug.