[Browser] Text Selection 'Cut' is available on Non-Editable text; does nothing

RESOLVED INVALID

Status

()

Core
Selection
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing], [Spark],, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Description:
When the user attempts to perform text selection on non-editable text (such as on an html page browser), they will observe the option for 'cut' (scissors). Tapping this option and performing a 'paste' operation in an appropriate field afterwards will display the last successful 'cut'/'copy' operation. Nothing was saved when cut is performed on non-editable text fields, but the avaiablility of the UI can be distracting.
* this is observed in browser pages, in marketplace hosted apps (soundcloud)
* this issue DOES NOT REPRO in the Messages app (long press message -> select text: reveals 'select-all' and 'copy' icons)

Repro Steps:
1) Update a Flame to 20150706010204
2) Open the Browser
3) Search for Wikipedia: 'Python'
4) Highlight the word (hold-press) 'Python' in the title of the wiki page
5) Observe 'cut':'scissors' icon, tap the scissors.
6) Hold press in a text field (browser search bar) and paste

Actual:
Cut performs no action when attempted on non-editable text; misleading having the icon present

Expected:
Cut is not available on non-editable text


Environmental Variables:
-----------------------------
Device: Aries 2.5
BuildID: 20150706103023
Gaia: dc6c18c0dea7af3c40bfff86c530fd877d899dc4
Gecko: cef11c3e86c3
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
Build ID: 20150706010204
Gaia: dc6c18c0dea7af3c40bfff86c530fd877d899dc4
Gecko: 136c41fca853
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
************************

This issue DOES NOT REPRO on 2.2 for flame devices
Results: Highlighted non-editable text does not show 'cut' icon

Device: Flame 2.2
BuildID: 20150706002507
Gaia: ea11f422b687a982f0a961c9aea7858066561707
Gecko: c0214b4c1ea0
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------

Repro frequency: 5/5
See attached: 
video- https://youtu.be/fJ1iurDTGu0
logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8630109 [details]
logcat_20150706_1231.txt
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
[Blocking Requested - why for this release]:
Visible regression with poor UX (button does nothing).
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: pcheng
Component: Gaia::Browser → Selection
Product: Firefox OS → Core
Who is owning selection bugs now?
Flags: needinfo?(timdream)
Whiteboard: [2.5-Daily-Testing], [Spark], [systemsfe] → [2.5-Daily-Testing], [Spark],
mozilla-inbound regression window:

Last Working
Device: Flame
BuildID: 20150630034444
Gaia: 27fe0f4261e3685187769411f2f74cff19287b19
Gecko: e8ea2a9493da
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame
BuildID: 20150630051845
Gaia: 5997b406e77ea726fbd9047057a1c3504f6cd6d4
Gecko: 924374177485
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working Gaia & First Broken Gecko - issue DOES repro
Gaia: 27fe0f4261e3685187769411f2f74cff19287b19
Gecko: 924374177485

Last Working Gecko & First Broken Gaia - issue does NOT repro
Gaia: 5997b406e77ea726fbd9047057a1c3504f6cd6d4
Gecko: e8ea2a9493da

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e8ea2a9493da&tochange=924374177485

Caused by changes made in Bug 1170531.
Blocks: 1170531
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted

Comment 5

3 years ago
This is an intentional change that we made in bug 1159490.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Resolution: INVALID → FIXED
Accidentally changed the status.  Reverting
Resolution: FIXED → INVALID
But we probably don't want to show the 'cut' icon if its useless. It somehow works on desktop. Do we need to fix this in the selection code or somewhere in the browser app?
Flags: needinfo?(ehsan)

Comment 8

3 years ago
The cut icon won't be useless.  Web pages can receive a cut event and do something with it (same with copy), so our previous heuristics for disabling these commands were wrong.

Does that make sense?
Flags: needinfo?(ehsan)
The STR already shows the cut command is useless in this particular case.
(In reply to Gregor Wagner [:gwagner] from comment #3)
> Who is owning selection bugs now?

TYLin and me.
Flags: needinfo?(timdream)

Comment 11

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #9)
> The STR already shows the cut command is useless in this particular case.

Yes, the problem is that you can't know whether the page does anything with the cut event before it is dispatched.

That being said, most pages probably won't handle this event, so if you want to forcefully disable the commands in the UI, that's your choice.  But doing so will break those (perhaps fewer) pages that do want to do something with the cut event.
You need to log in before you can comment on or make changes to this bug.