Joining the same room twice fails in odd ways

RESOLVED DUPLICATE of bug 1194699

Status

P2
normal
RESOLVED DUPLICATE of bug 1194699
3 years ago
3 years ago

People

(Reporter: vladan, Unassigned)

Tracking

unspecified
Points:
5
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Markus created a room and sent me the link (https://hello.firefox.com/5mE_gBV9ns0#myq38hIUo-jH3YgvrpJqfQ). I opened the link and started the conversation. 

Then I opened the link in a second tab (simultaneously) and clicked on Join Conversation. Hello said "Something went wrong" and showed a "Retry" button.

> eRoomView.shouldRenderRemoteVideo: unexpected roomState:  room-failed standaloneRoomViews.js:366:1
> OT.Publisher.onStreamAvailableError SourceUnavailableError: Unknown Error while getting user media sdk.js:3399:13
> OT.exception :: title: Unable to Publish (1500) msg: GetUserMedia sdk.js:3399:13
> 1500 Unknown Error while getting user media sdk.js:3399:13
> OT.exception :: title: Unable to Publish (1500) msg: Unknown Error while getting user media sdk.js:3399:13
> StandaloneRoomView.shouldRenderRemoteVideo: unexpected roomState:  room-failed

Then I closed the second tab and tried to open the link again in a new tab (total tabs=2) and clicked on "Join Conversation", this time the hello.firefox.com page didn't show any errors

Finally, Markus left the Hello room and I tried to open the URL in a second tab using the same link and the page told me there were already two people in the room (I think this is a known bug)
Points: --- → 5
Flags: qe-verify+
Flags: firefox-backlog+
Priority: -- → P2
Vladan: Which platform are you on? This sounds a bit like Windows or Linux where you can't get access to the same device twice.

Could you try loading the http://mozilla.github.io/webrtc-landing/gum_test.html on two separate tabs and accessing at the same time?
Flags: needinfo?(vdjeric)
(Reporter)

Comment 2

3 years ago
(In reply to Mark Banner (:standard8) from comment #1)
> Vladan: Which platform are you on?

I saw this on Windows 7 & Windows 8

> This sounds a bit like Windows or Linux where you can't get access to the same device twice.

Yes, that could be it

> Could you try loading the
> http://mozilla.github.io/webrtc-landing/gum_test.html on two separate tabs
> and accessing at the same time?

I tested on Windows 7:

- This page works in Aurora, Nightly single-process, and Nightly e10s
- In process-per-tab Nightly (dom.ipc.processCount=10, my own config) or when I open the link in 2 different Firefox profiles at the same time, I get "SourceUnavailableError: Failed to allocate videosource"
Flags: needinfo?(vdjeric)

Comment 3

3 years ago
shell find the bug we're fixing this issue with and associate - won't fix based on that if OK with team.
Flags: needinfo?(sescalante)
Marking as duplicate of bug 1194699 - my understanding per comment 2 that this is e10s related, and although that's a later bug, there's a bit clearer description and discussions ongoing there.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(sescalante)
Resolution: --- → DUPLICATE
Duplicate of bug: 1194699
You need to log in before you can comment on or make changes to this bug.