Closed Bug 11809 Opened 21 years ago Closed 17 years ago

Dr Watson log generated running TestInterfaceInfo

Categories

(Core :: XPCOM, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 136936
Future

People

(Reporter: me, Assigned: dbradley)

References

()

Details

Application exception occurred:
        App: TestInterfaceInfo.dbg (pid=161)
        When: 8/12/1999 @ 16:4:3.301
        Exception number: c0000005 (access violation)

*----> System Information <----*
        Computer Name: FLETCHERB_TEST
        User Name: fletcheb
        Number of Processors: 1
        Processor Type: x86 Family 6 Model 7 Stepping 2
        Windows Version: 4.0
        Current Build: 1381
        Service Pack: 4
        Current Type: Uniprocessor Free
        Registered Organization: WRQ
        Registered Owner: Fletcher Bonds

*----> Task List <----*
   0 Idle.exe
   2 System.exe
  20 smss.exe
  28 csrss.exe
  34 winlogon.exe
  40 services.exe
  43 lsass.exe
  69 spoolss.exe
  88 smartagt.exe
  81 RpcSs.exe
 107 pstores.exe
 100 nddeagnt.exe
 133 Explorer.exe
  67 SysTray.exe
 138 comsmd.exe
 143 DACONFIG.exe
 145 RealPlay.exe
 154 Remote.exe
  98 netscape.exe
  99 ddhelp.exe
 161 TestInterfaceIn.exe
 164 drwtsn32.exe
   0 _Total.exe

(00400000 - 00405000) TestInterfaceInfo.dbg
(77f60000 - 77fbc000) dll\ntdll.dbg
(608e0000 - 60916000) xpcom.dbg
(60800000 - 60807000) plc3.dbg
(607b0000 - 607cf000) nspr3.dbg
(776d0000 - 776d8000) dll\wsock32.dbg
(77f00000 - 77f5e000) dll\kernel32.dbg
(776b0000 - 776c4000) dll\ws2_32.dbg
(78000000 - 78040000)
(77e70000 - 77ec4000) dll\user32.dbg
(77ed0000 - 77efc000) dll\gdi32.dbg
(77dc0000 - 77dff000) dll\advapi32.dbg
(77e10000 - 77e67000) dll\rpcrt4.dbg
(776a0000 - 776a7000) dll\ws2help.dbg
(77fd0000 - 77ffa000) dll\winmm.dbg
(606d0000 - 606d8000) libreg32.dbg
(77c40000 - 77d7c000) dll\shell32.dbg
(77aa0000 - 77b14000) COMCTL32.dbg
(780a0000 - 780a0000)
(60810000 - 60817000) plds3.dbg
(77fc0000 - 77fc8000) dll\mmdrv.dbg
(6bd00000 - 6bd28000) D:\DDK-NT\lib\i386\free\ydsxg32.dll

State Dump for Thread Id 0x61

eax=00000000 ebx=7800fa87 ecx=004030f8 edx=672a21be esi=004104e0 edi=0040323c
eip=004011ba esp=0012feec ebp=0012ff4c iopl=0         nv up ei pl zr na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00000246


function: <nosymbols>
        004011a2 50               push    eax
        004011a3 ffd3             call    ebx
        004011a5 8b06             mov     eax,[esi]
ds:004104e0=60900e30
        004011a7 83c410           add     esp,0x10
        004011aa 8d4df4           lea     ecx,[ebp-0xc]
ss:0105e952=????????
        004011ad 51               push    ecx
        004011ae 68f8304000       push    0x4030f8
        004011b3 56               push    esi
        004011b4 ff5010           call    dword ptr [eax+0x10]
ds:00f2ea06=????????
        004011b7 8b45f4           mov     eax,[ebp-0xc]
ss:0105e952=????????
FAULT ->004011ba 8b08             mov     ecx,[eax]
ds:00000000=????????
        004011bc 8d55fe           lea     edx,[ebp-0x2]
ss:0105e952=????????
        004011bf 52               push    edx
        004011c0 50               push    eax
        004011c1 ff511c           call    dword ptr [ecx+0x1c]
ds:01331afe=????????
        004011c4 33f6             xor     esi,esi
        004011c6 663975fe         cmp     [ebp-0x2],si
ss:0105e953=????
        004011ca 7631             jbe     004011fd
        004011cc 8b45f4           mov     eax,[ebp-0xc]
ss:0105e952=????????
        004011cf 8d55f0           lea     edx,[ebp-0x10]
ss:0105e952=????????
        004011d2 52               push    edx
        004011d3 56               push    esi

*----> Stack Back Trace <----*

FramePtr ReturnAd Param#1  Param#2  Param#3  Param#4  Function Name
0012ff4c 004013d3 00000001 00410c70 00410be0 00403000
TestInterfaceInfo!<nosymbols>
0012ffc0 77f1ba3c 0510e4c4 77c44073 7ffdf000 c0000005
TestInterfaceInfo!<nosymbols>
0012fff0 00000000 004012f0 00000000 00000000 77fa5ab0
kernel32!GetProcessPriorityBoost
00000000 00000000 00000000 00000000 00000000 00000000
TestInterfaceInfo!<nosymbols>

*----> Raw Stack Dump <----*
0012feec  c4 e4 10 05 73 40 c4 77 - 00 f0 fd 7f 70 0c 41 00  ....s@.w....p.A.
0012fefc  34 ff 12 00 6d 6f f6 77 - b0 ff 12 00 90 2f 45 00  4...mo.w...../E.
0012ff0c  10 20 45 00 70 20 45 00 - 58 ff 12 00 d7 12 00 78  . E.p E.X......x
0012ff1c  30 20 45 00 18 37 14 00 - e0 04 41 00 00 f0 fd 7f  0 E..7....A.....
0012ff2c  50 20 45 00 40 21 45 00 - b0 21 45 00 a0 10 45 00  P E.@!E..!E...E.
0012ff3c  78 0c 41 00 00 00 00 00 - 60 21 45 00 c4 e4 10 05  x.A.....`!E.....
0012ff4c  c0 ff 12 00 d3 13 40 00 - 01 00 00 00 70 0c 41 00  ......@.....p.A.
0012ff5c  e0 0b 41 00 00 30 40 00 - 04 30 40 00 a4 ff 12 00  ..A..0@..0@.....
0012ff6c  94 ff 12 00 a0 ff 12 00 - 00 00 00 00 98 ff 12 00  ................
0012ff7c  08 30 40 00 0c 30 40 00 - c4 e4 10 05 73 40 c4 77  .0@..0@.....s@.w
0012ff8c  00 f0 fd 7f 05 00 00 c0 - 70 0c 41 00 00 00 00 00  ........p.A.....
0012ff9c  37 dd 11 80 e0 0b 41 00 - 01 00 00 00 84 ff 12 00  7.....A.........
0012ffac  34 fd 12 00 e0 ff 12 00 - 30 14 40 00 a8 20 40 00  4.......0.@.. @.
0012ffbc  00 00 00 00 f0 ff 12 00 - 3c ba f1 77 c4 e4 10 05  ........<..w....
0012ffcc  73 40 c4 77 00 f0 fd 7f - 05 00 00 c0 c8 ff 12 00  s@.w............
0012ffdc  34 fd 12 00 ff ff ff ff - 74 b8 f3 77 48 d2 f3 77  4.......t..wH..w
0012ffec  00 00 00 00 00 00 00 00 - 00 00 00 00 f0 12 40 00  ..............@.
0012fffc  00 00 00 00 00 00 00 00 - b0 5a fa 77 e8 55 fa 77  .........Z.w.U.w
0013000c  98 5a fa 77 00 00 00 00 - 00 00 00 00 00 00 00 00  .Z.w............
0013001c  00 00 00 00 40 00 13 00 - 00 00 00 00 00 00 00 00  ....@...........
NT4 SP4 running M8 w/ Communicator 4.61 installed.  Fired test prog w/o
parameters while browsing EXEs.
Assignee: don → mccabe
Component: Browser-General → XPCOM
Resetting QA contact from leger.
QA Contact: dp → rginda
resetting qa contact again. This is certainly not dp's qa problem (but I added
him to the cc list just in case he really wants to track the state of the
various test programs in xpcom).

TestInterfaceInfo is of very low priority. It is not really used for anything at
present. It has been broken in various ways in the past. It has hardcoded
dependencies on interfaces that have changed over time.
[SPAM] Marking milestone 'future' as part of nsbeta3 triage.
Target Milestone: --- → Future
Mass-reassigning mccabe's non-JS, non-Rhino bugs to jband (34 total). 

Would like to cc mccabe; but the mass-reassign page does not allow this. 
I'll leave it up to mccabe to decide if he wants to be cc'ed on these - 
Assignee: mike+mozilla → jband
mass reassign of bugs to dbradley@netscape.com
Assignee: jband → dbradley
Component: XPCOM → xpidl
Status: NEW → ASSIGNED
QA Contact: rginda → pschwartau
I ran this with current code. I'm not getting an access violation, but I suspect  
I'm not getting as far any more. Currently it stops after trying to find 
nsIServiceManager. This AFAICT doesn't have an IDL, thus doesn't have an XPT 
file, so isn't visible in this context. It's using nsIInterfaceInfoManager to 
query for the interfaces, which appears to use the typelib information.

Should the test for nsIServiceManager just be removed now?
We have lots of useless tests. This one no longer crashes. It you think you need 
there to be a meaningful test, then you can fix it. Otherhwise I'd just mark it 
WORKSFORME.
It really doesn't work for me. It doesn't crash, but the test fails. I think the 
test is out of date now and probably needs to be updated. Is this really a 
major?
Downgrading - tidying up
Severity: major → minor

*** This bug has been marked as a duplicate of 136936 ***
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Verified Duplicate -
Status: RESOLVED → VERIFIED
Component: xpidl → XPCOM
QA Contact: pschwartau → xpcom
You need to log in before you can comment on or make changes to this bug.