[Aries] Unable to open window does not fit screen correctly.

RESOLVED DUPLICATE of bug 1176909

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1176909
2 years ago
2 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8630249 [details]
logcat_20150706_1725.txt

Description:
If the user receives an unable to open window, (such as opening a html file) the window will not fit correctly on the Aries device.


Repro Steps:

Prereq: At least 1 photo within gallery.

1) Update a Aries to 20150706103023
2) Open Marketplace.
3) From one of the various app click and hold a "Install for free" button.
4) Select Save linked file
5) Open downloaded file.

Actual:
User receives Unable to open window that does not fit correctly to the Aries device.

Expected:
It is expected that this window will fit the screen correctly.
Environmental Variables:
Device: Aries 2.5
Build ID: 20150706103023
Gaia: dc6c18c0dea7af3c40bfff86c530fd877d899dc4
Gecko: cef11c3e86c3
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 4/4
See attached: Logcat, Video, Screenshot
(Reporter)

Comment 1

2 years ago
This issue does NOT occur on the flame 2.5, 2.2, 2.1 and 2.0

Result: "Unable to open message" fits the screen correctly. However for 2.0 the user does not receive the option to download the saved file from Marketplace.


Environmental Variables:
Device: Flame 2.5 Kk Fullflash (319mb)
Build ID: 20150706010204
Gaia: dc6c18c0dea7af3c40bfff86c530fd877d899dc4
Gecko: 136c41fca853
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (319mb)
Build ID: 20150706002507
Gaia: ea11f422b687a982f0a961c9aea7858066561707
Gecko: c0214b4c1ea0
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1 Kk Fullflash (319mb)
Build ID: 20150706001204
Gaia: d13826b20b4a45e3f5cd4b25a30a737d8be7f1b9
Gecko: 37de99064c33
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0



Environmental Variables:
Device: Flame 2.0 Kk Fullflash (319mb)
Build ID: 20150706000206
Gaia: 43607033ac3ecd068ac0fa226403db384a59429d
Gecko: 2a92b52cc30e
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Spark]
(Reporter)

Comment 2

2 years ago
Created attachment 8630250 [details]
IMG_0002.jpg
(Reporter)

Comment 3

2 years ago
Correction, the variables for 2.0 are as follows.

Result: Marketplace does not give the option to download html files.

Environmental Variables:
Device: Flame 2.0
Build ID: 20150702000207
Gaia: 5552bf529d3d6775a968942e9afa6c1d4037362c
Gecko: 88eedcc6fd9b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: NEW → RESOLVED
Last Resolved: 2 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 1176909
You need to log in before you can comment on or make changes to this bug.