Intermittent 815489.html | application crashed [@ CreateBoxShadow]

RESOLVED FIXED in Firefox 42

Status

()

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: cbook, Assigned: mchang)

Tracking

({crash, intermittent-failure})

unspecified
mozilla42
Unspecified
Windows XP
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox40 unaffected, firefox41 unaffected, firefox42 fixed, firefox-esr31 unaffected, firefox-esr38 unaffected)

Details

(Whiteboard: gfx-noted, URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=11417635&repo=mozilla-inbound

21:49:09 WARNING - PROCESS-CRASH | file:///C:/slave/test/build/tests/reftest/tests/gfx/tests/crashtests/815489.html | application crashed [@ CreateBoxShadow]
21:49:09 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpwekjjx.mozrunner\minidumps\aaa16875-257c-4e50-a8f1-e1e8ee65fbbe.dmp
21:49:09 INFO - Operating system: Windows NT
21:49:09 INFO - 6.1.7601 Service Pack 1
21:49:09 INFO - CPU: x86
21:49:09 INFO - GenuineIntel family 6 model 30 stepping 5
21:49:09 INFO - 8 CPUs
21:49:09 INFO - Crash reason: EXCEPTION_BREAKPOINT
21:49:09 INFO - Crash address: 0x642e5148
21:49:09 INFO - Thread 0 (crashed)
21:49:09 INFO - 0 xul.dll!CreateBoxShadow [gfxBlur.cpp:42effec49f3f : 442 + 0x2d]
21:49:09 INFO - eip = 0x642e5148 esp = 0x0030d85c ebp = 0x0030d8a0 ebx = 0x00000000
21:49:09 INFO - esi = 0x000001ba edi = 0x1f48f8e0 eax = 0x00000000 ecx = 0x691f0ad9
21:49:09 INFO - edx = 0x00121ff1 efl = 0x00200206
21:49:09 INFO - Found by: given as instruction pointer in context
21:49:09 INFO - 1 xul.dll!GetBlur(mozilla::gfx::DrawTarget &,mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gfx::RectCornerRadii *,gfxRGBA const &,mozilla::gfx::IntMarginTyped<mozilla::gfx::UnknownUnits> &,mozilla::gfx::IntMarginTyped<mozilla::gfx::UnknownUnits> &) [gfxBlur.cpp:42effec49f3f : 482 + 0xd]
21:49:09 INFO - eip = 0x642eac39 esp = 0x0030d8a8 ebp = 0x0030d8e4
21:49:09 INFO - Found by: call frame info
21:49:09 INFO - 2 xul.dll!gfxAlphaBoxBlur::BlurRectangle(gfxContext *,gfxRect const &,mozilla::gfx::RectCornerRadii *,gfxPoint const &,gfxRGBA const &,gfxRect const &,gfxRect const &) [gfxBlur.cpp:42effec49f3f : 574 + 0x2a]
21:49:09 INFO - eip = 0x642e2c46 esp = 0x0030d8ec ebp = 0x0030db24
21:49:09 INFO - Found by: call frame info
21:49:09 INFO - 3 xul.dll!nsContextBoxBlur::BlurRectangle(gfxContext *,nsRect const &,int,mozilla::gfx::RectCornerRadii *,int,gfxRGBA const &,nsRect const &,gfxRect const &) [nsCSSRendering.cpp:42effec49f3f : 5414 + 0x25]
21:49:09 INFO - eip = 0x653fcb68 esp = 0x0030db2c ebp = 0x0030dce0
21:49:09 INFO - Found by: call frame info
21:49:09 INFO - 4 xul.dll!nsCSSRendering::PaintBoxShadowOuter(nsPresContext *,nsRenderingContext &,nsIFrame *,nsRect const &,nsRect const &,float) [nsCSSRendering.cpp:42effec49f3f : 1445 + 0x39]
21:49:09 INFO - eip = 0x65421a5c esp = 0x0030dce8 ebp = 0x0030dff8
21:49:09 INFO - Found by: call frame info
21:49:09 INFO - 5 xul.dll!nsDisplayBoxShadowOuter::Paint(nsDisplayListBuilder *,nsRenderingContext *) [nsDisplayList.cpp:42effec49f3f : 3402 + 0x23]
21:49:09 INFO - eip = 0x6541f917 esp = 0x0030e000 ebp = 0x0030e0ec
21:49:09 INFO - Found by: call frame info
21:49:09 INFO - 6 xul.dll!mozilla::FrameLayerBuilder::PaintItems(nsTArray<mozilla::FrameLayerBuilder::ClippedDisplayItem> &,mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const &,gfxContext *,nsRenderingContext *,nsDisplayListBuilder *,nsPresContext *,mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits> const &,float,float,int) [FrameLayerBuilder.cpp:42effec49f3f : 5462 + 0x12]
21:49:09 INFO - eip = 0x653e5818 esp = 0x0030e0f4 ebp = 0x0030e204
21:49:09 INFO - Found by: call frame info
21:49:09 INFO - 7 xul.dll!mozilla::FrameLayerBuilder::DrawPaintedLayer(mozilla::layers::PaintedLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *) [FrameLayerBuilder.cpp:42effec49f3f : 5662 + 0x40]
21:49:09 INFO - eip = 0x653dd91b esp = 0x0030e20c ebp = 0x0030e33c
21:49:09 INFO - Found by: call frame info
21:49:09 INFO - 8 xul.dll!mozilla::layers::ClientPaintedLayer::PaintThebes() [ClientPaintedLayer.cpp:42effec49f3f : 92 + 0x1b]
21:49:09 INFO - eip = 0x64266805 esp = 0x0030e344 ebp = 0x0030e3c4
21:49:09 INFO - Found by: call frame info
21:49:09 INFO - 9 xul.dll!mozilla::layers::ClientPaintedLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor *) [ClientPaintedLayer.cpp:42effec49f3f : 140 + 0x6]
21:49:09 INFO - eip = 0x64269272 esp = 0x0030e3cc ebp = 0x0030e41c
21:49:09 INFO - Found by: call frame info 




21:48:56 INFO - Assertion failure: boxShadowDT->GetType() == aDT.GetType(), at c:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/src/gfx/thebes/gfxBlur.cpp:442
21:48:56 INFO - #01: GetBlur(mozilla::gfx::DrawTarget &,mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gfx::RectCornerRadii *,gfxRGBA const &,mozilla::gfx::IntMarginTyped<mozilla::gfx::UnknownUnits> &,mozilla::gfx::IntMarginTyped<mozilla::gfx::UnknownUnits> &) [gfx/thebes/gfxBlur.cpp:482]
21:48:56 INFO - #02: gfxAlphaBoxBlur::BlurRectangle(gfxContext *,gfxRect const &,mozilla::gfx::RectCornerRadii *,gfxPoint const &,gfxRGBA const &,gfxRect const &,gfxRect const &) [gfx/thebes/gfxBlur.cpp:574]
21:48:56 INFO - #03: nsContextBoxBlur::BlurRectangle(gfxContext *,nsRect const &,int,mozilla::gfx::RectCornerRadii *,int,gfxRGBA const &,nsRect const &,gfxRect const &) [layout/base/nsCSSRendering.cpp:5414]
21:48:56 INFO - #04: nsCSSRendering::PaintBoxShadowOuter(nsPresContext *,nsRenderingContext &,nsIFrame *,nsRect const &,nsRect const &,float) [layout/base/nsCSSRendering.cpp:1445]
21:48:56 INFO - #05: nsDisplayBoxShadowOuter::Paint(nsDisplayListBuilder *,nsRenderingContext *) [layout/base/nsDisplayList.cpp:3402]
21:48:56 INFO - #06: mozilla::FrameLayerBuilder::PaintItems(nsTArray<mozilla::FrameLayerBuilder::ClippedDisplayItem> &,mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const &,gfxContext *,nsRenderingContext *,nsDisplayListBuilder *,nsPresContext *,mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits> const &,float,float,int) [layout/base/FrameLayerBuilder.cpp:5466]
21:48:56 INFO - #07: mozilla::FrameLayerBuilder::DrawPaintedLayer(mozilla::layers::PaintedLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *) [layout/base/FrameLayerBuilder.cpp:5665]
21:48:56 INFO - #08: mozilla::layers::ClientPaintedLayer::PaintThebes() [gfx/layers/client/ClientPaintedLayer.cpp:92]
21:48:56 INFO - #09: mozilla::layers::ClientPaintedLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor *) [gfx/layers/client/ClientPaintedLayer.cpp:141]
21:48:56 INFO - #10: mozilla::layers::ClientContainerLayer::RenderLayer() [gfx/layers/client/ClientContainerLayer.h:69]
21:48:56 INFO - #11: mozilla::layers::ClientLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor *) [gfx/layers/client/ClientLayerManager.h:384]
21:48:56 INFO - #12: mozilla::layers::ClientLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor *) [gfx/layers/client/ClientLayerManager.h:384]
21:48:56 INFO - #13: mozilla::layers::ClientLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor *) [gfx/layers/client/ClientLayerManager.h:384]
21:48:56 INFO - #14: mozilla::layers::ClientLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor *) [gfx/layers/client/ClientLayerManager.h:384]
21:48:56 INFO - #15: mozilla::layers::ClientLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor *) [gfx/layers/client/ClientLayerManager.h:384]
21:48:56 INFO - #16: mozilla::layers::ClientLayerManager::EndTransactionInternal(void (*)(mozilla::layers::PaintedLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *),void *,mozilla::layers::LayerManager::EndTransactionFlags) [gfx/layers/client/ClientLayerManager.cpp:275]
21:48:56 INFO - #17: mozilla::layers::ClientLayerManager::EndTransaction(void (*)(mozilla::layers::PaintedLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *),void *,mozilla::layers::LayerManager::EndTransactionFlags) [gfx/layers/client/ClientLayerManager.cpp:318]
21:48:56 INFO - #18: nsDisplayList::PaintRoot(nsDisplayListBuilder *,nsRenderingContext *,unsigned int) [layout/base/nsDisplayList.cpp:1654]
21:48:56 INFO - #19: nsLayoutUtils::PaintFrame(nsRenderingContext *,nsIFrame *,nsRegion const &,unsigned int,unsigned int) [layout/base/nsLayoutUtils.cpp:3327]
21:48:56 INFO - #20: PresShell::Paint(nsView *,nsRegion const &,unsigned int) [layout/base/nsPresShell.cpp:6118]
21:48:56 INFO - #21: nsViewManager::ProcessPendingUpdatesPaint(nsIWidget *) [view/nsViewManager.cpp:456]
21:48:56 INFO - #22: nsViewManager::ProcessPendingUpdatesForView(nsView *,bool) [view/nsViewManager.cpp:392]
21:48:56 INFO - #23: nsViewManager::ProcessPendingUpdates() [view/nsViewManager.cpp:1086]
21:48:56 INFO - #24: mozilla::RefreshDriverTimer::TickDriver(nsRefreshDriver *,__int64,mozilla::TimeStamp) [layout/base/nsRefreshDriver.cpp:197]
21:48:56 INFO - #25: mozilla::RefreshDriverTimer::Tick(__int64,mozilla::TimeStamp) [layout/base/nsRefreshDriver.cpp:187]
21:48:56 INFO - #26: mozilla::VsyncRefreshDriverTimer::RunRefreshDrivers(mozilla::TimeStamp) [layout/base/nsRefreshDriver.cpp:439]
21:48:56 INFO - #27: mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::TickRefreshDriver(mozilla::TimeStamp) [layout/base/nsRefreshDriver.cpp:374]
21:48:56 INFO - #28: nsRunnableMethodImpl<void ( mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::*)(mozilla::TimeStamp),1,mozilla::TimeStamp>::Run() [xpcom/glue/nsThreadUtils.h:828]
21:48:56 INFO - #29: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:849]
21:48:56 INFO - #30: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/glue/nsThreadUtils.cpp:265]
21:48:56 INFO - #31: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:95]
21:48:56 INFO - #32: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:234]
21:48:56 INFO - #33: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:228]
21:48:56 INFO - #34: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:202]
21:48:56 INFO - #35: nsBaseAppShell::Run() [widget/nsBaseAppShell.cpp:167]
21:48:56 INFO - #36: nsAppShell::Run() [widget/windows/nsAppShell.cpp:180]
21:48:56 INFO - #37: nsAppStartup::Run() [toolkit/components/startup/nsAppStartup.cpp:281]
21:48:56 INFO - #38: XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:4275]
21:48:56 INFO - #39: XREMain::XRE_main(int,char * * const,nsXREAppData const *) [toolkit/xre/nsAppRunner.cpp:4359]
21:48:56 INFO - #40: XRE_main [toolkit/xre/nsAppRunner.cpp:4448]
21:48:56 INFO - #41: do_main [browser/app/nsBrowserApp.cpp:212]
21:48:56 INFO - #42: NS_internal_main(int,char * *) [browser/app/nsBrowserApp.cpp:399]
21:48:56 INFO - #43: wmain [toolkit/xre/nsWindowsWMain.cpp:138]
21:48:56 INFO - #44: __tmainCRTStartup [f:/dd/vctools/crt/crtw32/startup/crt0.c:255]
21:48:56 INFO - #45: kernel32 + 0x53c45
21:48:56 INFO - #46: ntdll + 0x637f5
21:48:56 INFO - #47: ntdll + 0x637c8
Comment hidden (Treeherder Robot)
(Assignee)

Updated

4 years ago
Assignee: nobody → mchang
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 8630628 [details] [diff] [review]
Log different backend types

Logging to see what kind of backend type we're getting.
(Assignee)

Updated

4 years ago
Keywords: leave-open
Whiteboard: gfx-noted
(Assignee)

Comment 5

4 years ago
Doh! Thanks for the backout. 

Updated patch with try - https://treeherder.mozilla.org/#/jobs?repo=try&revision=ff0d9544a07a

Figured I'll wait this time.
Flags: needinfo?(mchang)
(Assignee)

Comment 8

4 years ago
Created attachment 8631092 [details] [diff] [review]
Delete draw target assertion

Delete the assertion at [1]. See bug 1181442. For example, when printing the page, the source draw target is correctly the host OS backend, e.g. CoreGraphics on OS X, but the print page backend is Cairo. The assertion is invalid, so delete it.

[1] https://dxr.mozilla.org/mozilla-central/source/gfx/thebes/gfxBlur.cpp?from=gfxBlur.cpp&case=true#442
Attachment #8631092 - Flags: review?(mstange)
(Assignee)

Updated

4 years ago
Attachment #8630628 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1181442
Attachment #8631092 - Flags: review?(mstange) → review+
(Assignee)

Updated

4 years ago
Keywords: leave-open
(Reporter)

Comment 11

4 years ago
https://hg.mozilla.org/mozilla-central/rev/4a67e35361f5
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
status-firefox40: --- → unaffected
status-firefox41: --- → unaffected
status-firefox-esr31: --- → unaffected
status-firefox-esr38: --- → unaffected
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1217186
You need to log in before you can comment on or make changes to this bug.