ford.com subsections takes an extremely long time to render

NEW
Unassigned

Status

()

Core
Layout
3 years ago
3 years ago

People

(Reporter: Leman Bennett [Omega], Unassigned)

Tracking

Trunk
x86_64
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
http://www.ford.com/

Just browse it. Network Tools state that the elements get there pretty quickly. But there's a very long pause for displaying pages. In Chrome and Internet Explorer navigating is instantaneous. 

The same slow behavior is also in Fx39.0
I loaded ford.com in firefox nightly and chrome, firefox felt faster (no science was used in this comparison).
Loads quite quickly for me in Nightly as well.

Leman, I'm guessing you're seeing this behavior on the Release channel. Do you still see performance issues on Nightly?

Also, can you clarify what you mean by a "long pause"? 10 seconds? 1 minute?
Flags: needinfo?(lh.bennett)
(Reporter)

Comment 3

3 years ago
 (In reply to Seth Fowler [:seth] from comment #2)
> Loads quite quickly for me in Nightly as well.
> 
> Leman, I'm guessing you're seeing this behavior on the Release channel. Do
> you still see performance issues on Nightly?
> 
> Also, can you clarify what you mean by a "long pause"? 10 seconds? 1 minute?

I'm seeing this on both Nightly and Release.

If you load just the intro page its competitive enough. But again, browse the site, you'll see it easily enough.

Load into anything other than the index, say this one for example: http://www.ford.com/cars/focus/gallery/photos/

It takes an additional 5-6 seconds compared to IE and Chrome. I see this throughout the site on anything other than a simple intro page filled with simple images and text. 

For example: http://www.ford.com/cars/focus/?gnav=header-cars

Will load competitively with other browsers. Chrome will load it slightly faster than everyone else.

But dive into the sub-menu items: http://www.ford.com/cars/focus/pricing/

Again a 5-6 second pause. Fx release and nightly show the exact same behavior.
Flags: needinfo?(lh.bennett)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

3 years ago
Changed the title to something more accurate.
Summary: ford.com takes an extremely long time to render → ford.com subsections takes an extremely long time to render
You need to log in before you can comment on or make changes to this bug.