[PP]input type=file cannot be disabled

VERIFIED FIXED

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: phillip, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Overview Description:
	html like this doens't disable file input controls:
	<input type="file" disabled>

Steps to Reproduce:
	1) open the attatchment [to come]
	2) click the 'Browse...' button

Actual Results:

	A file open dialog/picker thingy appears.

Expected Results:

	It should not appear.

Build Date & Platform: (viewer && apprunner)
     1999-08-11-01 RedHat Linux 6.0 (GNOME/enlightenment)
     1999-08-12-10 WinNT 4.0 sp5
     1999-08-12-08 MacOS 8.51
(Reporter)

Comment 1

19 years ago
Created attachment 1220 [details]
html testcase

Updated

19 years ago
Assignee: karnaze → kmcclusk

Comment 2

19 years ago
Reassigning to Kevin.

Updated

19 years ago
Assignee: kmcclusk → rods
Rod re-assigning to you
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
Fixed.
(Reporter)

Updated

19 years ago
Whiteboard: [19990830]can't verify until win32 is more stable
(Reporter)

Comment 5

19 years ago
verified fixed on

     1999-08-30-02-M10 RedHat Linux 6.0 (GNOME/enlightenment)
     1999-08-30-10-M10 MacOS 8.51

but html inputs and file input controls are crashing on
     1999-08-30-10-M10 WinNT 4.0 sp5

not sure if it's the same problem, so i'll look around for that bug and
wait to verify until it is fixed...
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
OS: All → Linux
Hardware: All → PC
Summary: input type=file cannot be disabled → [PP]input type=file cannot be disabled
Whiteboard: [19990830]can't verify until win32 is more stable
(Reporter)

Comment 6

19 years ago
verified fixed on
     1999-09-14-09-M10 WinNT 4.0 sp5
     1999-09-14-09-M10 MacOS 8.51

but broken on
     1999-09-14-09-M10 RedHat Linux 6.0 (GNOME/enlightenment)

specifically, on linux, the "browse..." button contains no text and is about 3
pixels wide. if you click the button, a file picker comes up, and you can pick
a file. the filename will be inserted in the grayed out textfield.

reopening and changing platform info.

Updated

19 years ago
Resolution: FIXED → ---

Comment 7

19 years ago
Clearing FIXED resolution due to reopen of this bug.
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

18 years ago
Just tested this on Linux with the above attachment. it appears to be fixed.

Updated

18 years ago
QA Contact: phillip → desale

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Verified with 1999-11-29-09.
You need to log in before you can comment on or make changes to this bug.