Closed Bug 1181101 Opened 5 years ago Closed 5 years ago

Statusbar gets paused when opening the cards view

Categories

(Firefox OS Graveyard :: Gaia::System::Status bar, Utility tray, Notification, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected
b2g-master --- verified

People

(Reporter: apastor, Assigned: apastor)

References

Details

Attachments

(3 files)

STR:

1.- Open Settings
2.- Longpress the home button (cards view)
3.- Go back to settings
4.- Make changes to the icons (enable/disable NFC, Bluetooth...)

Expected:

The statusbar gets updated

Actual

It remains the same
Let's check branches
Keywords: qawanted
This bug can be repro on latest Nightly build of Flame v2.2&Master by the STR in Comment 0, but can't be repro on latest Flame v2.1.

Actual results: The statusbar remains the same and is not updated after long pressing Home button.
See attachment: Flame_v2.2.3gp and logcat_0417.txt
Reproduce rate: 8/8(v2.2&Master), 0/10(v2.1)


Device: Flame v2.1 build(unaffected)
Build ID               20150707001206
Gaia Revision          d13826b20b4a45e3f5cd4b25a30a737d8be7f1b9
Gaia Date              2015-07-02 23:36:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/37de99064c33
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150707.035032
Firmware Date          Tue Jul  7 03:50:44 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v2.2 (affected) 
Build ID               20150707162503
Gaia Revision          ea11f422b687a982f0a961c9aea7858066561707
Gaia Date              2015-07-02 23:37:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/52d19a805d35
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150707.202802
Firmware Date          Tue Jul  7 20:28:14 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (affected)
Build ID               20150707160207
Gaia Revision          86af137c7f4c41c1185e609339002ab47fd6c640
Gaia Date              2015-07-07 17:02:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9340658848d1
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150707.193318
Firmware Date          Tue Jul  7 19:33:30 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
blocking-b2g: --- → 2.2?
Assignee: nobody → apastor
[Blocking Requested - why for this release]:
blocking-b2g: 2.2? → 2.5?
blocking-b2g: 2.5? → 2.5+
Attachment #8630972 - Flags: review?(etienne)
Attachment #8630972 - Flags: review?(etienne) → review+
Duplicate of this bug: 1183928
master: https://github.com/mozilla-b2g/gaia/commit/38ad6b7600ed6327bed542517258af0020fefd78
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This issue is verified fixed on Aries and Flame. Status bar correctly updates after doing original STR as well as STR from bug 1183928.

Device: Aries 2.5
BuildID: 20150721153949
Gaia: 805cf546729ba742bf23febda52970fcb35c0e8f
Gecko: 512c7e8f0030
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
BuildID: 20150721010202
Gaia: 4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko: 3a4bfa5d2d02
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+], [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [MGSEI-Triage+], [QAnalyst-Triage?] → [MGSEI-Triage+], [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Per comment 9, change the 'status-b2g-master:' as verified.
You need to log in before you can comment on or make changes to this bug.