Closed Bug 1181133 Opened 4 years ago Closed 4 years ago

Remove Google logo from aboutHome.js

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1171344

People

(Reporter: mak, Unassigned, Mentored)

Details

(Whiteboard: [good first bug][lang=js])

We show a magnifier on about:home in default case, doesn't make sense to make Google special, providing a logo just for it.
Also I think when about:home will grow one-click search UI, this should regardless be removed.

This would make aboutHome.js much smaller since we could remove SEARCH_ENGINES along with the big datauri, and some supporting code.
See http://mxr.mozilla.org/mozilla-central/source/browser/base/content/abouthome/aboutHome.js#7

Setting a needinfo on mconnor, just to be sure we can do this (but I assume we have no roadblocks).
Flags: needinfo?(mconnor)
Flags: firefox-backlog+
Yes, please kill it.

Should we kill the images in search plugins?
Flags: needinfo?(mconnor)
(In reply to Mike Connor [:mconnor] from comment #1)
> Yes, please kill it.
> 
> Should we kill the images in search plugins?

I'm sorry but I don't have an answer to that, all the plans and mock-ups I saw around are just showing icons, I don't know if we use full logo images anywhere else. Regardless we would miss hi-dpi versions, so it's unlikely we can use those anywhere.

Btw, here I was just referring to the homepage logo, anything else can be done in another bug. Who should we ask to, regarding search plugins, now that Gavin left?
ah wait, we do have hidpi versions of the logos, indeed we have 65x26 and 130x52 images. We don't have hidpi versions of the icons (ugh!).
We do have hidpi icons, the 16x16 .ico files have multiple sizes. Yes, that's a pain.
looks like bug 1171344 is already doing this
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171344
You need to log in before you can comment on or make changes to this bug.