Event notification accept/decline/etc buttons in Lightning missing (again)

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: snafuxnj, Unassigned)

Tracking

Lightning 4.0.0.1

Details

(Whiteboard: [addon:ExQuilla])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.130 Safari/537.36

Steps to reproduce:

Install TB 38.0.1 in OSX Yosemite
Install Lightning addon ver 4.0.0.1
Have someone send you a meeting invitation



Actual results:

No accept/decline buttons in window, tab, or otherwise views of the invitation.


Expected results:

Buttons should exist to allow recipient to accept, decline, or respond to the invitation giving recipient option to change reminder types and times. Upon response, invitation is saved or otherwise to recipient's calendar and a reply maybe sent to sender of recipient's decision.

Updated

3 years ago
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 38 → Lightning 4.0

Comment 1

3 years ago
Just to be sure, you're talking about email invitations? What calendars do you use?

Do you have other extensions installed? If so, does the issue persist if you disable all of them? If not, please re-enable one by one to identify that one causing the issue. Thunderbird Conversations is known for that already.

Have you any messages in the error console when displaying the invitation?

Updated

3 years ago
Flags: needinfo?(snafuxnj)
(Reporter)

Comment 2

3 years ago
The calendar used where this is failing is exchange calendars integrated with lightning.

Extensions installed are: 

enigmail 1.8.2
exquilla 38.0.1159
importexporttoools 3.2.1
lightning 4.0.0.1

Error console contains the following (after clearing error console and then highlighting errant invitation in TB):

NOTE: this error occurs twice

Timestamp: 7/8/15, 11:01:30 AM
Error: Assert failed: [Exception... "JavaScript component does not have a method named: "getItem"'JavaScript component does not have a method named: "getItem"' when calling method: [calICalendar::getItem]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame :: file:///Users/user/Library/Thunderbird/Profiles/wg4mjve3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js :: calCompositeCalendar.prototype.getItem :: line 373"  data: no]
2: [file:///Users/user/Library/Thunderbird/Profiles/wg4mjve3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:375] calCompositeCalendar.prototype.getItem
3: [resource://calendar/modules/calItipUtils.jsm:1150] findItem
4: [resource://calendar/modules/calItipUtils.jsm:1105] findItem
5: [resource://calendar/modules/calItipUtils.jsm:513] cal_itip_processItipItem
6: [chrome://lightning/content/imip-bar.js:91] ltnImipBar_observe
7: [file:///Users/user/Library/Thunderbird/Profiles/wg4mjve3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js:322] lmcCTH
8: [null:0] null

Source File: resource://calendar/modules/calUtils.jsm -> file:///Users/user/Library/Thunderbird/Profiles/wg4mjve3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1001





Disabled all add-ons and restarted TB. Obviously after all add-ons disabled, I wasn't able to access the mailbox as it's an exquilla/exchange box.

Re-enabled exquilla and restarted TB. Able to access mbox now, but highlighting invitation fails to recognize message as an invitation.

Re-enabled lightning and restarted TB. Invitation now recognized, but buttons missing to accept/deny/reschedule etc (this reported bug).

NOTE: Eventually got this error before restarting TB, but I think this is a red-herring:

//////////////
Timestamp: 7/8/15, 11:11:28 AM
Error: Unix error 14 during operation makeDir (Bad address)
Source File: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js
Line: 870
/////////////

/////////////
Also getting errors similar to this:

Timestamp: 7/8/15, 11:13:29 AM
Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "can't access lexical declaration `event' before initialization" {file: "resource://exquilla/ewsCalendar.jsm" line: 670}]'[JavaScript Error: "can't access lexical declaration `event' before initialization" {file: "resource://exquilla/ewsCalendar.jsm" line: 670}]' when calling method: [msqIEwsEventListener::onEvent]
Source File: resource://exquilla/datastore.js Line: 115

Received similar ("can't access lexical declaration `event' before initialization") for resource://exquilla/ewsUtils.jsm (line 107)
/////////////




Re-enabled enigmail and restarted TB. Same outcome with "getItem" exception.

Re-enabled importexporttools and restarted TB. Same outcome.
Flags: needinfo?(snafuxnj)
Because the calendar is provided by the exquilla extension I think the errors in exquilla/ewsCalendar.jsm might affect Lightnings functionality.

Rkent, are you the R Kent James listed as the author of exquilla extension? If yes, do you know about those errors?
Flags: needinfo?(rkent)

Comment 4

3 years ago
ExQuilla does not officially support Calendar, though there is an unsupported hidden option to enable that for a test. I do not recommend that this feature be used, and I have frankly not tested it for over a year myself.

ExQuilla uses typically use this addon for Calendar support:

https://github.com/Ericsson/exchangecalendar/releases
Flags: needinfo?(rkent)
(Reporter)

Comment 5

3 years ago
RKent, I read your warning and used the hidden option (prefs.js hack) to enable the use of the calendar since you stated in the warning that the broken part dealt with timezone hackery, which doesn't affect me. Perhaps there is more?
(Reporter)

Comment 6

3 years ago
I'll disable the exquilla calendar hack and use the link above, test, and reply to the list with the outcome.
(Reporter)

Comment 7

3 years ago
OK. In account settings, I disabled exchange calendar system. In config editor under advanced settings, I switched hack from false to true. I installed the suggested add-on and restarted TB. The invitations now work. Thanks for the assist and sorry for the confusion. This is resolved.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: General → E-mail based Scheduling (iTIP/iMIP)
Resolution: --- → INVALID
Whiteboard: [addon:ExQuilla]
You need to log in before you can comment on or make changes to this bug.