/whatsnew Firefox 40 - Development

RESOLVED DUPLICATE of bug 1186485

Status

www.mozilla.org
Pages & Content
RESOLVED DUPLICATE of bug 1186485
3 years ago
3 years ago

People

(Reporter: ckprice, Assigned: agibson)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1800815] )

Attachments

(1 attachment)

This is the implementation bug for /whatsnew for Firefox 40. 

Design is in bug 1180020.
More specifications.

- Only see traffic from Windows 10 users[0]
- UITour piece to add a CTA which will open the Windows 10 default settings app[1]

[0] /whatsnew URL bug - https://bugzilla.mozilla.org/show_bug.cgi?id=1181182
[1] Default browser UITour bug - https://bugzilla.mozilla.org/show_bug.cgi?id=1175293
(Assignee)

Comment 2

3 years ago
Just seen the current design/mockups for this page:

https://drive.google.com/a/mozilla.com/file/d/0B5T1SCKaYZL8b0Jna09sX3liVW9HT1U2RmpGQW03Q0pnd1o0/view

Only thing that really stands out is the screenshot image with a lot of English text - are we being provided with localized images for this?
Whiteboard: [kb=1800815]
(Assignee)

Updated

3 years ago
Assignee: nobody → agibson
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
Copy questions that need some clarification:

1.) We have two strings that are identical, but one features a link and the other doesn't:

"We’ve designed Firefox to work seamlessly with your Windows 10 update, giving you the same great browsing experience you’ve come to love, with the privacy, speed and choice you’ve come to expect."

"We’ve designed Firefox to work seamlessly with your Windows 10 update, giving you the same great browsing experience you’ve come to love, with the <a href="#">privacy, speed and choice</a> you’ve come to expect."

Question - Can we just decide on / use one?

2.) There is a note on the copy slide that needs further clarification:

Privacy >>
Speed >>
Choice >>

"Please translate the three terms (privacy, speed and choice) separately as well. We may offer a design with separate links for these pages."

Question - Does this mean there is further copy to come that gives context to these links, or does it mean we might use a separate link for each word in the paragraph, like this?

"We’ve designed Firefox to work seamlessly with your Windows 10 update, giving you the same great browsing experience you’ve come to love, with the <a href="#">privacy</a>, <a href="#">speed</a> and <a href="#">choice</a> you’ve come to expect."

Any of these options might imply a string change, and it would be great not to ask localizers to translate all these variations unless really necessary.

3. I am not going to include this string in the template, unless anyone has objections?

"Firefox. As awesome as ever with Windows 10."

If this is just for a test and for en-US only, then perhaps it is better handled via Optimizely rather than asking for it to be translated? We rarely seem to have time act on tests for short lived pages such as this, so is it worth translating the string?
Flags: needinfo?(cprice)
(Assignee)

Comment 5

3 years ago
Another question:

"Firefox + Windows 10. Perfect together."

It would be nice to have some updated visual designs featuring this copy. For example, might we need to insert a line break between sentences, depending on how we want the page to look? e.g. "Firefox + Windows 10.<br> Perfect together."
Can we put the two images somewhere public (e.g. Bugzilla attachment)? I'm not sure if we're going to have a demo page soon, and having the design available would help localizers.
Some more notes after looking at the current WIP PR:
* Still missing an answer for 1) in Comment 4 (same string with and without link). Do we need both?
* We'd need some way to test the 2 versions of the page (query switch?)
(Assignee)

Comment 9

3 years ago
I have answers to the questions in Comment 4 via an email. I'm not sure I can post the final designs here (although I don't really see why tbh), but will try and get something up on a demo server today that is more concrete.

Localizers will be able to switch between the two designs by toggling Firefox as their default browser, but I'll try and bake in a query param toggle to make it a bit easier.
(Assignee)

Comment 11

3 years ago
When this goes on a demo server do we need to password protect it? I really don't know why we should be worrying about this page, but there seems to be resilience to posting designs here. All other bugs involved in this work are already public, fwiw.
There doesn't have to be any special protection on this page. I've asked that we make the doc public in the design bug.
(Assignee)

Comment 13

3 years ago
Thanks, Cory - placeholder page is now up on demo2 here:

https://www-demo2.allizom.org/en-US/firefox/40.0/whatsnew/

Note: the detection should be working based on whether or not Firefox is the default browser, but the "Let's do it" CTA button is not yet functional.

Localizers can also use a toggle to quickly test each state by appending the following query param to the end of the URL:

?default=false
(Assignee)

Comment 14

3 years ago
Initial design implementations for review:

https://www-demo2.allizom.org/en-US/firefox/40.0/whatsnew/?default=false

https://www-demo2.allizom.org/en-US/firefox/40.0/whatsnew/

My only thought so far is that the logo for when Firefox is set as your default browser feels way too big. I think we should use the smaller logo on both designs.
(Assignee)

Comment 15

3 years ago
Another design related question:

Currently the PSD seems to use a mixture of both Open Sans and Fira. I'm not sure if this is intentional, so currently the above links are just using Open Sans.

I'd like to put forward the notion that we should be using one font or the other, but not both (unless it is really vital to the design in some way). Using both font-family styles adds heavily to page weight, and given the importance of /whatsnew, we should prioritize putting visible content in from of people's eyes as quickly as we can.

Any thoughts on this one, Lee?
Flags: needinfo?(ltom)

Comment 16

3 years ago
Hi Alex, all fonts should be in Fira. The PSD I started designing from probably contains Open Sans. Apologies - this is not intentional. Can you tell me where you see Open Sans in the file, that way I can remove them for future comps. 

Regarding the size of the logo, I think it will be helpful to see it in demo and adjust accordingly. For the Firefox as default browser version, the logo was meant to be large - but again, seeing it live will give us a better idea of how to adjust the scale. 

 

(In reply to Alex Gibson [:agibson] from comment #15)
> Another design related question:
> 
> Currently the PSD seems to use a mixture of both Open Sans and Fira. I'm not
> sure if this is intentional, so currently the above links are just using
> Open Sans.
> 
> I'd like to put forward the notion that we should be using one font or the
> other, but not both (unless it is really vital to the design in some way).
> Using both font-family styles adds heavily to page weight, and given the
> importance of /whatsnew, we should prioritize putting visible content in
> from of people's eyes as quickly as we can.
> 
> Any thoughts on this one, Lee?
Flags: needinfo?(ltom)
(Assignee)

Comment 17

3 years ago
Thanks Lee,

I'll update to use Fira and make note on where I see Open Sans in the PSD.

As for viewing the logo, you can see it on demo2 using the above URL's

Note: you need to enable UITour for demo2:

1.) open about:config
2.) create a pref called 'browser.uitour.testingOrigins'
3.) give that pref a value of 'https://www-demo2.allizom.org'

Then visit:

https://www-demo2.allizom.org/en-US/firefox/40.0/whatsnew/

You should see the page in each state depending on if Firefox is your default browser. You need to do this in Firefox 40 or later for it to work.

Comment 18

3 years ago
Created attachment 8636166 [details]
firefox-40_whatsnew_windows10_dev_2.jpg

Heya, Alex 
Per our conversation around demo2 and the size/placement of the logo, I reduced the scale of it and adjusted the margins between the tabzilla and the logo. Take a look at this reference JPG and let me know if it helps pulling the contents on the page up a bit inside the browser. 

Also, I'm guessing the headline will eventually be formatted to Fira Sans Light Italic? 

Thanks!
(Assignee)

Comment 19

3 years ago
Ok, latest version is now up on demo2:

This is using the latest version of Fira Sans

https://www-demo2.allizom.org/en-US/firefox/40.0/whatsnew/

Also, clicking the "Let's do it" CTA button should now set Firefox as your default browser. I don't have a Windows 10 machine to test this on, but it works here for me on OSX.

Note that if your default browser has already been set to Firefox, clicking the button again does nothing (on OSX at least).
(In reply to Alex Gibson [:agibson] from comment #19)
> Also, clicking the "Let's do it" CTA button should now set Firefox as your
> default browser. I don't have a Windows 10 machine to test this on, but it
> works here for me on OSX.

It opens Settings->Default apps on my VM (build 10064), which I think is correct/expected.
(Assignee)

Comment 21

3 years ago
(In reply to Francesco Lodolo [:flod] from comment #20)
> (In reply to Alex Gibson [:agibson] from comment #19)
> > Also, clicking the "Let's do it" CTA button should now set Firefox as your
> > default browser. I don't have a Windows 10 machine to test this on, but it
> > works here for me on OSX.
> 
> It opens Settings->Default apps on my VM (build 10064), which I think is
> correct/expected.

Thanks, Flod. Yes I believe that's the correct behavior for Win10.
Resolving as a duplicate of the Welcome page bug. See bug 1186485 for more information.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1186485
You need to log in before you can comment on or make changes to this bug.