firefox 39 ignores contents of the address bar

RESOLVED DUPLICATE of bug 1180419

Status

()

RESOLVED DUPLICATE of bug 1180419
3 years ago
3 years ago

People

(Reporter: andrew.dingwall, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Recently I upgraded from firefox 38 to firefox 39.
Now, it ignores anything typed in the address bar, both when typing a RETURN or clicking on the little arrow at the right-hand end.
Although links, bookmarks, new tab page still work OK.

I tried rebooting, but that didn't help.
I downgraded to firefox 38 - address bar worked as expected.
I upgraded to firefox 39 - address bar was ignored again.

So for now I am stuck with firefox 38.


Actual results:

firefox ignores address bar contents, both when typing RETURN or clicking on the little arrow at the right-hand end of the address bar.


Expected results:

firefox should (at least attempt to) connect to the URL typed in the address bar

Comment 1

3 years ago
Andrew, could you send by email the file places.sqlite (from your profile) to Marco, he is the Moz dev who's going to debug that.
https://bugzilla.mozilla.org/show_bug.cgi?id=1180419#c12
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1180419

Updated

3 years ago
Flags: needinfo?(andrew.dingwall)
(Reporter)

Comment 2

3 years ago
places.sqlite file sent as requested.
Hi andrew, I'm testing your file in Firefox 39, but I cannot reproduce any issue. I can type and select entries from the locationbar, I can type new addresses and visit them.

I can only see recent history from today, and looks like you don't have any keywords, that makes this different from bug 1180419, where my primary suspect is keyword changes.

Is this the same database that didn't work for you, of did you generate a new one?

did you try Safe Mode to esclude add-ons? https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

would you mind attaching a log from your about:support page to this bug report?
(Reporter)

Comment 4

3 years ago
Hmm ... I just re-installed firefox 39 and the location bar works for me as well now.
Which is odd because yesterday I stepped backwards and forwards between 38 and 39 twice
and the problem was only apparent in 39.

And - yes - now I see that there is no history before today.

I didn't try safe mode or any other tricks.
The only other thing I did was to reboot between the first and second installs of 39 yesterday.
I haven't rebooted between then and today's install of 39.

Yesterday I found a firefox support web page that included a refresh button.
(I could still navigate after a fashion by using the google search box)
But when I pressed the button it didn't appear to do anything.
Flags: needinfo?(andrew.dingwall)
(Reporter)

Comment 5

3 years ago
Created attachment 8631035 [details]
about:support log

about:support log attached as requested
do you have a places.sqlite-corrupt file in the profile folder?
You need to log in before you can comment on or make changes to this bug.