Intermittent apps/ftu/test/marionette/language_pseudo_localization_test.js | First Time Use > Pseudo Localization "before each" hook

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: philor, Assigned: kgrandon)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Comment hidden (empty)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Created attachment 8638954 [details] [review]
[gaia] KevinGrandon:bug_1181419_ftu_pseudo_localization_test > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Blocks: 1035226
(Assignee)

Comment 19

3 years ago
Comment on attachment 8638954 [details] [review]
[gaia] KevinGrandon:bug_1181419_ftu_pseudo_localization_test > mozilla-b2g:master

Hey Sam - could you give this patch to resolve an intermittent failure a review? Thanks!
Attachment #8638954 - Flags: review?(sfoster)
(Assignee)

Updated

3 years ago
Assignee: nobody → kgrandon
Comment on attachment 8638954 [details] [review]
[gaia] KevinGrandon:bug_1181419_ftu_pseudo_localization_test > mozilla-b2g:master

That looks like a good call and works locally for me (fwiw) Gij38 seems to be having a cow - I think unrelated but we should get a clean run if possible before landing
Attachment #8638954 - Flags: review?(sfoster) → review+
(Assignee)

Comment 21

3 years ago
Looks like a Gij38 retrigger seems to have passed. Thanks for the review!

In master: https://github.com/mozilla-b2g/gaia/commit/bebdd0c23149d57d26369adbfa08f392841c97b8
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Still happening it appears :(
Status: RESOLVED → REOPENED
Flags: needinfo?(kevingrandon)
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 39

3 years ago
I am debugging this, but anyone is free to jump on it until I can find a fix (I don't have any solid hints hunches yet).
Assignee: kevingrandon → nobody
(Assignee)

Comment 40

3 years ago
Think I've got a fix for this, ~20 passing runs here:  https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=e3b16abd1bad2b6ac66f0ecb138673648fe7ef51
Assignee: nobody → kevingrandon
Status: REOPENED → ASSIGNED
Flags: needinfo?(kevingrandon)
Created attachment 8640260 [details] [review]
[gaia] KevinGrandon:bug_1181419_debug_test > mozilla-b2g:master
(Assignee)

Comment 42

3 years ago
Comment on attachment 8640260 [details] [review]
[gaia] KevinGrandon:bug_1181419_debug_test > mozilla-b2g:master

Sam - could you review this? I don't know why, but it seems to fix the races. I assume that using such a short timeout causes some platform race condition. I don't see a reason to use a short timeout in these tests, so I think we should just use a normal client here. Thanks!
Attachment #8640260 - Flags: review?(sfoster)
Comment on attachment 8640260 [details] [review]
[gaia] KevinGrandon:bug_1181419_debug_test > mozilla-b2g:master

Thanks for digging into this, I just sat down to do so myself and saw your review request :) Yeah it does seem a bit odd, but dialing it back to the default timeout for this case (which we use successfully without complaint most everywhere else) looks just fine to me.
Attachment #8640260 - Flags: review?(sfoster) → review+
(Assignee)

Comment 44

3 years ago
Thank you for the review! We should probably dig into the platform issue at some point to figure out what exactly is going on, but glad we found this. It seems that rtl_test.js might also have the same problem, if there's an intermittent bug for that one, we may want to try the same fix.

In master: https://github.com/mozilla-b2g/gaia/commit/bbf14824939479074049ff4c3888614794c4cec1
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.