Closed Bug 1181419 Opened 5 years ago Closed 4 years ago

Intermittent apps/ftu/test/marionette/language_pseudo_localization_test.js | First Time Use > Pseudo Localization "before each" hook

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philor, Assigned: kgrandon)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

No description provided.
Blocks: 1035226
Comment on attachment 8638954 [details] [review]
[gaia] KevinGrandon:bug_1181419_ftu_pseudo_localization_test > mozilla-b2g:master

Hey Sam - could you give this patch to resolve an intermittent failure a review? Thanks!
Attachment #8638954 - Flags: review?(sfoster)
Assignee: nobody → kgrandon
Comment on attachment 8638954 [details] [review]
[gaia] KevinGrandon:bug_1181419_ftu_pseudo_localization_test > mozilla-b2g:master

That looks like a good call and works locally for me (fwiw) Gij38 seems to be having a cow - I think unrelated but we should get a clean run if possible before landing
Attachment #8638954 - Flags: review?(sfoster) → review+
Looks like a Gij38 retrigger seems to have passed. Thanks for the review!

In master: https://github.com/mozilla-b2g/gaia/commit/bebdd0c23149d57d26369adbfa08f392841c97b8
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Still happening it appears :(
Status: RESOLVED → REOPENED
Flags: needinfo?(kevingrandon)
Resolution: FIXED → ---
I am debugging this, but anyone is free to jump on it until I can find a fix (I don't have any solid hints hunches yet).
Assignee: kevingrandon → nobody
Think I've got a fix for this, ~20 passing runs here:  https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=e3b16abd1bad2b6ac66f0ecb138673648fe7ef51
Assignee: nobody → kevingrandon
Status: REOPENED → ASSIGNED
Flags: needinfo?(kevingrandon)
Comment on attachment 8640260 [details] [review]
[gaia] KevinGrandon:bug_1181419_debug_test > mozilla-b2g:master

Sam - could you review this? I don't know why, but it seems to fix the races. I assume that using such a short timeout causes some platform race condition. I don't see a reason to use a short timeout in these tests, so I think we should just use a normal client here. Thanks!
Attachment #8640260 - Flags: review?(sfoster)
Comment on attachment 8640260 [details] [review]
[gaia] KevinGrandon:bug_1181419_debug_test > mozilla-b2g:master

Thanks for digging into this, I just sat down to do so myself and saw your review request :) Yeah it does seem a bit odd, but dialing it back to the default timeout for this case (which we use successfully without complaint most everywhere else) looks just fine to me.
Attachment #8640260 - Flags: review?(sfoster) → review+
Thank you for the review! We should probably dig into the platform issue at some point to figure out what exactly is going on, but glad we found this. It seems that rtl_test.js might also have the same problem, if there's an intermittent bug for that one, we may want to try the same fix.

In master: https://github.com/mozilla-b2g/gaia/commit/bbf14824939479074049ff4c3888614794c4cec1
Status: ASSIGNED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.