Closed Bug 1181425 Opened 7 years ago Closed 6 years ago

Settings TableViewCells that aren't buttons shouldn't show animation on tap

Categories

(Firefox for iOS :: Theme & Visual Design, defect)

ARM
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: BigxMac, Assigned: BigxMac)

Details

(Keywords: polish)

Attachments

(1 file)

47 bytes, text/x-github-pull-request
bnicholson
: review+
Details | Review
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150703004018

Steps to reproduce:

Navigate to the settings and tap any cell


Actual results:

Button was highlighted on tap when it shouldn't be
I would like to take on this bug
Assignee: nobody → allmacosx24
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: polish
Hardware: Other → ARM
Are you sure this is a bug? I see the same behaviour in the system Settings.app
Not necessarily a bug but something we should do for polish. We need to turn off selection for the table view since the rows themselves are not selectable:

> cell.selectionStyle = UITableViewCellSelectionStyle.None
Attached file Pull Request
Attachment #8631735 - Flags: review?(bnicholson)
Comment on attachment 8631735 [details] [review]
Pull Request

Looks good. Left some cleanup comments in the PR.
Attachment #8631735 - Flags: review?(bnicholson) → feedback+
Attachment #8631735 - Flags: feedback+ → review+
Looks good. Thanks for the contribution!

https://github.com/mozilla/firefox-ios/commit/05fc9c2d2c2cdb160c530591701ac1de89a89d1c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.