Assertion failure: mGotTimecodeScale, at dom/media/webm/WebMBufferedParser.cpp:172

RESOLVED FIXED in Firefox 41

Status

()

Core
Audio/Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

Trunk
mozilla42
Points:
---

Firefox Tracking Flags

(firefox41 fixed, firefox42 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
this is a regression from bug 1175768

This is not the same as bug 1180881, even though the stack trace are similar.

Assertion failure: mGotTimecodeScale, at /Users/jyavenard/Work/Mozilla/mozilla-central/dom/media/webm/WebMBufferedParser.cpp:172
#01: mozilla::WebMBufferedParser::Append(unsigned char const*, unsigned int, nsTArray<mozilla::WebMTimeDataOffset>&, mozilla::ReentrantMonitor&)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x33c613c]
#02: mozilla::WebMBufferedState::NotifyDataArrived(unsigned char const*, unsigned int, long long)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x33c6c33]
#03: mozilla::WebMReader::NotifyDataArrivedInternal(unsigned int, long long)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x33ca6b3]
#04: mozilla::MediaDecoderReader::NotifyDataArrived(mozilla::media::Interval<long long> const&)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x3104a17]
#05: mozilla::TrackBuffer::InitializeDecoder(mozilla::SourceBufferDecoder*)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x327cb1c]
#06: void nsRunnableMethodArguments<mozilla::SourceBufferDecoder*>::apply<mozilla::TrackBuffer, void (mozilla::TrackBuffer::*)(mozilla::SourceBufferDecoder*)>(mozilla::TrackBuffer*, void (mozilla::TrackBuffer::*)(mozilla::SourceBufferDecoder*))[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x32a10ef]
#07: nsRunnableMethodImpl<void (mozilla::TrackBuffer::*)(mozilla::SourceBufferDecoder*), true, mozilla::SourceBufferDecoder*>::Run()[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x32a0e1c]
#08: mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run()[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x30a2899]
#09: mozilla::MediaTaskQueue::Runner::Run()[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x31c60cd]
#10: nsThreadPool::Run()[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x198898]
#11: non-virtual thunk to nsThreadPool::Run()[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x19899c]
#12: nsThread::ProcessNextEvent(bool, bool*)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x195393]
#13: NS_ProcessNextEvent(nsIThread*, bool)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x2075e7]
#14: mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x84c5ce]
#15: MessageLoop::RunInternal()[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x7b8e05]
#16: MessageLoop::RunHandler()[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x7b8d15]
#17: MessageLoop::Run()[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x7b8cbd]
#18: nsThread::ThreadFunc(void*)[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/XUL +0x193919]
#19: _pt_root[/Users/jyavenard/Work/Mozilla/mozilla-central/obj-ff-dbg/dist/NightlyDebug.app/Contents/MacOS/libnss3.dylib +0x371621]
#20: _pthread_body[/usr/lib/system/libsystem_pthread.dylib +0x3268]
#21: _pthread_body[/usr/lib/system/libsystem_pthread.dylib +0x31e5]
(lldb)
(Assignee)

Comment 1

3 years ago
Created attachment 8630869 [details] [diff] [review]
Include init segment range when calling NotifyDataArrived.
(Assignee)

Comment 2

3 years ago
Comment on attachment 8630869 [details] [diff] [review]
Include init segment range when calling NotifyDataArrived.

appears I forgot to use the bz extension between last friday and now
Attachment #8630869 - Flags: review?(cpearce)
(Assignee)

Updated

3 years ago
Assignee: nobody → jyavenard
Attachment #8630869 - Flags: review?(cpearce) → review+
(Assignee)

Comment 4

3 years ago
Comment on attachment 8630869 [details] [diff] [review]
Include init segment range when calling NotifyDataArrived.

Approval Request Comment
[Feature/regressing bug #]: bug 1175768
[User impact if declined]: Under some circumstances, we could trigger an assert or playback will stall.
[Describe test coverage new/current, TreeHerder]: Locally tested
[Risks and why]: Very low. It's an addendum to bug 1175768
[String/UUID change made/needed]: None
Attachment #8630869 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/c051c5b1b045
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42

Comment 6

3 years ago
Setting status flags to reflect affected on Aurora.
status-firefox41: --- → affected

Comment 7

3 years ago
Comment on attachment 8630869 [details] [diff] [review]
Include init segment range when calling NotifyDataArrived.

Approving for uplift on Aurora because low-risk.
Attachment #8630869 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.