Scrolling about:addons page is janky

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Mikel, Unassigned)

Tracking

({perf})

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

1.24 MB, text/plain
Details
2.33 MB, text/plain
Details
(Reporter)

Description

3 years ago
Created attachment 8630974 [details]
profile.json

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150707030206

Steps to reproduce:

1) Open about:addons
2) Smooth scroll the page
3) Observe the jank.

A performance recording confirms a lot time spent on painting and style recalculations.
Attaching the profile recording.


Actual results:

Janky scrolling on about:addons page.


Expected results:

Smooth scrolling on about:addons page.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: perf
Product: Firefox → Core
Can you still reproduce the issue with latest stable Firefox or latest Nightly?
Flags: needinfo?(nissan4321)
(Reporter)

Comment 2

2 years ago
Well, the paints and recalculation styles are almost all gone in a new performance recording from the latest Nighlty, but now there are a lot of GC work with a huge "Non-incremental GC" that takes a whooping ~500 ms also when just staying idle on the addons page (and also when scrolling, which janks APZ scrolling of course)!

Note: this seems (I say seems, as I don't see a visual jank of ~500ms while scrolling with APZ) to happen only when recording a performance recording.
Note2: this seems to happen only on internal pages such as the about:addons page and also a "new tab" page (blank page or non blank, doesn't matter), but NOT on tabs with sites where scrolling is smooth and no such GC work.


Attaching a performance recording when staying idle on the about:addons page, and one with smooth scrolling the page (APZ enabled).
Flags: needinfo?(nissan4321)
(Reporter)

Comment 3

2 years ago
Created attachment 8714012 [details]
profile (idle).json
(Reporter)

Comment 4

2 years ago
Created attachment 8714013 [details]
profile (scrolling).json
(Reporter)

Updated

2 years ago
Attachment #8630974 - Attachment is obsolete: true

Comment 5

2 years ago
Based on comment #2 and the profiles, is this something the JS team can/should look at? mccr8?
Flags: needinfo?(continuation)
Flags: needinfo?(continuation) → needinfo?(terrence)
Moving ni? to Jon.
Flags: needinfo?(terrence) → needinfo?(jcoppeard)
(In reply to Mikel from comment #2)
It's possible that the performance recording triggers extra GCs.  I can see this happening in your supplied profile data, but not for anything like 500ms.

I tried to reproduce this but I don't see any long non-incremental GCs myself.

Since it doesn't seem to happen in normal use I'm going to close this.  Please reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jcoppeard)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.