[Windows 10] The separator displayed next to URLs with EVs attached should be solid

VERIFIED FIXED in Firefox 40

Status

()

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: avaida, Assigned: jaws)

Tracking

(Blocks 1 bug)

40 Branch
Firefox 42
All
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 verified, firefox41 verified, firefox42 verified)

Details

Attachments

(3 attachments)

Reproducible on:
* Nightly 42.0a1 (2015-07-07)
* Aurora 41.0a2 (2015-07-07)
* Beta 40.0b2 (20150706172413)

Affected platforms:
* Microsoft Surface Pro 2 - Windows 10 Pro x64 (Insider Preview Build 10162)

Steps to reproduce:
1. Launch Firefox.
2. Visit https://www.mozilla.org/
3. Check the styling of the separator displayed between the Extended Validation Certificate mark and the URL in the Location Bar.

Expected result:
The separator has a solid styling, as the ones from the tab strip and main toolbar.

Actual result:
The separator styling still reflects the old design.
There are a number of similar P4ish separator bugs, but I'm going to call this one P2 because I've noticed it too, and it seems to jump out at me far more than the others for some reason.
Priority: -- → P2
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Posted patch PatchSplinter Review
I feel pretty strongly that we should just make this separator solid on all platforms. I don't think the gradient here is unique enough to keep per platform, and the gradient feels "old" in terms of modern design elements.
Attachment #8635407 - Flags: review?(dao)
Attachment #8635407 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/0492fa483509
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Blocks: 1180213
Approval Request Comment
[Feature/regressing bug #]: Windows 10 UI changes
[User impact if declined]: separator between identity-box and URL won't match other platform styles
[Describe test coverage new/current, TreeHerder]: none, CSS-only change
[Risks and why]: none
[String/UUID change made/needed]: none
Attachment #8636753 - Flags: approval-mozilla-beta?
Attachment #8636753 - Flags: approval-mozilla-aurora?
Comment on attachment 8636753 [details] [diff] [review]
Patch for Aurora41 and Beta40

Safe to uplift. Approved.
Attachment #8636753 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8636753 [details] [diff] [review]
Patch for Aurora41 and Beta40

Let's get this small change on beta as well. Beta+
Attachment #8636753 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Contact: cornel.ionce
Using a MS Pro 2 device running Windows 10 build 10240 I'm still seeing the old separator on https://www.mozilla.org.
Screenshot: http://i.imgur.com/dKDJoB3.png

Although, on several XUL pages (i.e. about:support) the separator is solid: http://i.imgur.com/x1RfHnO.png

Is there something I'm missing here?
Flags: needinfo?(jaws)
(In reply to Cornel Ionce [QA] from comment #10)
> Using a MS Pro 2 device running Windows 10 build 10240 I'm still seeing the
> old separator on https://www.mozilla.org.
> Screenshot: http://i.imgur.com/dKDJoB3.png
> 
> Although, on several XUL pages (i.e. about:support) the separator is solid:
> http://i.imgur.com/x1RfHnO.png
> 
> Is there something I'm missing here?

Those are both solid, but the background colors are different. This will be changed in Firefox 42 by bug 1186818.
Flags: needinfo?(jaws)
With Comment 11 taken into consideration, this is verified fixed on Beta 40.0b8 (20150727174134) and Nightly 42.0a1 (2015-07-28), using Windows 10 Pro x64 (Build 10240).

A potential issue I noticed on Aurora 41.0a2 (2015-07-28) is that the separator's height is too big on the dark theme, here's a screenshot - http://i.imgur.com/Rfi25GM.png. Jared, is this intended?
(In reply to Andrei Vaida, QA [:avaida] from comment #12)
> With Comment 11 taken into consideration, this is verified fixed on Beta
> 40.0b8 (20150727174134) and Nightly 42.0a1 (2015-07-28), using Windows 10
> Pro x64 (Build 10240).
> 
> A potential issue I noticed on Aurora 41.0a2 (2015-07-28) is that the
> separator's height is too big on the dark theme, here's a screenshot -
> http://i.imgur.com/Rfi25GM.png. Jared, is this intended?

That is not intended. Can you file a separate bug for that, and CC myself and :bgrins?
Flags: needinfo?(jaws)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #13)
> That is not intended. Can you file a separate bug for that, and CC myself
> and :bgrins?
Sure, I've filed Bug 1188901 on this matter. Since it'll be treated separately, I'm closing this one.
Blocks: 1188901
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.