Closed Bug 118167 Opened 18 years ago Closed 18 years ago

Viewing page source takes a lot of time to show it and CPU load is 100%

Categories

(SeaMonkey :: General, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 84707

People

(Reporter: dereck, Assigned: asa)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Windows NT 5.0; U)
BuildID:    2001010303

Viewing page source with syntax highlight takes long time to show it (and "eats" 
CPU power) even on Pentium4/1.5 GHz. Syntax highlight off, and everything is ok.

Other interesting behaviour is that when the source is rendered mouse pointer is 
"jumping" instead of smooth moving, but... when the source is scrolled to the 
bottom - mouse pointer moves ok.

The page size is about 719 KB.

[There are other strange things about this webpage and Mozilla, but not 
connected with this bug]


Reproducible: Always
Steps to Reproduce:
1.Go to http://www.scan.co.uk/allprice.htm
2.Right mouse button -> view page source (be sure 
3.Waaaait...
4.Try to move your mouse pointer...

Actual Results:  Waiting time is long (more than 50 seconds on Pentium 4/1.5 
GHz!).
Mouse pointer "jumps" over source code.
CPU load is 100% when loading page.
Summary: Vieving page source takes a lot of time to show it and CPU load is 100% → Viewing page source takes a lot of time to show it and CPU load is 100%
rjesup, could you possibly profile this?
Dup.  View Source is still slow.  Still needs work.  I'll do a jprof and attach
it to bug 84707

*** This bug has been marked as a duplicate of 84707 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
OK.  The biggest time-sink on this page was fixed in bug 109428.  The
next-biggest one is already covered by bug 98118.  Marking verified as dup of
the tracker bug of view-source perf issues.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.