[Aries-L][Audio Channels] In-Call volume is not being adjusted

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
7 months ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, tracking-b2g:backlog, b2g-master affected)

Details

(Whiteboard: [aries-l-support][Spark])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8631164 [details]
logcat

Description:
When a user is in a call and adjusts the call volume there are no changes in volume that can be heard. the volume bar appear and changes when the volume buttons are pressed but the changes cannot be heard.

Repro Steps:
1) Update a Aries to 20150707205829
2) Call another phone
3) Have audio coming through the phone to the current phone
4) Adjust volume while in call
5) Observe audio as volume is adjusted

Actual:
The audio volume does not change

Expected:
It is expected that the audio changes volume

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150707205829
Gaia: 553e4e281d11500bea702918841f011bfb5405f7
Gecko: 0246d86e619670bf381d45d587e8ab036e7a8db5
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/1298/
See attached: logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Keywords: smoketest
Whiteboard: [aries-l-support][Spark]
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the earliest Aries-l 2.5 build

Environmental Variables:
Device: Aries 2.5
BuildID: 20150616130603
Gaia: 6d941efc270505fcf604a39568248913e256b363
Gecko: f1830a2b6c0e5fbf03e42ce29d13a7ddc01e4d1a
Version: 41.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Result:
The audio volume does not change
[Blocking Requested - why for this release]:
Functional issue that fails smoke tests, regression from kitkat to lollipop.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regression
(Reporter)

Updated

3 years ago
Summary: [Aries][Audio Channels] In-Call volume is not being adjusted → [Aries-L][Audio Channels] In-Call volume is not being adjusted
I think this might be a lower level issue since it's device specific.  Ken, could you find someone to look into this further please?
Flags: needinfo?(kchang)

Comment 4

3 years ago
Hi Alastor, please help. Thanks.
Assignee: nobody → alwu
Flags: needinfo?(kchang)

Comment 5

3 years ago
Hi, Adam,
Where can I get the flashing package file of the Aries?
Thanks.
Flags: needinfo?(aalldredge)
Naoki made it personally for us.
Flags: needinfo?(aalldredge) → needinfo?(nhirata.bugzilla)
1) I had to unzip http://developer.sonymobile.com/downloads/tool/software-binaries-for-aosp-lollipop-android-5-0/ into the b2g project folder (under vendor)
2) I ran ./config.sh aries-l
3) I had to flash a device to lollipop and then create a backup-aries folder via running ./build.sh

My builds can be found here :
https://drive.google.com/a/mozilla.com/folderview?id=0B_0LdM1CVycIfngzZzh2ZlozR1BfejdEUV9MVjBHbGxnUkVUMFNuR3pkcUVGd3Y5T2k5VXM&usp=sharing

The folder inside contains the backup and vendor files I used.
aries_spark.zip is the first build that we used to test.
aries_l_2.zip was the second build we used to test (which resolved a few issues we reported).

Also to note I filed https://bugzilla.mozilla.org/show_bug.cgi?id=1183823 for taskcluster builds.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(alwu)
Hi Adam, 
Just want to double confirm. 
This bug only occurs on Aries-L, not on Aries(kk), right?
Flags: needinfo?(aalldredge)

Comment 9

3 years ago
[QAWANTED] please check it occur on Aries-L only.
Keywords: qawanted
This is only happening on Aries Master on Lollipop

The in call volume is not changing when pressing the volume buttons. 

Device: Aries 2.5
Build ID: 20150728121751
Gaia: 862f0895f3f5a97200601542d99a152a46385a0b
Gecko: c86c8718cf8af63f3d9fe50ede77a4f2e457159c
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


This does not occur on Aries on Master KitKat

The user can change the in call volume while on a call.

Device: Aries 2.5
Build ID: 20150810214003
Gaia: 497fe3f938722b0aa49c93f975fad5d9ed3b0a82
Gecko: 08c257046b51447c4bb144ded0567ed3da74b9d7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Keywords: qawanted

Comment 11

3 years ago
[Triage] Minus because it's hardware dependency issue. We'll leave it open and fix it in the future if necessary.
blocking-b2g: 2.5? → -
(Reporter)

Comment 12

3 years ago
Clearing needinfo request because question was answered by QAWanted.
Flags: needinfo?(aalldredge)
Keywords: smoketest

Comment 13

3 years ago
Free it, because now we have no specific plan to continue L porting.
Assignee: alwu → nobody
Flags: needinfo?(alwu)
[Tracking Requested - why for this release]:
Per comment 13
tracking-b2g: --- → backlog

Comment 15

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.